Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 66

Thread: zypper problem with 13.1x64?

  1. #21
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    ...just verifying identical behavior after reinstall for 13.1: (see end of Konsole dump below)

    Code:
    TYAN4:/home/patti # zypper clean
    All repositories have been cleaned up.
    TYAN4:/home/patti # rpm --rebuilddb
    TYAN4:/home/patti # zypper clean
    All repositories have been cleaned up.
    TYAN4:/home/patti # zypper lr
    # | Alias                     | Name                               | Enabled | Refresh
    --+---------------------------+------------------------------------+---------+--------
    1 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | No      | Yes    
    2 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes    
    3 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes    
    4 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | Yes     | Yes    
    5 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes    
    6 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes    
    7 | repo-source               | openSUSE-13.1-Source               | No      | Yes    
    8 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes    
    9 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes    
    TYAN4:/home/patti # zypper refresh
    Retrieving repository 'openSUSE-13.1-Update-Debug-Non-Oss' metadata ..............................................................[done]
    Building repository 'openSUSE-13.1-Update-Debug-Non-Oss' cache ...................................................................[done]
    Repository 'openSUSE-13.1-Non-Oss' is up to date.
    Repository 'openSUSE-13.1-Oss' is up to date.
    Repository 'openSUSE-13.1-Update' is up to date.
    Repository 'openSUSE-13.1-Update-Non-Oss' is up to date.
    All repositories have been refreshed.
    TYAN4:/home/patti # zypper patch
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 29 NEW packages are going to be installed:
      apper-lang clutter-lang evolution-data-server-lang gdk-pixbuf-lang glib-networking-lang gstreamer-0_10-fluendo-mp3 
      java-1_7_0-openjdk-headless kdeartwork4-wallpapers kdeartwork4-wallpapers-weather kernel-default-devel-3.11.10-21.1 
      kernel-desktop-3.11.10-21.1 kernel-desktop-devel-3.11.10-21.1 kernel-devel-3.11.10-21.1 kernel-source-3.11.10-21.1 
    
    <<snip!!>>
    
      typelib-1_0-WebKit-1_0 udev udev-configure-printer udevmountd udisks udisks2 umbrello upower util-linux vim vim-data vorbis-tools 
      wpa_supplicant x11-tools xalan-j2 xf86-input-vmmouse xf86-video-modesetting xinetd xorg-x11-server xorg-x11-server-extra xscreensaver 
      xscreensaver-data xscreensaver-data-extra yast2 yast2-add-on yast2-iscsi-client yast2-ldap-client yast2-network yast2-nis-client 
      yast2-ruby-bindings yast2-services-manager yast2-storage yast2-trans-en_US yast2-ycp-ui-bindings yelp zip 
    
    799 packages to upgrade, 29 new.
    Overall download size: 950.1 MiB. After the operation, additional 753.4 MiB will be used.
    Continue? [y/n/? shows all options] (y): 
    Do you agree with the terms of the license? [yes/no] (no): yes
    Retrieving package poppler-data-0.4.6-5.1.2.noarch                                               (1/828),   1.4 MiB ( 11.4 MiB unpacked)
    Retrieving: poppler-data-0.4.6-5.1.2.noarch.rpm ..................................................................................[done]
    Retrieving package apache2-doc-2.4.6-6.33.1.noarch                                               (2/828),   2.6 MiB ( 18.0 MiB unpacked)
    Retrieving delta: ./noarch/apache2-doc-2.4.6-6.3.1_6.33.1.noarch.drpm, 165.0 KiB
    Retrieving: apache2-doc-2.4.6-6.3.1_6.33.1.noarch.drpm ...........................................................................[done]
    Applying delta: ./apache2-doc-2.4.6-6.3.1_6.33.1.noarch.drpm .....................................................................[done]
    Retrieving package apache2-example-pages-2.4.6-6.33.1.x86_64                                       (3/828),  40.4 KiB (  373 B unpacked)
    Retrieving: apache2-example-pages-2.4.6-6.33.1.x86_64.rpm ........................................................................[done]
    Retrieving package apparmor-docs-2.8.2-4.13.1.noarch                                             (4/828), 288.2 KiB (411.8 KiB unpacked)
    Retrieving delta: ./noarch/apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm, 22.9 KiB
    Retrieving: apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm .........................................................................[done]
    Applying delta: ./apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm ...................................................................[done]
    Retrieving package at-spi2-atk-common-2.10.2-12.1.x86_64                                           (5/828),  26.6 KiB (  213 B unpacked)
    Retrieving: at-spi2-atk-common-2.10.2-12.1.x86_64.rpm ............................................................................[done]
    Retrieving package digikam-doc-3.5.0-7.3.noarch                                                  (6/828),  19.3 MiB ( 19.9 MiB unpacked)
    Retrieving delta: ./noarch/digikam-doc-3.5.0-4.1_7.3.noarch.drpm, 272.1 KiB
    Retrieving: digikam-doc-3.5.0-4.1_7.3.noarch.drpm ................................................................................[done]
    Applying delta: ./digikam-doc-3.5.0-4.1_7.3.noarch.drpm ..........................................................................[done]
    Retrieving package file-magic-5.15-4.20.1.x86_64                                                 (7/828), 302.8 KiB (  3.3 MiB unpacked)
    Retrieving delta: ./x86_64/file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm, 53.1 KiB
    Retrieving: file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm ........................................................................[done]
    Applying delta: ./file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm ..................................................................[done]
    Retrieving package glibc-2.18-4.21.1.x86_64                                                      (8/828),   1.6 MiB (  6.3 MiB unpacked)
    Retrieving delta: ./x86_64/glibc-2.18-4.4.1_4.21.1.x86_64.drpm, 130.9 KiB
    Retrieving: glibc-2.18-4.4.1_4.21.1.x86_64.drpm ..................................................................................[done]
    Applying delta: ./glibc-2.18-4.4.1_4.21.1.x86_64.drpm ............................................................................[done]
    Retrieving package gnome-control-center-user-faces-3.10.3-18.2.x86_64                            (9/828), 226.1 KiB (114.2 KiB unpacked)
    Retrieving: gnome-control-center-user-faces-3.10.3-18.2.x86_64.rpm ...............................................................[done]
    Retrieving package gtk2-data-2.24.23-7.1.noarch                                                 (10/828),  67.1 KiB (  3.9 KiB unpacked)
    Retrieving: gtk2-data-2.24.23-7.1.noarch.rpm .....................................................................................[done]
    Retrieving package icewm-1.3.7-26.4.1.x86_64                                                   (11/828), 232.0 KiB (1016.2 KiB unpacked)
    Retrieving delta: ./x86_64/icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm, 52.7 KiB
    Retrieving: icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm ................................................................................[done]
    Applying delta: ./icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm ..........................................................................[done]
    Retrieving package kdeartwork4-wallpapers-4.11.5-143.11.noarch                                  (12/828),  77.0 MiB ( 77.5 MiB unpacked)
    Retrieving: kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm .....................................................................[error]
    File './noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a):
    We know the kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm package is there, and that YaST reports a weird proxy error, and I can't seem install anything from the repos, apparently related to the above error, and that 12.3 in an identical box using the same YaST proxy settings is able to update just fine and YaST Proxy throws no errors. So it's not the LAN/Proxy, but perhaps the 13.1 proxy daemon?
    .

  2. #22
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: zypper problem with 13.1x64?

    If you upgrade you need to change the repos and then do a zypper dup

    ie distribution upgrade Just doing an up will not do it. It is probably your problem

  3. #23

    Default Re: zypper problem with 13.1x64?

    On 10/22/2014 04:26 PM, PattiMichelle wrote:
    >
    > ...just verifying identical behavior after reinstall for 13.1: (see end
    > of Konsole dump below)
    >
    >
    > Code:
    > --------------------
    > TYAN4:/home/patti # zypper clean
    > All repositories have been cleaned up.
    > TYAN4:/home/patti # rpm --rebuilddb
    > TYAN4:/home/patti # zypper clean
    > All repositories have been cleaned up.


    One other thing you might want to try is adding a lock for the five
    packages giving you problems and the running your zypper patch.

    <Code>

    zypper al <package name> <package name> ...

    </code>

    Not sure if (in your case) it will produce more issues.

    Ken


  4. #24
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    Quote Originally Posted by gogalthorp View Post
    If you upgrade you need to change the repos and then do a zypper dup

    ie distribution upgrade Just doing an up will not do it. It is probably your problem
    I didn't do an upgrade - this is a bare-metal 13.1x64 install.

  5. #25
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: zypper problem with 13.1x64?

    Ok sorry thought you where upgrading version.


    It is truly odd that the problem only effects some files. Can you go to yast and force the install or does that also give an error

  6. #26
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    Quote Originally Posted by kensch View Post
    On 10/22/2014 04:26 PM, PattiMichelle wrote:
    >
    > ...just verifying identical behavior after reinstall for 13.1: (see end
    > of Konsole dump below)
    >
    >
    > Code:
    > --------------------
    > TYAN4:/home/patti # zypper clean
    > All repositories have been cleaned up.
    > TYAN4:/home/patti # rpm --rebuilddb
    > TYAN4:/home/patti # zypper clean
    > All repositories have been cleaned up.


    One other thing you might want to try is adding a lock for the five
    packages giving you problems and the running your zypper patch.

    <Code>

    zypper al <package name> <package name> ...

    </code>

    Not sure if (in your case) it will produce more issues.

    Ken
    Thank you very much, Ken, I did not think of that. I guess I'm going to have to give up on 13.1 since this isn't converging though I showed that 12.3 works fine but 13.1 has a proxy-daemon(?) issue (identically configured YaST proxy settings work in 12.3 but not in 13.1 when clicking "Test Proxy Settings" button - the 13.1 YaST error which is thrown is shown in previous post on this thread).

    This is a production machine so I guess since this isn't converging I need to install 12.3 and hope for the best with 13.2...

    I did notice issues of different "installability" (hardware support) of 12.3 and 13.1 on some different, recent HP laptops I have. So something is going on within the OS during the 12.x => 13.x changeout which I haven't a clue about. Sad. This has been a great distro.

    Thank you very much everyone for your replies!!

  7. #27
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    Quote Originally Posted by gogalthorp View Post
    Ok sorry thought you where upgrading version.


    It is truly odd that the problem only effects some files. Can you go to yast and force the install or does that also give an error
    Ya - but I don't know what you mean about forcing the install. Also, note that YaST Proxy "Test Proxy Settings" in the 13.1 box fails with the error I posted earlier, but the 12.3 identically-set settings do not fail. Thus, I think it's related to the proxy-handling codebase.

    In my last post I mentioned that I have a couple of different kinds of very recent HP laptops. One kind refuses to boot the 13.1 installer, and the other kind refuses to boot the 12.3 installer. Very weird. Haven't seen anything like this since before OS 10.x. Something is going on in *nix we mere mortals don't know about.

  8. #28
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: zypper problem with 13.1x64?

    I mean go into yast and manually start the install for the problem packages

    As far as I can see you are getting some package and not others from the same repo.

  9. #29
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    Quote Originally Posted by gogalthorp View Post
    I mean go into yast and manually start the install for the problem packages

    As far as I can see you are getting some package and not others from the same repo.
    Yes, I get 855 packages, and 5 fail. But also Test Proxy Settings in the YaST Proxy tool gives this error:
    My guess is they're related. (12.3 YaST proxy does not give this error, and everything is the same except the motherboard/CPU/memory)

    Code:
    * Rebuilt URL to: http://www.novell.com/
    * Adding handle: conn: 0xef2050
    * Adding handle: send: 0
    * Adding handle: recv: 0
    * Curl_addHandleToPipeline: length: 1
    * - Conn 0 (0xef2050) send_pipe: 1, recv_pipe: 0
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    
      0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* About to connect() to proxy proxy.domain.dom port 4319 (#0)
    *   Trying 101.0.114.39...
    * Connected to proxy.domain.dom (101.0.114.39) port 4319 (#0)
    * Proxy auth using Basic with user 'rffry'
    > GET http://www.novell.com/ HTTP/1.1
    > Proxy-Authorization: Basic MTYxWDDGV9Vk
    > User-Agent: curl/7.32.0
    > Host: www.novell.com
    > Accept: */*
    > Proxy-Connection: Keep-Alive
    > 
    < HTTP/1.1 301 Moved Permanently
    < Date: Wed, 22 Oct 2014 18:25:59 GMT
    * Server Apache is not blacklisted
    < Server: Apache
    < Location: http://www.novell.com/home/
    < X-Mag: 6EAD06EADDDDB09;5a386713;71780882;usrLkup->0;usrBase->0;getPRBefFind->0;getPRBefFind->0;PRAfterFind->0;www_root;publicURL->0;FP4->0;
    < Keep-Alive: timeout=2, max=96
    < Content-Type: text/html; charset=iso-8859-1
    < Set-Cookie: lb_novell=OAODEBIJ; Domain=.novell.com; Path=/
    < Content-Length: 377
    < Age: 11
    < Via: 1.1 www.novell.com (Access Gateway-ag-6DDDD6E4F4DDDD09-71522482), 1.1 proxy.domain.dom:4319 (Cisco-IronPort-WSA/7.7.0-753)
    < Connection: keep-alive
    < Proxy-Connection: keep-alive
    < 
    { [data not shown]
    
    10    377  10   377    1     1   1919      0 --:--:-- --:--:-- --:--:--  1922
    * Connection #0 to host proxy.domain.dom left intact
    "Wizard" time. http://foldoc.org/wizard

    Or even a Lord High Fixer.... http://foldoc.org/lord+high+fixer

  10. #30
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: zypper problem with 13.1x64?

    I'd agree if you got none of the packages that it is a proxy/network problem but most of the packages are installed just a short list that do not.

    So what have the packages in common?

    Try another tool Yast

    Try using a browser to go to view and perhaps download the rpms direct

    It could be a bad mirror try changing to another mirror not so close. ( you do know that you get redirected to a mirror close to you when using the default URLs??)

    Wizard class 101

Page 3 of 7 FirstFirst 12345 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •