Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Won't boot to Grub 2

  1. #1

    Default Won't boot to Grub 2

    I've been installed opensuse 13.1 dual boot with windows 7. I set the boot or grub 2 on root partition. When I was rebooting the computer, It 's turned out that it boot into the windows 7 instead the grub 2 one! So, where is the problem?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: Won't boot to Grub 2

    Did you use a MBR set up or a EFI? Sounds like a MBR since you don't install grub to a partition on a EFI machine. If you mixed EFI and MBR then it can be a little difficult to correct it. If this is a relatively new machine it probably has a EFI BIOS . But we can only guess

    Basically you are saying it's broke what is wrong. We need more info then that.

  3. #3

    Default Re: Won't boot to Grub 2

    My take on that is the bootable flag * is still on the windows partition. In your favorite windows os you can probably see that using DISKPART but don't ask me about windows. You can (probably) transfer that bootable flag to your suse partition too using DISKPART or any bootable media eg. dvd/cd.

    Next guess please
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  4. #4

    Default Re: Won't boot to Grub 2

    I'm using MBR

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Won't boot to Grub 2

    Re-run the install and set the grub options like this
    https://dl.dropboxusercontent.com/u/...install/13.png
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Won't boot to Grub 2

    Is it safe to reinstall? I'm afraid it will break the bootsector.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Won't boot to Grub 2

    Quote Originally Posted by Ihsan View Post
    Is it safe to reinstall? I'm afraid it will break the bootsector.
    Yes
    Just use the custom route and select the existing partitions
    Here is a complete walk through
    https://dl.dropboxusercontent.com/u/....1_install.pdf
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Won't boot to Grub 2

    Quote Originally Posted by Ihsan View Post
    I've been installed opensuse 13.1 dual boot with windows 7. I set the boot or grub 2 on root partition. When I was rebooting the computer, It 's turned out that it boot into the windows 7 instead the grub 2 one! So, where is the problem?
    Boot with the 13.1 install DVD.

    But, do not click on Install.

    Instead, 3rd item down should be "Rescue System". Click on that and wait for it to load.

    It will stop with the line

    Rescue login:

    Type (without the quotes) "root" then press Enter.

    You will now see the prompt, probably in a red font:

    Rescue:~#

    Do
    Code:
    fdisk -l
    (that is a lower case "L", not a numeral 1)

    This will list your drives and partitions. Double-check which is the drive that you installed on to make certain you will be using the right drive and right partition when you run commands on the disk. In the following examples, I will use sdX to refer to the drive. You change the X to match your drive with the new Linux installation.

    (ie: If the drive is listed as "sda" then replace the X with a in the following guide.)

    If none of the partitions have the * under the Boot column, then no boot partition has been set. However, I suspect you will find it is set for the Windows partition, and the partition you chose as root ("/") is the one where you want the * in the Boot column. If it is anywhere else, or is not there, you will need to set it.

    I will proceed as if you want to set the second partition (sdX2) as the boot (or "Active") partition (change the sdX2 to the correct one for your root partition in the following commands, if it is different).

    Do:
    Code:
    parted
    You will now have a prompt
    (parted)

    Do:
    Code:
    select /dev/sdX
    (remember to replace the X with the correct letter for your drive)

    You should get a confirmation message that the device is now selected.

    Now, I am going to PRETEND that you have the Linux root partition installed in the second partition. So, I will be using the numeral "2" in the following examples.

    Make sure you change that to match the correct partition that you have Linux root installed in, if it is not in the 2nd partition.

    (However, do not panic if you guess wrong. You can just do this full procedure over again to change the flag to another partition at any time.)

    Do:
    Code:
    set 2 boot
    That is to set/reset the 2nd partition's boot flag.

    It will prompt you with the line New state?

    Do:
    Code:
    on
    When it is confirmed, do:
    Code:
    quit
    You will be back at the Rescue:~# prompt.

    Do:
    Code:
    reboot
    If that was your problem, you should now see the Grub screen.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  9. #9
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Won't boot to Grub 2

    I confirm the standard installer (DVD) didn't set the boot flags correctly, but GRUB2 installation was correct in a similar case.
    Setting the boot flag to the root partition by whatever means (rescue system, GParted, etc.) solved the problem.

  10. #10
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Won't boot to Grub 2

    Quote Originally Posted by OrsoBruno View Post
    I confirm the standard installer (DVD) didn't set the boot flags correctly,
    By default, it will not change the boot flag, if you already have a boot flag set. This is by design.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •