Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Need a wallpaper changer for popular desktops like GNOME, kde, xfce, lxde

  1. #1
    Join Date
    Aug 2011
    Location
    India
    Posts
    249

    Unhappy Need a wallpaper changer for popular desktops like GNOME, kde, xfce, lxde

    In windows there are many wallpaper managers but I think its difficult to find for Linux.

    I have tried variety wallpaper changer but its not working properly.

    Actually my intention is I want an app that will change wallpapers on the popular desktops like GNOME, KDE, xfce and lxde and so can you please suggest the app.
    Regards,
    Rupesh.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,531
    Blog Entries
    15

    Default Re: Need a wallpaper changer for popular desktops like GNOME, kde,xfce, lxde

    On Mon 13 Oct 2014 03:36:01 PM CDT, rupeshforu3 wrote:


    In windows there are many wallpaper managers but I think its difficult
    to find for Linux.

    I have tried variety wallpaper changer but its not working properly.

    Actually my intention is I want an app that will change wallpapers on
    the popular desktops like GNOME, KDE, xfce and lxde and so can you
    please suggest the app.


    Hi
    I'm assuming your using my variety package? In what way is it not
    working properly, specifically the GNOME DE?

    You could write a script to automate changes if there is a specific set
    of wallpapers your wanting to use, in GNOME AFAIK, you can create an
    xml file to do this as well, look at the ones available by default and
    make your own?

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Aug 2011
    Location
    India
    Posts
    249

    Default Re: Need a wallpaper changer for popular desktops like GNOME, kde, xfce, lxde

    In variety app I have added a folder /usr/share/backgrounds to which I have added some wallpapers previously.

    I have followed the above procedure for root account and it worked and after rebooting the system it is not at all working.

    I have followed the same procedure for non root account and it is not at all working.

    Variety app is not working I mean it is showing the same wallpaper all the times.

    During installation I selected 1 click install and during the process I got warning message as nothing provides
    Python-pillow for variety then I selected the option break the dependencies. Even I have installed Python pillow app but no use.

    As I don't know the internals of variety so can you please suggest how to use.
    Regards,
    Rupesh.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,531
    Blog Entries
    15

    Default Re: Need a wallpaper changer for popular desktops like GNOME, kde,xfce, lxde

    On Mon 13 Oct 2014 04:26:01 PM CDT, rupeshforu3 wrote:


    In variety app I have added a folder /usr/share/backgrounds to which I
    have added some wallpapers previously.

    I have followed the above procedure for root account and it worked and
    after rebooting the system it is not at all working.

    I have followed the same procedure for non root account and it is not at
    all working.

    Variety app is not working I mean it is showing the same wallpaper all
    the times.

    During installation I selected 1 click install and during the process I
    got warning message as nothing provides
    Python-pillow for variety then I selected the option break the
    dependencies. Even I have installed Python pillow app but no use.

    As I don't know the internals of variety so can you please suggest how
    to use.**


    Hi
    Make sure you install the version of python-pillow from;
    http://download.opensuse.org/reposit...openSUSE_13.1/

    Open a terminal as your user and run;
    Code:
    variety
    Do you see errors?

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Default Re: Need a wallpaper changer for popular desktops like GNOME, kde, xfce, lxde

    Hi,

    Also you do not select break dependencies and expect a package to work. I only done that when installing a package with zypper with the -d flag which means dowload only
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  6. #6
    Join Date
    Aug 2011
    Location
    India
    Posts
    249

    Lightbulb Re: Need a wallpaper changer for popular desktops like GNOME, kde, xfce, lxde

    installing a package in linux is always difficult for example I have tried to install the package python pillow and it is replying that python imaging conflicts with it and when I try to remove python imaging the package manager is replying that there are many dependencies and the sequence continue endless I think. I am providing the output below

    Code:
    linux-ylea:~ # cd Downloads/
    linux-ylea:~/Downloads # rpm -ivh python-Pillow-2.5.1-26.1.x86_64.rpm
    warning: python-Pillow-2.5.1-26.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID edf0d733: NOKEY
    error: Failed dependencies:
        python-imaging < 2.5.1 conflicts with python-Pillow-2.5.1-26.1.x86_64
    linux-ylea:~/Downloads # rpm -q python-imaging
    python-imaging-1.1.7-18.4.1.x86_64
    linux-ylea:~/Downloads # rpm -evh python-imaging-1.1.7-18.4.1.x86_64
    error: Failed dependencies:
        python-imaging is needed by (installed) python-pyglet-1.1.4-2.2.noarch
        python-imaging is needed by (installed) cinnamon-control-center-2.3.0-4.1.x86_64
        python-imaging is needed by (installed) cinnamon-settings-2.3.0-2.1.x86_64
        python-imaging is needed by (installed) scribus-1.4.4-8.1.x86_64
    linux-ylea:~/Downloads #
    Regards,
    Rupesh.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,531
    Blog Entries
    15

    Default Re: Need a wallpaper changer for popular desktops like GNOME, kde,xfce, lxde

    On Fri 17 Oct 2014 04:56:01 PM CDT, rupeshforu3 wrote:


    installing a package in linux is always difficult for example I have
    tried to install the package python pillow and it is replying that
    python imaging conflicts with it and when I try to remove python imaging
    the package manager is replying that there are many dependencies and the
    sequence continue endless I think. I am providing the output below


    Code:
    --------------------

    linux-ylea:~ # cd Downloads/
    linux-ylea:~/Downloads # rpm -ivh python-Pillow-2.5.1-26.1.x86_64.rpm
    warning: python-Pillow-2.5.1-26.1.x86_64.rpm: Header V3 DSA/SHA1
    Signature, key ID edf0d733: NOKEY error: Failed dependencies:
    python-imaging < 2.5.1 conflicts with python-Pillow-2.5.1-26.1.x86_64
    linux-ylea:~/Downloads # rpm -q python-imaging
    python-imaging-1.1.7-18.4.1.x86_64
    linux-ylea:~/Downloads # rpm -evh python-imaging-1.1.7-18.4.1.x86_64
    error: Failed dependencies:
    python-imaging is needed by (installed) python-pyglet-1.1.4-2.2.noarch
    python-imaging is needed by (installed)
    cinnamon-control-center-2.3.0-4.1.x86_64 python-imaging is needed by
    (installed) cinnamon-settings-2.3.0-2.1.x86_64 python-imaging is needed
    by (installed) scribus-1.4.4-8.1.x86_64 linux-ylea:~/Downloads #

    --------------------


    Hi
    You would need to talk to the cinnamon folks about building the
    python-imaging or using their repo on OBS to build variety.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,954
    Blog Entries
    2

    Default Re: Need a wallpaper changer for popular desktops like GNOME, kde, xfce, lxde

    Depending on how badly you want this app, I see several possible approaches, I'll list some that come to my mind in the order I believe is practical...

    At http://software.opensuse.org/package/python-Pillow
    I see that a version 2.5.3 was compiled for OpenStack. I'd guess that if there are improvements that version will run on "non-OpenStack" just fine so is worth trying.

    Another possible try is that since it appears that you have a more modern version of the library file already installed, you can try installing while "breaking dependencies" -- Maybe it'll work, maybe not.

    From your post, it does appear that a third try which is to install an older version likely leads you down a rathole of replacing additional dependencies with older versions.

    I don't know if the older file was distributed as part of an older version of python, if so another option could be to install the older python and then using something like pyenv run the app... But this is probably an approach someone more experienced with manipulating python environments than me might detail.

    TSU

  9. #9
    Join Date
    Feb 2013
    Location
    Adelaide Hills, Australia
    Posts
    36

    Default Re: Need a wallpaper changer for popular desktops like GNOME, kde, xfce, lxde

    I get the following issue any ideas

    Code:
    variety 
    Traceback (most recent call last):
      File "/usr/bin/variety", line 39, in <module>
        import variety
      File "/usr/lib/python2.7/site-packages/variety/__init__.py", line 49, in <module>
        from variety import VarietyWindow
      File "/usr/lib/python2.7/site-packages/variety/VarietyWindow.py", line 45, in <module>
        from variety.PreferencesVarietyDialog import PreferencesVarietyDialog
      File "/usr/lib/python2.7/site-packages/variety/PreferencesVarietyDialog.py", line 36, in <module>
        from variety.AddPanoramioDialog import AddPanoramioDialog
      File "/usr/lib/python2.7/site-packages/variety/AddPanoramioDialog.py", line 19, in <module>
        from gi.repository import Gtk, WebKit, GObject # pylint: disable=E0611
      File "/usr/lib64/python2.7/site-packages/gi/importer.py", line 68, in load_module
        dynamic_module._load()
      File "/usr/lib64/python2.7/site-packages/gi/module.py", line 287, in _load
        self._introspection_module = get_introspection_module(self._namespace)
      File "/usr/lib64/python2.7/site-packages/gi/module.py", line 266, in get_introspection_module
        module = IntrospectionModule(namespace, version)
      File "/usr/lib64/python2.7/site-packages/gi/module.py", line 117, in __init__
        repository.require(namespace, version)
    gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded
    Enlightenment openSUSE Maintainer

    Development Blog - http://simotek.net/opensuse-e

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Need a wallpaper changer for popular desktops like GNOME, kde, xfce, lxde

    Or in KDE it works out of the box
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •