Results 1 to 2 of 2

Thread: Question about Akonadi won't start

  1. #1
    Join Date
    Sep 2014
    Location
    Ho Chi Minh
    Posts
    13

    Default Question about Akonadi won't start

    Hello, I use kmail and kontact on an almost daily basis but sometime over the past week whenever I try to open either I get the 'Akonadi server is starting' box that just doesn't go away


    Unless I crash it with ctrl-alt-esc it will just stay there doing nothing, yesterday I left it attempting to start for over two hours


    I tried deleting the folder.config/akonadi as was suggested as a fix that worked for someone during my googling on the subject without success, and I've looked for anything akonadi related in /var/log/messages but nothing there


    Any suggestions on what I should be trying to fix this?


    Akonadi must be logging it's activity (and start failures) somewhere, but as I've no idea where it does that I can't really look into what's causing it to fail


    It's suse 11.3 64 bit and other than what the update applet's done there have been no changes made to the system for quite some time, well before this behaviour started
    A Nice day.

  2. #2

    Default Re: Question about Akonadi won't start

    Quote Originally Posted by phanhan View Post
    I tried deleting the folder.config/akonadi as was suggested as a fix that worked for someone during my googling on the subject without success, and I've looked for anything akonadi related in /var/log/messages but nothing there
    It logs to ~/.xsession-errors or ~/.xsession-errors-:0.
    If you run "akonadictl start" in a terminal window, you should see Akonadi's output there.

    Btw, you should be able to stop it with "akonadictl stop", no need to kill it (unless it is stuck of course).

    Any suggestions on what I should be trying to fix this?
    Well, instead of deleting the config, I would rather try deleting/moving the database.
    ~/.local/share/akonadi

    No data should get lost by this, except if there are changes in the database/cache that have not been synchronized yet.
    And you might have to re-setup things like filter destination folders and the accounts' sent-mail, drafts and trash folders, as they are only referenced internally by a numeric id which might change when the database is created from scratch.

    Akonadi must be logging it's activity (and start failures) somewhere, but as I've no idea where it does that I can't really look into what's causing it to fail
    See above.

    It's suse 11.3 64 bit and other than what the update applet's done there have been no changes made to the system for quite some time, well before this behaviour started
    Is it really 11.3?
    Then it's clear that there have been no changes to the system for quite some time, as 11.3 is EOL since 2.5 years...
    Maybe you should consider upgrading to a supported openSUSE version in this case.
    But KMail didn't even use Akonadi back then, only KAddressbook did.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •