Results 1 to 2 of 2

Thread: Raw image from physical node for Virtualization

  1. #1

    Default Raw image from physical node for Virtualization

    Friends -
    I am in process to create a virtual raw image from a physical node. I installed OpenSUse13.1 on a physical instance with 2 GB as root filesystem and 512mb as swap.

    - Installed OpenSuse 13.1 on physical node 2 GB as root filesystem and 512mb as swap. /dev/sda1, /dev/sda2 respectively.
    - Using DD took a raw image
    - Using kvm vm manager (virt-manager) from another node, I tried to spin up the instance using raw image.

    It errors as waiting for device /dev/root to appear and enter into maintenance mode. I have settings in fstab and grub2 to mount using device UUID (also tried device name).

    Further digging, /dev/root is a symlink to /dev/sda1 on physical node. This sym link do not exist on copied image.

    How do I hardcode to mount /dev/sda1 to / .

    PS: I have been creating images from physical nodes for ubuntu,fedora,centos I havent seen this sym link behaviour on any of the other distributions. Please advice.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,447
    Blog Entries
    2

    Default Re: Raw image from physical node for Virtualization

    Quote Originally Posted by turtle510 View Post
    Friends -
    I am in process to create a virtual raw image from a physical node. I installed OpenSUse13.1 on a physical instance with 2 GB as root filesystem and 512mb as swap.

    - Installed OpenSuse 13.1 on physical node 2 GB as root filesystem and 512mb as swap. /dev/sda1, /dev/sda2 respectively.
    - Using DD took a raw image
    - Using kvm vm manager (virt-manager) from another node, I tried to spin up the instance using raw image.

    It errors as waiting for device /dev/root to appear and enter into maintenance mode. I have settings in fstab and grub2 to mount using device UUID (also tried device name).

    Further digging, /dev/root is a symlink to /dev/sda1 on physical node. This sym link do not exist on copied image.

    How do I hardcode to mount /dev/sda1 to / .

    PS: I have been creating images from physical nodes for ubuntu,fedora,centos I havent seen this sym link behaviour on any of the other distributions. Please advice.
    Am I reading your post right that you are trying to run your Guest pointing to the raw Host file system?
    If so, then for starters, you'll need to correctly identify your partitions and mount them accordingly.
    Also, I assume you can avoid all these partition mapping issues by mounting your partitions in an isolated environment like a loop/backing file (the normal way) or I would guess theoretically but haven't done it... in a chroot (or similar). Of course, if you mounted and re-deployed a file system in an isolated environment, you'd normally expect all existing mappings like symlinks would automatically continue to work.

    I would also ask for the reasons behind your somewhat unusual adventure. There are well-trodden paths and recipes for doing P2V conversions and similar (I'm not real big on re-inventing the wheel when there are proven solutions).

    TSU

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •