Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Wifi button light flashing / blinking during network usage (it shouldnt)

  1. #1

    Default Wifi button light flashing / blinking during network usage (it shouldnt)

    So i 've recently gotten a HP G60 laptop that has a built-in Atheros AR242x / AR542x wireless adapter and using the ath5k driver.

    the wifi button shows orange when it's not connected to a network and blue when it is.

    But with openSUSE it flashes constantly between the two colors and sometimes looks purple, whenever the laptop is sending & receiving data.

    I've searched around on a few forums, but most comments are for ubuntu and for config files that aren't in my opensuse install.

    So how can i diable the blinking so the wifi button just stays the same colour ?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,837
    Blog Entries
    15

    Default Re: Wifi button light flashing / blinking during network usage (itshouldnt)

    On Thu 09 Oct 2014 05:56:01 PM CDT, cra1g321 wrote:


    So i 've recently gotten a HP G60 laptop that has a built-in Atheros
    AR242x / AR542x wireless adapter and using the ath5k driver.

    the wifi button shows orange when it's not connected to a network and
    blue when it is.

    But with openSUSE it flashes constantly between the two colors and
    sometimes looks purple, whenever the laptop is sending & receiving data.

    I've searched around on a few forums, but most comments are for ubuntu
    and for config files that aren't in my opensuse install.

    So how can i diable the blinking so the wifi button just stays the same
    colour ?
    Hi
    With the ath5k doesn't look like there is a module option to disable.

    Is there info if you run;
    Code:
    cat /sys/class/leds/ath5k-phy0::rx/trigger
    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3

    Default Re: Wifi button light flashing / blinking during network usage (it shouldnt)

    Code:
    cra1g321@linux:~> cat /sys/class/leds/ath5k-phy0::rx/trigger
    none cpu0 cpu1 cpu2 cpu3 ADP1-online BAT0-charging-or-full BAT0-charging BAT0-full BAT0-charging-blink-full-solid rfkill0 [phy0rx] phy0tx phy0assoc phy0radio

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,837
    Blog Entries
    15

    Default Re: Wifi button light flashing / blinking during network usage (itshouldnt)

    On Thu 09 Oct 2014 06:26:01 PM CDT, cra1g321 wrote:
    Code:
    cra1g321@linux:~> cat /sys/class/leds/ath5k-phy0::rx/trigger
    none cpu0 cpu1 cpu2 cpu3 ADP1-online BAT0-charging-or-full BAT0-charging BAT0-full BAT0-charging-blink-full-solid rfkill0 [phy0rx] phy0tx phy0assoc phy0radio
    Hi
    Ok, so [phy0rx] is selected, try as root user;
    Code:
    echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
    echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Default Re: Wifi button light flashing / blinking during network usage (itshouldnt)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Ok, so [phy0rx] is selected, try as root user;
    Code:
    echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
    echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
    No difference, thanks for the help so far.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,837
    Blog Entries
    15

    Default Re: Wifi button light flashing / blinking during network usage (itshouldnt)

    Quote Originally Posted by cra1g321 View Post
    No difference, thanks for the help so far.
    Hi
    So if you re run the cat command, did it change?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: Wifi button light flashing / blinking during network usage (itshouldnt)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So if you re run the cat command, did it change?
    I entered both those lines, opened a new webpage and it still was flashing,

    rebooted the laptop and still was flashing during network input/ouput.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,837
    Blog Entries
    15

    Default Re: Wifi button light flashing / blinking during network usage (itshouldnt)

    On Thu 09 Oct 2014 07:46:01 PM CDT, cra1g321 wrote:


    malcolmlewis;2668627 Wrote:
    > Hi
    > So if you re run the cat command, did it change?


    I entered both those lines, opened a new webpage and it still was
    flashing,

    rebooted the laptop and still was flashing during network input/ouput.


    Hi
    If you run;
    Code:
    cat /sys/class/leds/ath5k-phy0::rx/trigger
    Then;
    Code:
    echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
    echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
    Then;
    Code:
    cat /sys/class/leds/ath5k-phy0::rx/trigger
    Does it change from [phy0rx] to [none]?

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  9. #9

    Default Re: Wifi button light flashing / blinking during network usage (itshouldnt)

    Code:
    linux:~ # cat /sys/class/leds/ath5k-phy0::rx/trigger
    none cpu0 cpu1 cpu2 cpu3 ADP1-online BAT0-charging-or-full BAT0-charging BAT0-full BAT0-charging-blink-full-solid rfkill0 [phy0rx] phy0tx phy0assoc phy0radio 
    linux:~ # echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
    linux:~ # echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
    linux:~ # cat /sys/class/leds/ath5k-phy0::rx/trigger
    [none] cpu0 cpu1 cpu2 cpu3 ADP1-online BAT0-charging-or-full BAT0-charging BAT0-full BAT0-charging-blink-full-solid rfkill0 phy0rx phy0tx phy0assoc phy0radio 
    linux:~ #

    It's stopped flashing !!! woohoo !!
    going to reboot and see if it stays like this.

    ** UPDATE **

    rebooted and its flashing again :/

    after rebooting and logging in again, i did the first command, the one that has "tx" then loaded youtube and it flashed still,
    then i did the second command and it stopped flashing.

    hope this helps you think of a solution.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,837
    Blog Entries
    15

    Default Re: Wifi button light flashing / blinking during network usage (it shouldnt)

    Hi
    OK, so we can turn that into a systemd service file so it runs at boot.

    Create a text file called ath5knoled.service from below and copy it (as root user) to /etc/systemd/system/

    Code:
    # /etc/systemd/system/ath5knoled.service
    #
    
    [Unit]
    Description=Disable flashing leds with ath5k module
    After=syslog.target
    
    [Service]
    Type=oneshot
    ExecStart=/bin/sh -c "/usr/bin/echo none > \"/sys/class/leds/ath5k-phy0::tx/trigger\""
    ExecStart=/bin/sh -c "/usr/bin/echo none > \"/sys/class/leds/ath5k-phy0::rx/trigger\""
    
    [Install]
    WantedBy=multi-user.target
    Then lets test to see if it works;
    Code:
    systemctl start ath5knoled.service
    systemctl status ath5knoled.service
    If it exits with success, then enable the service and reboot to test;
    Code:
    systemctl enable ath5knoled.service
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •