Results 1 to 7 of 7

Thread: inconsistent icons in KDE menu and yast

  1. #1

    Default inconsistent icons in KDE menu and yast

    I've installed and changed the icon to 'compass icon', but the icons didn't show up correctly in the menu(application launcher).

    OK, that's fine. But ...

    some icons didn't change correctly. And in kubuntu, icons just display correctly.
    Also, the icons in yast do not changed. So is there anyway can fix this proplem.
    PS:As this is my first thread posted, please figure out the problem where i'm wrong or the inappropriate format. And sorry for my poor English.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,646

    Default Re: inconsistent icons in KDE menu and yast

    log out log back in maybe??

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: inconsistent icons in KDE menu and yast

    Welcome first poster.

    Please always tell which version of openSUSE you use. And when you use a more recent version of any software (in this case maybe KDE) you ask about, also tell us.
    Henk van Velden

  4. #4

    Default Re: inconsistent icons in KDE menu and yast

    Quote Originally Posted by gogalthorp View Post
    log out log back in maybe??
    Still, it doesn't work...

  5. #5

    Default Re: inconsistent icons in KDE menu and yast

    Quote Originally Posted by hcvv View Post
    Welcome first poster.

    Please always tell which version of openSUSE you use. And when you use a more recent version of any software (in this case maybe KDE) you ask about, also tell us.
    I'm using openSUSE 13.1. The KDE version is 4.11.5.

  6. #6

    Default Re: inconsistent icons in KDE menu and yast

    Sounds like this:
    https://bugzilla.opensuse.org/show_bug.cgi?id=858426

    In short, it seems the icon theme you use doesn't name the category icon files the way the openSUSE menu structure expects them.
    Whether this is a bug in openSUSE or in the icon theme I don't want to judge.

    I see the following workarounds:
    - Run the menu editor (right-click on the K-Menu and select "Edit menu entries") and manually change the icons to what you like
    - Rename the icon theme's file names accordingly or create corresponding symlinks
    - Edit the files in /usr/share/desktop-directories/ (those define the menu subdirectories including their icons) to use the "correct" icons from your theme. To not have your changes lost on updates, you should copy the file(s) to ~/.local/share/desktop-directories/ first and edit it there. (this is in effect the same thing as point 1)
    Last edited by wolfi323; 10-Oct-2014 at 01:24.

  7. #7

    Default Re: inconsistent icons in KDE menu and yast

    Quote Originally Posted by wolfi323 View Post
    Sounds like this:
    https://bugzilla.opensuse.org/show_bug.cgi?id=858426

    In short, it seems the icon theme you use doesn't name the category icon files the way the openSUSE menu structure expects them.
    Whether this is a bug in openSUSE or in the icon theme I don't want to judge.

    I see the following workarounds:
    - Run the menu editor (right-click on the K-Menu and select "Edit menu entries") and manually change the icons to what you like
    - Rename the icon theme's file names accordingly or create corresponding symlinks
    - Edit the files in /usr/share/desktop-directories/ (those define the menu subdirectories including their icons) to use the "correct" icons from your theme. To not have your changes lost on updates, you should copy the file(s) to ~/.local/share/desktop-directories/ first and edit it there. (this is in effect the same thing as point 1)
    That needs to do a lot of thing..I'll just leave it alone..Any way,thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •