Results 1 to 4 of 4

Thread: what I have to do with libkdevplatform7-1.6.0-13.8.x86_64 requires kdevplatform

  1. #1

    Default what I have to do with libkdevplatform7-1.6.0-13.8.x86_64 requires kdevplatform

    I'm updating opensuse 13.1 and have this error:
    Code:
    #### YaST2 conflicts list - generated 2014-10-04 19:21:56 ####
    
    libkdevplatform7-1.6.0-13.8.x86_64 requires kdevplatform = 1.6.0, but this requirement cannot be provided
    deleted providers: kdevplatform-1.6.0-13.8.x86_64
        [ ] do not install kdevplatform-1.7.0-14.3.x86_64
    
        [ ] Following actions will be done:
    deinstallation of libkdevplatform7-1.6.0-13.8.x86_64
    deinstallation of kdevelop4-plugin-qmake-1.7.60git.1407324868-29.3.x86_64
    deinstallation of kdevelop4-plugin-cppsupport-4.7.60git.1409010820-105.7.x86_64
    downgrade of kdevelop4-4.7.60git.1409010820-105.7.x86_64 to kdevelop4-4.7.0-11.3.x86_64
    install kdevelop4-4.7.0-11.3.x86_64 (with vendor change)
      obs://build.opensuse.org/KDE:Unstable  -->  obs://build.opensuse.org/KDE
    deinstallation of kdevelop4-plugin-qmake-lang-1.7.60git.1407324868-29.3.noarch
        [ ] break libkdevplatform7-1.6.0-13.8.x86_64 by ignoring some of its dependencies
    
    
    
    kdevplatform-lang-1.7.0-14.3.noarch requires kdevplatform = 1.7.0, but this requirement cannot be provided
    uninstallable providers: kdevplatform-1.7.0-14.3.i586[KDE_extra_current_13.1]
                       kdevplatform-1.7.0-14.3.x86_64[KDE_extra_current_13.1]
        [ ] break kdevplatform-lang-1.7.0-14.3.noarch by ignoring some of its dependencies
    
        [ ] do not install kdevplatform-lang-1.7.0-14.3.noarch
    
        [ ] do not install kdevplatform-lang-1.7.0-14.3.noarch
    
        [ ] Following actions will be done:
    downgrade of libkdevplatform8-1.7.60git.1408971948-100.3.x86_64 to libkdevplatform8-1.7.0-14.3.x86_64
    install libkdevplatform8-1.7.0-14.3.x86_64 (with vendor change)
      obs://build.opensuse.org/KDE:Unstable  -->  obs://build.opensuse.org/KDE
    deinstallation of kdevelop4-plugin-qmake-1.7.60git.1407324868-29.3.x86_64
    deinstallation of kdevelop4-plugin-cppsupport-4.7.60git.1409010820-105.7.x86_64
    downgrade of kdevelop4-4.7.60git.1409010820-105.7.x86_64 to kdevelop4-4.7.0-11.3.x86_64
    install kdevelop4-4.7.0-11.3.x86_64 (with vendor change)
      obs://build.opensuse.org/KDE:Unstable  -->  obs://build.opensuse.org/KDE
    deinstallation of kdevelop4-plugin-qmake-lang-1.7.60git.1407324868-29.3.noarch
    
    
    
    #### YaST2 conflicts list END ###
    choosing n2 for the first at the end remain only the downgrade..
    what I have to do???
    manythanks :-) :-) ciao :-) pier

  2. #2

    Default Re: what I have to do with libkdevplatform7-1.6.0-13.8.x86_64 requires kdevplatform

    Quote Originally Posted by pier_andreit View Post
    I'm updating opensuse 13.1 and have this error:
    ...
    choosing n2 for the first at the end remain only the downgrade..
    what I have to do???
    You obviously have kdevelop installed which requires libkdevplatform7.
    But the version you have installed (which is an unstable development version btw) is not available in any repo any more that I know of.
    (KDE:Unstable:Extra and KDE:Extra both contain libkdevplatform8, so the kdevelop and kdevplatform in there should require this)

    So I would recommend to indeed downgrade to the stable version from KDE:Extra (i.e. Solution 2 in the first conflict), or uninstall kdevelop completely if you do not need/want it.

  3. #3

    Default Re: what I have to do with libkdevplatform7-1.6.0-13.8.x86_64 requires kdevplatform

    Quote Originally Posted by wolfi323 View Post
    You obviously have kdevelop installed which requires libkdevplatform7.
    But the version you have installed (which is an unstable development version btw) is not available in any repo any more that I know of.
    (KDE:Unstable:Extra and KDE:Extra both contain libkdevplatform8, so the kdevelop and kdevplatform in there should require this)

    So I would recommend to indeed downgrade to the stable version from KDE:Extra (i.e. Solution 2 in the first conflict), or uninstall kdevelop completely if you do not need/want it.
    ...manythanks, :-) as I don't remember why I installed kdevelop from the unstable..., so I have sometimes doubts to downgrade, but as I understood the downgrade isn't referred to the installed version but to the needed..

  4. #4

    Default Re: what I have to do with libkdevplatform7-1.6.0-13.8.x86_64 requires kdevplatform

    Quote Originally Posted by pier_andreit View Post
    but as I understood the downgrade isn't referred to the installed version but to the needed..
    Hm?
    Of course the downgrade referred to the _installed_ version.
    You had kdevelop4-4.7.60git.1409010820-105.7.x86_64 installed, and you should have the stable kdevelop4-4.7.0-11.3.x86_64 instead after the downgrade.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •