Results 1 to 4 of 4

Thread: postgresql does not run on openSUSE 13.1, maybe missing password

  1. #1
    Join Date
    Nov 2009
    Location
    India
    Posts
    52

    Default postgresql does not run on openSUSE 13.1, maybe missing password

    I have been trying to run postgresql server on the first time on my PC. It actually had a prior installation but I removed it and reinstalled it.


    Now my pg_hba and postgresql.conf files can be found here..
    http://paste.opensuse.org/14045101
    http://paste.opensuse.org/29265877

    Whenever, I run su postgres -c psql postgres, it asks for a password, I am not sure what should I enter over here.
    Is there a default password or is there a way to reset the password again.

    HTML Code:
    _______@linux-x4vi:~/Downloads> su postgres -c psql postgres
    Password: 
    su: Authentication failure
    
    I also do not remember creating a user named postgres as can be seen here.

    drwxr-x--- 4 postgres postgres 4096 Sep 22 12:36 .
    drwxr-xr-x 49 root root 4096 Sep 22 12:30 ..
    -rw------- 1 postgres postgres 332 Aug 22 14:59 .bash_history
    -rw-r----- 1 postgres postgres 192 Feb 28 2014 .bash_profile
    drwxr-xr-x 3 postgres postgres 4096 Aug 12 15:14 .local
    -rw------- 1 postgres postgres 109 Aug 13 11:08 .psql_history
    drwx------ 15 postgres postgres 4096 Sep 22 15:10 data
    -rw-r--r-- 1 postgres postgres 1228 Aug 12 15:14 initlog
    Manu Gupta
    Manipal Institute Of Technology
    Manipal, Karnataka - 576104
    India

  2. #2
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    431

    Default Re: postgresql does not run on openSUSE 13.1, maybe missing password

    I'm not completely up on everything, but shouldn't you be using something like:

    Code:
    sudo systemctl start postgres.service
    or
    Code:
    su systemctl start postgres.service
    "Making rich people richer doesn't make the rest of us richer."
    Ha-Joon Chang

    openSUSE 15.0 4.12.14-lp150.12.45-default x64

  3. #3
    Join Date
    Nov 2009
    Location
    India
    Posts
    52

    Default Re: postgresql does not run on openSUSE 13.1, maybe missing password

    Quote Originally Posted by kerijan2003 View Post
    I'm not completely up on everything, but shouldn't you be using something like:

    Code:
    sudo systemctl start postgres.service
    or
    Code:
    su systemctl start postgres.service

    Oh Yeah, I had already started the postgressql server as a service
    Manu Gupta
    Manipal Institute Of Technology
    Manipal, Karnataka - 576104
    India

  4. #4
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    431

    Default Re: postgresql does not run on openSUSE 13.1, maybe missing password

    Yes, but you may have started it with the wrong command set.
    You used the following:

    Code:
    su postgres -c psql postgres
    and it seems to me you shouldn't start it that way anymore.

    Can someone else jump in and advise?
    "Making rich people richer doesn't make the rest of us richer."
    Ha-Joon Chang

    openSUSE 15.0 4.12.14-lp150.12.45-default x64

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •