Results 1 to 6 of 6

Thread: Dependency problem with recent gstreamer update.

  1. #1

    Default Dependency problem with recent gstreamer update.

    Hi,

    I'm new to Linux and OpenSUSE.

    System updater recently proposed to install several gstreamer packages, but it reports the following dependency problem:

    "nothing provides libpng15.so.15()(64bit) needed by gstreamer-0_10-plugins-bad-0.10.23 "

    I couldn't find any alternative vendors for the package, so the question is how to resolve this.

    Will appreciate any help with this

    Kind regards,
    Ivan

  2. #2

    Default AW: Dependency problem with recent gstreamer update.

    Quote Originally Posted by imartynau View Post
    I couldn't find any alternative vendors for the package, so the question is how to resolve this.
    Well, which vendor are you actually using, and which openSUSE version anyway?

    Please post your repo list:
    Code:
    zypper lr -d
    My guess would be that you added some repo for 12.3 to a 13.1 system, and the updater tries to install the packages from there.
    12.3 shipped with libpng15, 13.1 has libpng16 instead. Any package for 13.1 should therefore require libpng16, not libpng15.
    Last edited by wolfi323; 22-Sep-2014 at 12:06.

  3. #3
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: Dependency problem with recent gstreamer update.

    Could you open a terminal and post the results of the following command, please encase the output in CODE blocks (# in the editor toolbar here in the forums):
    zypper lr -d

    You can run it in a terminal as the normal user.

    Edit:
    Daym Wolfie, you fast.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  4. #4

    Default Re: AW: Dependency problem with recent gstreamer update.

    Thank you for the quick replies:

    I'm using 13.1.

    Here's the repo list. And your hunches proved right the repo at 5 (packman), which I set when then there were problems with the Packman at 2, is for 12.3. This is where the update is coming from. So, should I just disable the packman repo at 5?

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------+--------
    1 | Bumblebee | Bumblebee | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/
    2 | Packman Repository I Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.1/
    3 | home:gottcode | home:gottcode | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/
    4 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/
    5 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_12.3/
    6 | repo-debug | openSUSE-13.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.1/repo/oss/
    7 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1/
    8 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/
    9 | repo-non-oss | openSUSE-13.1-Non-Oss | Yes | Yes | 99 | NONE | http://download.opensuse.org/distrib.../repo/non-oss/
    10 | repo-oss | openSUSE-13.1-Oss | Yes | Yes | 99 | NONE | http://download.opensuse.org/distrib...13.1/repo/oss/
    11 | repo-source | openSUSE-13.1-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...13.1/repo/oss/
    12 | repo-update | openSUSE-13.1-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    13 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/ |

  5. #5

    Default Re: Dependency problem with recent gstreamer update.

    Quote Originally Posted by imartynau View Post
    So, should I just disable the packman repo at 5?
    Yes, definitely. Or better remove it completely.

    You can use the packman.inode.at mirror of course, but you should then use the correct URL for 13.1:
    http://packman.inode.at/suse/openSUSE_13.1/

  6. #6

    Default Re: Dependency problem with recent gstreamer update.

    Thank you!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •