Results 1 to 5 of 5

Thread: can't install zlib/libz

  1. #1

    Default can't install zlib/libz

    Hello,

    I'm on opensuse 13.1, and I'm in the process of installing openssh.

    But, when I run the opensuse "configure" , I get:
    ...
    checking...
    configure: error: *** zlib missing - please install first ***

    So, I tried to install zlib, but I get :

    >rpm -i zlib-1.2.5_git201105272030-20.1.4.x86_64.rpm
    error: Failed dependencies:
    zlib < 1.2.8-3.1.2 is obsoleted by (installed) libz1-1.2.8-3.1.2.x86_64

    I tried to find the libz command , but no luck.
    I did see the libz.so files in /lib64 , but I can't find the rpm that it seems to say is already installed.
    How does one install zlib ?

    Thanks

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,002

    Default Re: can't install zlib/libz

    First of all, openssh is included with openSUSE, second of all you don't install packages directly with RPM unless absolutely necessary but instead use the package manager;

    zypper in openssh
    systemctl enable sshd
    systemctl start sshd

    Will start and enable the ssh daemon. Which is installed by default on any normal system, merely not enabled or started by default.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: can't install zlib/libz

    thanks. I think that worked - I now see the openssh process.

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,002

    Default Re: can't install zlib/libz

    For future reference, you can find applications to install by using;

    zypper se something
    Where you replace something with the name of the application you wish to find or part of the name.

    zypper se -d something
    Will search for something and includes the description instead of just searching for the filename.

    zypper in something
    Will install something and all dependencies that it needs.

    Remember if you need to access the service from the outside, you need to open port 22 in the firewall. With that in mind, remember to have a strong password and prevent root login from the outside.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  5. #5

    Default Re: can't install zlib/libz

    awesome. thanks for the bonus info.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •