Results 1 to 2 of 2

Thread: Openbox - autostart not running and menu.xml not working

  1. #1

    Default Openbox - autostart not running and menu.xml not working

    I'm having two issues with openbox on openSUSE 13.1. I have an autostart file in ~/.config/openbox and it's not executing at all on startup. My autostart read:

    Code:
    # Programs that will run after Openbox has started
    
    # Set the wallpaper
    nitrogen &
    
    # A panel for good times
    tint2 &
    
    conky &
    Also, I like how the menu is autogenerated based on what is installed. However, I want to add items at the top of the menu for my most frequently used programs. But my menu.xml is not being read. I used obmenu to generate it, and my menu.xml reads:

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <menu id="ob-menu" label="Openbox Preferences">
        <menu id="None-22934" label="New Menu">
            <item label="Terminal">
                <action name="Execute">
                    <execute>xfce4-terminal</execute>
                </action>
            </item>
            <item label="Firefox">
                <action name="Execute">
                    <execute>Firefox</execute>
                </action>
            </item>
            <item label="File Manager">
                <action name="Execute">
                    <execute>thunar</execute>
                </action>
            </item>
        </menu>
    </menu>
    Any help would be greatly appreciated.

  2. #2
    Taki NNTP User

    Default Re: Openbox - autostart not running and menu.xml not working

    On 21/09/14 10:06 AM, DupermanDave wrote:
    ....
    .... my menu.xml reads:
    ....
    > <?xml version="1.0" encoding="utf-8"?>
    > <menu id="ob-menu" label="Openbox Preferences">
    > <menu id="None-22934" label="New Menu">
    > <item label="Terminal">
    > <action name="Execute">
    > <execute>xfce4-terminal</execute>
    > </action>
    > </item>
    > <item label="Firefox">
    > <action name="Execute">
    > <execute>Firefox</execute>
    > </action>
    > </item>
    > <item label="File Manager">
    > <action name="Execute">
    > <execute>thunar</execute>
    > </action>
    > </item>
    > </menu>
    > </menu>


    My 'menu.xml':

    <?xml version="1.0" encoding="UTF-8"?>

    <openbox_menu xmlns="http://openbox.org/3.4/menu">

    <menu id="apps-menu" label="Applications" execute="openbox-pipemenu" />
    <menu id="ob-menu" label="Openbox Preferences">
    <item label="Openbox Configuration Manager">
    <action name="Execute">
    <command>obconf</command>
    <startupnotify><enabled>yes</enabled></startupnotify>
    </action>
    </item>
    <item label="Reconfigure Openbox">
    <action name="Reconfigure" />
    </item>
    </menu>

    <menu id="root-menu" label="Openbox 3">
    <separator label="Openbox 3" />
    <item label="UXTerm">
    <action name="Execute">
    <command>uxterm</command>
    </action>
    </item>
    <item label="Firefox">
    <action name="Execute">
    <command>firefox</command>
    </action>
    </item>
    <item label="Dolphin">
    <action name="Execute">
    <command>dolphin</command>
    </action>
    </item>
    <item label="Thunderbird">
    <action name="Execute">
    <command>thunderbird</command>
    </action>
    </item>
    <menu id="apps-menu" />
    <separator />
    <item label="Edit this menu">
    <action name="Execute">
    <command>gvim ~/.config/openbox/menu.xml</command>
    </action>
    </item>
    <separator />
    <menu id="ob-menu" />
    <separator />
    <item label="Log Out">
    <action name="Exit">
    <prompt>yes</prompt>
    </action>
    </item>
    </menu>

    </openbox_menu>

    I seem to recall that I had a similar problem: the menu layout /
    template changed some time ago. Pay attention to where sub-menus go,
    especially 'root-menu'. Follow the pattern, you'll be OK.

    When I click for menu, the pop-up menu box has a label at the top
    'Openbox 3', then
    'UXTerm',
    'Firefox',
    'Dolphin',
    'Thunderbird',
    'Applications' with an arrow to indicate a sub-menu,
    separator,
    'Edit this menu' (I use this this to edit, well, the menu itself),
    separator,
    'Openbox Preferences' with an arrow for a sub-menu,
    separator,
    'Log Out'

    As for 'autostart', I have no idea what the problem is. It should work.
    Was the file renamed 'Autostart'?



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •