Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Apache : permission error after install

  1. #1

    Default Apache : permission error after install

    Hello,

    I installed apache2 and mariadb by using Yast.
    But after installation I use Yast to make apache run, goto 127.0.0.1 and see then a permission denied error.

    How to solve this ?

    Roelof

  2. #2

    Default Re: Apache : permission error after install

    Quote Originally Posted by snowman1967 View Post
    I installed apache2 and mariadb by using Yast.
    But after installation I use Yast to make apache run, goto 127.0.0.1 and see then a permission denied error.

    How to solve this ?
    Some more information, please? Like the openSUSE version you use?

    Have you even started Apache, and how?

    What does "systemctl status apache2" say?
    Last edited by wolfi323; 15-Sep-2014 at 10:33.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Apache : permission error after install

    "Going to 127.0.0.1" (which probably means you use 127.0.0.1 as an URL in a browser on the system), will try to show you the file index.html from the server root. Which is /srv/www/htdocs/ (if you did not change the default Apache configuration).

    Thus why not look there
    Code:
    ls -l /srv/www/htdocs/index.html
    to see if that file exists and when yes, who owns it (user/group) and what the permissions are?
    Henk van Velden

  4. #4

    Default Re: Apache : permission error after install

    Quote Originally Posted by hcvv View Post
    "Going to 127.0.0.1" (which probably means you use 127.0.0.1 as an URL in a browser on the system), will try to show you the file index.html from the server root. Which is /srv/www/htdocs/ (if you did not change the default Apache configuration). Thus why not look there
    Code:
    ls -l /srv/www/htdocs/index.html
    to see if that file exists and when yes, who owns it (user/group) and what the permissions are?
    This directory contains this :

    drwxr-xr-x 3 root root 4096 Nov 6 2013 .
    drwxr-xr-x 5 root root 4096 Nov 6 2013 ..
    drwxr-xr-x 2 root root 4096 Nov 6 2013 gif
    -rw-r--r-- 1 root root 2356 Sep 28 2013 info2html.css


    Roelof

  5. #5

    Default Re: Apache : permission error after install

    Quote Originally Posted by snowman1967 View Post
    This directory contains this :

    drwxr-xr-x 3 root root 4096 Nov 6 2013 .
    drwxr-xr-x 5 root root 4096 Nov 6 2013 ..
    drwxr-xr-x 2 root root 4096 Nov 6 2013 gif
    -rw-r--r-- 1 root root 2356 Sep 28 2013 info2html.css
    Well, as you can see yourself, there is no index.html.
    How would you expect Apache to serve you one then?

    So either create one yourself, or install the package "apache2-example-pages" to get a simple one.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Apache : permission error after install

    As wolfi323 said. Web sites are not created out of the blue. I assume that when you want to run a web-server program (Apache), you have something to show to the world (or a smaller audience).

    And please, when posting computer output (copied/pasted from your terminal window), do so between CODE tags. You get them by clicking on the # button in the tool bar of the post editor.

    Also, please do not say things like: "This directory contains this :". Post the prompt, the command, the output and the next prompt. Then we can see what you did (and more) without you explaining it.
    Last edited by hcvv; 15-Sep-2014 at 11:11.
    Henk van Velden

  7. #7

    Default Re: Apache : permission error after install

    Quote Originally Posted by hcvv View Post
    As wolfi323 said. Web sites are not created out of the blue. I assume that when you want to run a web-server program (Apache), you have something to show to the world (or a smaller audience).

    And please, when posting computer output (copied/pasted from your terminal window), do so between CODE tags. You get them by clicking on the # button in the tool bar of the post editor.

    Also, please do not say things like: "This directory contains this :". Post the prompt, the command, the output and the next prompt. Then we can see what you did (and more) without you explaining it.

    Thanks,

    Last question.

    I have to make a new virtual host or change the current host so it points to /srv/www/laravel/public instead of /src/www
    According to the manual I can do this with Yast -> Network Services -> http-server But tI do not have the choice ht-server.
    I work with the lastest Opensue version.

    Roelof

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Apache : permission error after install

    Quote Originally Posted by snowman1967 View Post
    Thanks,

    Last question.

    I have to make a new virtual host or change the current host so it points to /srv/www/laravel/public instead of /src/www
    According to the manual I can do this with Yast -> Network Services -> http-server But tI do not have the choice ht-server.
    I work with the lastest Opensue version.

    Roelof
    I might misunderstand what you want, but your earlier post showed that there is no /srv/www/laravel/, let alone a /srv/www/laravel/public.

    You can however change your server root in your Apache configuration file(s). I assume you know where to find them and how to handle them. Else you could maybe tell more about what you want. In other words describe the goal, not the step (http://www.catb.org/~esr/faqs/smart-questions.html#goal).
    Henk van Velden

  9. #9

    Default Re: Apache : permission error after install

    Quote Originally Posted by hcvv View Post
    I might misunderstand what you want, but your earlier post showed that there is no /srv/www/laravel/, let alone a /srv/www/laravel/public.

    You can however change your server root in your Apache configuration file(s). I assume you know where to find them and how to handle them. Else you could maybe tell more about what you want. In other words describe the goal, not the step (http://www.catb.org/~esr/faqs/smart-questions.html#goal).
    Correct, this ia a new question but related to the old one.

    I have installed laravel according to the manual of the site of laravel.

    Now what I want to achieve is that if I type localhost or 127.0.0.1 I see the page which can be found at this url : srv/www/larael/public.

    I know how to change them if I know where Opensuse has placed the file.
    If I look at this page : https://www.suse.com/documentation/s...iguration.html
    That page is stated I could do that with Yast but on my Yast there is no option http-server.

    Roelof

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Apache : permission error after install

    Look in /etc/apache2/default-server.conf.
    Henk van Velden

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •