Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video tearing)

  1. #1

    Default Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video tearing)

    • Last week my gpu died and I replaced it with a Nvidia GT 640 card. Normally this card should be more than capable of playing video smoothly
    • I have the latest proprietary drivers installed (GO3 from the repos).
    • When playing videos (tried sevaral) I noticed an annoying horizontal video tearing and my wobbly windows effect is not very smooth.
    • Now comes the strange part. When I either stop and start kwin, or change from opengl 3.1 to opengl 2.0 (or vice versa) in the kde desktop effects settings (probably causing a kwin restart?), the video tearing is gone and effects like wobbly windows are smooth again.
    • After a reboot or logoff the video tearing and unsmooth effects are back. I have to do my little trick each boot which is very annoying.
    • So it seems that kde is not using my gpu correctly somehow, until I restart the kde desktop effects.


    Does anyone have any clue what could trigger this problem and how to solve it?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,890

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video tearin

    What after a logout/login instead of a reboot. Does that also reintroduce the problem?
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,954
    Blog Entries
    2

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video tearin

    1. You need to describe the version of openSUSE

    2. Is this a new install or an upgrade from a previous version? In an upgrade, I discovered to my dismay that when the upgrade also changed from an nVidia to Intel GPU, there was a little-documented "feature" somewhere in /etc? (I don't remember where at the moment, but is deep in my postings) where there was a "monitor" setting still pointing to nVidia which invalidated loading the Intel GPU drivers correctly.

    BTW - I think this is an "Install" problem, not an Application problem (and you'll likely find related posts there, too)

    TSU

  4. #4

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video tearin

    Quote Originally Posted by hcvv View Post
    What after a logout/login instead of a reboot. Does that also reintroduce the problem?
    Yes, after logout/login the problem is also reintroduced.

    I already tried these without success:


    • install Go2 drivers from yast instead of GO3. (this causes me to lose all desktop effect and nvidia fails to load)
    • Reinstall GO3 drivers
    • install mesa opengl instead of the nvidia opelglGO3 package (this causes opengl failing to load and thus even worse performance)


    Extra info: disabling/enabling desktop effects was not enough to resolve the issue temporarily after all (pressing alt-shift-F12 twice). I really have to go to desktop effects - advanced and change the "type composoting". It doesn't matter if I change it to openGL 2.0 or 3.1. KDE memories my selection after reboot, but I have to change the version in order to get good performance when playing video's.

  5. #5

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video tearin

    Quote Originally Posted by tsu2 View Post
    1. You need to describe the version of openSUSE

    2. Is this a new install or an upgrade from a previous version? In an upgrade, I discovered to my dismay that when the upgrade also changed from an nVidia to Intel GPU, there was a little-documented "feature" somewhere in /etc? (I don't remember where at the moment, but is deep in my postings) where there was a "monitor" setting still pointing to nVidia which invalidated loading the Intel GPU drivers correctly.

    BTW - I think this is an "Install" problem, not an Application problem (and you'll likely find related posts there, too)

    TSU

    • I use opensuse 13.1 64 bit.
    • I did a fresh install of the os, already 8 months ago. Not an upgrade. I did not reinstall/upgrade the os after changing the gpu
    • My old GPU was also NVIDIA brand (GT7950 or something like that - 8 years old) and didn't have this problem

  6. #6

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video te

    Quote Originally Posted by suskewiet View Post
    • I use opensuse 13.1 64 bit.
    • I did a fresh install of the os, already 8 months ago. Not an upgrade. I did not reinstall/upgrade the os after changing the gpu
    • My old GPU was also NVIDIA brand (GT7950 or something like that - 8 years old) and didn't have this problem
    Please post which packages (and kernels) you really have installed now:
    Code:
    rpm -qa | egrep "nvidia|kernel"
    According to the story so far, I'm pretty sure there's some mess up...

  7. #7

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video te

    Quote Originally Posted by wolfi323 View Post
    Please post which packages (and kernels) you really have installed now:
    Code:
    rpm -qa | egrep "nvidia|kernel"
    According to the story so far, I'm pretty sure there's some mess up...
    Thanks for the quick reply. This is the output:

    Code:
    rpm -qa | egrep "nvidia|kernel"
    kernel-desktop-3.11.10-21.1.x86_64
    nvidia-uvm-gfxG03-kmp-desktop-340.32_k3.11.6_4-31.1.x86_64
    kernel-devel-3.11.10-21.1.noarch
    nvidia-gfxG03-kmp-desktop-340.32_k3.11.6_4-31.1.x86_64
    kernel-desktop-devel-3.11.10-21.1.x86_64
    kernel-devel-3.11.10-17.2.noarch
    nvidia-computeG03-340.32-31.1.x86_64
    nvidia-glG03-340.32-31.1.x86_64
    kernel-desktop-devel-3.11.10-17.2.x86_64
    kernel-desktop-3.11.10-17.2.x86_64
    x11-video-nvidiaG03-340.32-31.1.x86_64
    kernel-firmware-20130714git-2.21.1.noarch
    The only strange thing I noticed during the installation was this. I had the GO2 packages installed for my old GPU. I then replaced the GPU and rebooted the pc. After that I went to yast software and it immediatelly suggested to installed the GO3 packages. I also marked the GO2 packages for removal and hit install. After install was finished I rebooted and nvidia failed to load. Then I reinstalled the GO3 packages in yast rebooted again and now nvidia could be loaded.

    I did the above twice because I tried the GO2 drivers as well. Also I can not remove GO2 and install GO3 in two steps, because yast always adds either one of the nvidia driver or the nouveau driver. Right now I have nouveau not installed.

  8. #8

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video te

    I tried to reinstall the GO2 drivers twice as well and now NVIDIA succesfully loads the GO2 drivers, but the problem is not solved with them. I start to think that it's not a driver problem, but something with opengl or KDE/kwin.

    So this configuration is also not ok:

    Code:
    rpm -qa | egrep "nvidia|kernel"
    kernel-desktop-3.11.10-21.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.121_k3.11.6_4-37.1.x86_64
    kernel-devel-3.11.10-21.1.noarch
    kernel-desktop-devel-3.11.10-21.1.x86_64
    x11-video-nvidiaG02-304.121-38.1.x86_64
    kernel-devel-3.11.10-17.2.noarch
    kernel-desktop-devel-3.11.10-17.2.x86_64
    kernel-desktop-3.11.10-17.2.x86_64
    nvidia-computeG02-304.121-38.1.x86_64
    kernel-firmware-20130714git-2.21.1.noarch
    Quote Originally Posted by suskewiet View Post
    Thanks for the quick reply. This is the output:

    Code:
    rpm -qa | egrep "nvidia|kernel"
    kernel-desktop-3.11.10-21.1.x86_64
    nvidia-uvm-gfxG03-kmp-desktop-340.32_k3.11.6_4-31.1.x86_64
    kernel-devel-3.11.10-21.1.noarch
    nvidia-gfxG03-kmp-desktop-340.32_k3.11.6_4-31.1.x86_64
    kernel-desktop-devel-3.11.10-21.1.x86_64
    kernel-devel-3.11.10-17.2.noarch
    nvidia-computeG03-340.32-31.1.x86_64
    nvidia-glG03-340.32-31.1.x86_64
    kernel-desktop-devel-3.11.10-17.2.x86_64
    kernel-desktop-3.11.10-17.2.x86_64
    x11-video-nvidiaG03-340.32-31.1.x86_64
    kernel-firmware-20130714git-2.21.1.noarch
    The only strange thing I noticed during the installation was this. I had the GO2 packages installed for my old GPU. I then replaced the GPU and rebooted the pc. After that I went to yast software and it immediatelly suggested to installed the GO3 packages. I also marked the GO2 packages for removal and hit install. After install was finished I rebooted and nvidia failed to load. Then I reinstalled the GO3 packages in yast rebooted again and now nvidia could be loaded.

    I did the above twice because I tried the GO2 drivers as well. Also I can not remove GO2 and install GO3 in two steps, because yast always adds either one of the nvidia driver or the nouveau driver. Right now I have nouveau not installed.

  9. #9

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video te

    Quote Originally Posted by suskewiet View Post
    I tried to reinstall the GO2 drivers twice as well and now NVIDIA succesfully loads the GO2 drivers, but the problem is not solved with them. I start to think that it's not a driver problem, but something with opengl or KDE/kwin.

    So this configuration is also not ok:

    Code:
    rpm -qa | egrep "nvidia|kernel"
    kernel-desktop-3.11.10-21.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.121_k3.11.6_4-37.1.x86_64
    kernel-devel-3.11.10-21.1.noarch
    kernel-desktop-devel-3.11.10-21.1.x86_64
    x11-video-nvidiaG02-304.121-38.1.x86_64
    kernel-devel-3.11.10-17.2.noarch
    kernel-desktop-devel-3.11.10-17.2.x86_64
    kernel-desktop-3.11.10-17.2.x86_64
    nvidia-computeG02-304.121-38.1.x86_64
    kernel-firmware-20130714git-2.21.1.noarch
    Ok.
    AFAICS, both of your outputs are ok.

    Then please post your /var/log/Xorg.0.log, and the output of:
    Code:
    glxinfo | grep render
    (you might have to install the package "Mesa-demo-x" first...)

    And please check that KDE's desktop effects settings are "OpenGL" and "Raster". (Configure Desktop->Desktop Effects->Advanced)
    They might have been reset to slower (but more compatible) settings.
    Last edited by wolfi323; 15-Sep-2014 at 11:23.

  10. #10

    Default Re: Replaced GPU, now each boot kwin effects need restart to work properly (eg to avoid video te

    Quote Originally Posted by wolfi323 View Post
    Ok.
    AFAICS, both of your outputs are ok.

    Then please post your /var/log/Xorg.0.log, and the output of:
    Code:
    glxinfo | grep render
    (you might have to install the package "Mesa-demo-x" first...)

    And please check that KDE's desktop effects settings are "OpenGL" and "Raster". (Configure Desktop->Desktop Effects->Advanced)
    They might have been reset to slower (but more compatible) settings.
    glxinfo:

    Code:
    glxinfo | grep render
    direct rendering: Yes
    OpenGL renderer string: GeForce GT 640/PCIe/SSE2
        GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
        GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
        GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
        GL_OES_depth_texture, GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 
        GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
        GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
        GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
        GL_OES_depth_texture, GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

    Configure Desktop->Desktop Effects->Advanced is set to opengl (I need to change the version here to bypass the problem. But the other is not raster right now but something that probably translates to "system default" . Is there a reason I should pick raster? If I do pick raster, it says 21 effects have been disabled...

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •