Results 1 to 6 of 6

Thread: Need Help setting up XRDP on openSUSE 13.1

  1. #1

    Default Need Help setting up XRDP on openSUSE 13.1

    I created an openSUSE 13.1 virtual machine on my Windows 2012 server and need to access it from my Windows 7 machine without RDPing into my server. I can connect directly to my Windows 8 virtual machine. The openSUSE 13.1 virtual machine has has SAMBA configured and has joined the Windows Active Directory.

    I followed the instructions at http://www.xrdp.org/index.php?option...ments&Itemid=7
    but could not connect. I receive "Remote Desktop can't connect to the remote computer for one of these reasons: 1) Remote access to the server is not enabled. 2) The remote computer is turned off. 3) The remote computer is not available on the network. Make sure the remote computer is turned on and connected to the network, and that remote access is enabled."
    I receive this attempting to connect by host name, ip, or from right clicking on computer in the network and selecting Connect with remote Desktop Connection. I disabled the firewall with no change.

    I went to http://software.opensuse.org/package/xrdp and ran all 6 "1 click installs" with no change. All the install processes looked like they worked, but I can not find out how to verify that everything is installed and working.

    How do I verify that XRDP is installed and correctly configured?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,806
    Blog Entries
    1

    Default Re: Need Help setting up XRDP on openSUSE 13.1

    Whenever posting about a problem,
    Always post the exact error message.
    If you can't screenshot or copy the text, then take a picture and post.

    Otherwise all anyone can provide is a guess.

    And, don't forget to either enable the RDP service or open an incoming port on your openSUSE.

    TSU

  3. #3

    Default Re: Need Help setting up XRDP on openSUSE 13.1

    I did include the exact error message. It is
    I receive "Remote Desktop can't connect to the remote computer for one of these reasons: 1) Remote access to the server is not enabled. 2) The remote computer is turned off. 3) The remote computer is not available on the network. Make sure the remote computer is turned on and connected to the network, and that remote access is enabled."
    I have TCP Port 3389 and the RDP IP Protocol allowed in the advanced settings of the firewall configuration.

  4. #4

    Default Re: Need Help setting up XRDP on openSUSE 13.1

    I have problem with this tool too. This happens also if I try to use VNC for remote desktop, so it might be connected.

    What happens is that after setting up xrdp (and enabling it's services) I connect from another machine, get the login screen...
    - if I login as root, everything works fine (on VNC too)
    - if I try to login as a normal user then I get a bit of the login animation for KDE and after 1-2 seconds the connection drops (before I get a desktop)

    This happens in every OpenSUSE version since at least version 11.4 (even on clean installs), but I didn't need remote desktop that much until now (and when I needed it was outside of work, so I could just use NX), so I ignored this. I have a feeling this is a permission problem, maybe I need to add the normal user to some specific group? But I couldn't find any documentation about this :-/.

  5. #5

    Default Re: Need Help setting up XRDP on openSUSE 13.1

    Quote Originally Posted by bagner View Post
    I did include the exact error message. It is


    I have TCP Port 3389 and the RDP IP Protocol allowed in the advanced settings of the firewall configuration.
    You need to enable the xrdp service. Do this in yast - services, enable and start xrdp and xrdp sesman, that should help.

  6. #6

    Default Re: Need Help setting up XRDP on openSUSE 13.1

    I got the solution to my problem! :-)

    It turns out one can't be logged in 2x as the same user. E.g. once on the machine physically and 2nd time via vnc or rdp. So when I logged out, then I could normally connect via remote :-).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •