Results 1 to 7 of 7

Thread: Firefox 32 failed to install, got 31.1

  1. #1
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    301

    Default Firefox 32 failed to install, got 31.1

    It looked like there was an update to Firefox 32 in Yast2, which I accepted. Now I see that the running FF version is 31.1. The compile date (shown in yast/software/software management/ search for Firefox, examine the 'Technical Data' tab) is 5 Sept 2014 at 6:35 a.m. EDT. That date seems recent enough to be the latest, but the version number isn't the expected value (32).
    Did I miss something?
    Leap/KDE and a film-based photographer

  2. #2

    Default Re: Firefox 32 failed to install, got 31.1

    Quote Originally Posted by konsultor View Post
    It looked like there was an update to Firefox 32 in Yast2, which I accepted. Now I see that the running FF version is 31.1. The compile date (shown in yast/software/software management/ search for Firefox, examine the 'Technical Data' tab) is 5 Sept 2014 at 6:35 a.m. EDT. That date seems recent enough to be the latest, but the version number isn't the expected value (32).
    Did I miss something?
    Firefox 31.1.0 is the latest ESR (Extended Support Release) version, and has been released on the same day as 32.

    Apparently the update description is wrong, or they included the wrong version in the update.

    If you do want Firefox 32, you can install it from the mozilla repo:
    http://software.opensuse.org/package/MozillaFirefox

  3. #3
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    301

    Default Re: Firefox 32 failed to install, got 31.1

    Thanks for the clarification. Seems OK to stick with the auto update of 31.1.
    Leap/KDE and a film-based photographer

  4. #4

    Default Re: Firefox 32 failed to install, got 31.1

    Quote Originally Posted by konsultor View Post
    Thanks for the clarification. Seems OK to stick with the auto update of 31.1.
    Yes.
    They probably switched to the 31 ESR branch on purpose, as that would fit better to openSUSE's update policy (no new features, just bug and security fixes)...

  5. #5
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Firefox 32 failed to install, got 31.1

    As much as I hate to use it, I installed Firefox 32.0 from the Mozilla repo, but it should be in the update repo.

    I am not an organization or enterprise and do not want the ESR version.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  6. #6

    Default Re: Firefox 32 failed to install, got 31.1

    Quote Originally Posted by rafter22 View Post
    As much as I hate to use it, I installed Firefox 32.0 from the Mozilla repo, but it should be in the update repo.

    I am not an organization or enterprise and do not want the ESR version.
    Well, then file a bug report.

    As I wrote already, openSUSE doesn't normally do feature updates, so it might make sense to have the ESR version in the update repo.
    I don't know the plans though.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Firefox 32 failed to install, got 31.1

    On 2014-09-10 18:56, konsultor wrote:
    >
    > It looked like there was an update to Firefox 32 in Yast2, which I
    > accepted. Now I see that the running FF version is 31.1. The compile
    > date (shown in yast/software/software management/ search for Firefox,
    > examine the 'Technical Data' tab) is 5 Sept 2014 at 6:35 a.m. EDT.
    > That date seems recent enough to be the latest, but the version number
    > isn't the expected value (32).
    > Did I miss something?



    Copied from the mail list:

    +++······················
    On 2014-09-10 21:05, Wolfgang Rosenauer wrote:

    > Hi,
    >
    > Am 10.09.2014 um 20:11 schrieb Peter Gumbrell:
    >> Since the latest Firefox was offered this week in the official Online Update for 13.1, it displays in the accompanying info as a 'Security update to Firefox 32', yet the actual packages show they will be updated to 31.1. Thunderbird meanwhile says it will be updated to 31.1 and says nothing about 32.
    >>
    >> What's going on? Have the Firefox packages been misnumbered or are they not the correct ones? I don't want to update until the confusion appears to be cleared up.

    >
    >
    > the online update contains Firefox 31.1 which is a security fix to version 31.
    > At the same time Firefox 32 got released from Mozilla. Security wise 31.1 and 32
    > have all required fixes.
    > The reason why this is different this time is that Firefox 32 does currently not
    > build for us on i586 and therefore couldn't be shipped with this patch.
    > So you should go with 31.1 for now and wait until 32 or 33 is released in a few
    > weeks.
    >
    >
    > Wolfgang

    ······················++-


    And he is the maintainer, I understand, so that's straight from the
    horse mouth :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •