Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: Root password not accepted

  1. #1

    Question Root password not accepted

    Hallo, could anybody advise on following problem please?

    When performing certain activities, like trying to install VBox additions, request for root password is displayed, but the password is rejected as if not correct, although it is correct.
    Many other events accept the root password without problems: su in terminal, YaST etc. Problem is only with the black overlay dialog.

    Running OpenSUSE 13.1 (with all fixes applied) in virtual mode, hosted in Oracle VirtualBox.

    I'm not very skilled with Linux, thanks for any tips.

  2. #2

    Default Re: Root password not accepted

    Quote Originally Posted by flamestring View Post
    Many other events accept the root password without problems: su in terminal, YaST etc. Problem is only with the black overlay dialog.
    What "black overlay dialog" are you talking about?
    Can you please post a screenshot?

    Btw, you don't have to install VBox guest additions in openSUSE.
    They are included and installed by default.

  3. #3

    Default Re: Root password not accepted

    Wow, that was quick

    This is the black overlay dialog I mentioned: https://drive.google.com/file/d/0B_M...it?usp=sharing .
    The other type - normal modal widow dialogs for root psw (like the one when entering YaST) accept root password well.



    Thanks for the tip on VBox additions beeing in SUSE already. I just wanted to update, because there was notification of beeing outdated.

  4. #4

    Default Re: Root password not accepted

    Anyway the problem with root password not beeing accepted is not limited to VBox additions installation.
    It happens whenever I want to change some system settings like network etc.
    So any suggestions how to fix are welcome.
    It's clean installation, no changes or modifications. Problem occurs right after installation.

  5. #5

    Default Re: Root password not accepted

    Quote Originally Posted by flamestring View Post
    Wow, that was quick

    This is the black overlay dialog I mentioned: https://drive.google.com/file/d/0B_M...it?usp=sharing .
    The other type - normal modal widow dialogs for root psw (like the one when entering YaST) accept root password well.
    Well, you are using GNOME.
    I cannot help with that I'm afraid.
    No idea where that dialog would come from. Seems to be some GNOME-internal thing.

    Does it work when you run "gnomesu /sbin/yast2" or similar? (probably, as you said you can start YaST from the menu)

    And how exactly are you trying to install the guest additions when that dialog appears?

    Thanks for the tip on VBox additions beeing in SUSE already. I just wanted to update, because there was notification of beeing outdated.
    There should not be any notification, if you use the shipped additions at least (I never saw one even after installing really old openSUSE versions like 11.3 upto 12.3 in VBox).
    And there's not really a need to update them.
    You could do so via the Virtualization repo though, as you can start YaST.
    Add that in "YaST->Software Repositories"->Add->Community Repositories, then install the newer "virtualbox-guest-*" packages with YaST->Software Management. You would also get automatic updates then...

    Quote Originally Posted by flamestring View Post
    Anyway the problem with root password not beeing accepted is not limited to VBox additions installation.
    Yes, I understood that.
    I'm just trying to find out what displays this dialog, i.e. what is not working.

    It happens whenever I want to change some system settings like network etc.
    Where? In GNOME's settings? Or in YaST?
    Last edited by wolfi323; 07-Sep-2014 at 07:01.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,369
    Blog Entries
    3

    Default Re: Root password not accepted

    Quote Originally Posted by flamestring View Post
    Anyway the problem with root password not beeing accepted is not limited to VBox additions installation.
    It happens whenever I want to change some system settings like network etc.
    So any suggestions how to fix are welcome.
    It's clean installation, no changes or modifications. Problem occurs right after installation.
    Does rebooting help?

    Have you manually changed the pam configuration?

    I'm not at all sure here. However, my experience suggests that these requests from policy-kit depend on the systemd user agent. Presumably the user agent communicates with the main systemd process. If an update restarts the main systemd process, that breaks the communication and it might not work properly until reboot. And if the systemd entry is removed from the pam configuration, that also breaks the communication.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2 Beta

  7. #7

    Default Re: Root password not accepted

    Thanks for the tip on VBox repository, I will check that later.

    But we can abstract the problem from VBox completly. Easiest way to reproduce the troublesome root psw dialog is to go to "Settings -> Users" and push the "Unlock" button: https://drive.google.com/file/d/0B_M...it?usp=sharing. The overlay root psw window is displayed in GNOME.

    Calling something through gnomesu works fine and displays the standard modal window for root psw, which accepts password just fine: https://drive.google.com/file/d/0B_M...it?usp=sharing.

    Thanks a lot for your time.

  8. #8

    Default Re: Root password not accepted

    Quote Originally Posted by nrickert View Post
    Does rebooting help?
    No, several reboots and still the same. It actually occured right after first install of SUSE 13.1 from the downloaded package. Clean install, not an upgrade.

    Quote Originally Posted by nrickert View Post
    Have you manually changed the pam configuration?
    I did not, it's behaving this way right after installation without changing anything.

  9. #9

    Default Re: Root password not accepted

    Hm.
    At least you're not alone apparently:
    https://ask.fedoraproject.org/en/que...root-password/
    Unfortunately they only "fixed" the problem there by switching to XFCE as desktop environment...

    Maybe it is actually asking for your user's password, not root's? Yes, I know that it says "Admistrator", but you could at least try to enter the user's password once.

    Try this to maybe find out what's the problem:
    Check the system journal; run this command as root in terminal:
    Code:
    journalctl -b -f
    leave it running and try to authenticate, it should print info from polkit about what went wrong.

  10. #10

    Default Re: Root password not accepted

    Quote Originally Posted by wolfi323 View Post
    Hm.
    At least you're not alone apparently:
    https://ask.fedoraproject.org/en/que...root-password/
    Unfortunately they only "fixed" the problem there by switching to XFCE as desktop environment...
    Yes, this is exactly the problem I have. I tried to google all over before posting here but found no solution. Baybe GNOME bug?

    Quote Originally Posted by wolfi323 View Post
    Maybe it is actually asking for your user's password, not root's? Yes, I know that it says "Admistrator", but you could at least try to enter the user's password once.
    I tried all accounts' passwords besides root, but didn't work. The info in log is the same as the guy you linked mentions. No sign of error, just messages related to pressing CANCEL eventually.

    Thanks a lot for your effort anyway, I appreciate it

    Will check GNOME pages specifically for this problem.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •