I tried to run my old Epson perfection v30 scanner on openSuse 13.1. In "hardware" and "scanners" section in yast it was recognized as an Epson scanner right away. When i opened a scanning application like scanlight, the scanner was not found. I checked the Hardware compatibility and there was no entry for it.

I went to the Epson Website and checked for drivers. Though Epson states on its webpage it does not support drivers for linux, they do offer a variety of drivers for various distributions. You can find them with the search forms on this webpage


You can follow the instructions on the Epson website or read along my instructions as it kind of confusing on the Epson website.

Here is what i did:

In the search results I clicked on „download“ for the „core package&data package“. I was sent to a page where i had to click a „accept the terms of condition“ button at the very bottom of the page. Then on the same page below the button the download rpm were listed.

I clicked on „FAQ“ at the very bottom of the rpm list which lead me to a instruction on which drivers to select an how to install them.


I followed the instructins, downloaded the iscan-2.29.3-1.usb0.1.ltdl7.x86_64.rpm and the required data packages iscan-data-1.29.0-2.noarch.rpm

I then went back to the page


and clicked on „download“ for the „iscan plugin package“.

I went to yast, and installed the packages.

I opened scanlite, the scanner was found immediately. I did a testscan which worked fine.

If you are having trouble with the installation, you might find useful informatin on the support section.


Hope this is helpful.