Results 1 to 8 of 8

Thread: glxinfo not responding

  1. #1

    Default glxinfo not responding

    Hi,

    Firstly, I'll apologize in advance I don't know how to project the information to give any clues on what's happening. If anyone could lend me a hand in figuring out square one on fixing this it would be greatly appreciated.

    What I have done is checked to see if all the mesa lib's are installed, i just loaded up the flgrx driver and it's working.

    I know this information isn't enough at all but I don't know where to start

    HELP

  2. #2

    Default Re: glxinfo not responding

    OpenGL GLX context is not using direct rendering, which may cause performance problems.

    For more information visit https://support.steampowered.com/kb_...9938-EYZB-7457.

  3. #3

    Post Re: glxinfo not responding


  4. #4

    Default Re: glxinfo not responding


  5. #5

    Default Re: glxinfo not responding

    Quote Originally Posted by kpc18 View Post
    Well, I think the message is clear, isn't it?
    Code:
    [main] Error: glxinfo is not installed. Please install mesa-utils package
    You don't have glxinfo installed.

    The package is called "Mesa-demo-x" on openSUSE, so install that with YaST or zypper.

  6. #6

    Default Re: glxinfo not responding

    Quote Originally Posted by wolfi323 View Post
    Well, I think the message is clear, isn't it?
    Code:
    [main] Error: glxinfo is not installed. Please install mesa-utils package
    You don't have glxinfo installed.

    The package is called "Mesa-demo-x" on openSUSE, so install that with YaST or zypper.
    I really appreciate the help, as that did fix the problem. However, I admit I have plenty to learn about how linux and more in general Suse works.

  7. #7

    Default Re: glxinfo not responding

    Quote Originally Posted by kpc18 View Post
    I really appreciate the help, as that did fix the problem.
    TBH, I don't think you really had a problem.

    Apparently the application uses glxinfo to check whether direct rendering works, and because it couldn't run glxinfo, it assumed it does not work and printed a warning.

    As the name implies, glxinfo only prints out some information about the available OpenGL/GLX support.
    Not having glxinfo installed doesn't change anything regarding OpenGL/GLX though.
    But of course it's nicer to not get such warning messages...
    Last edited by wolfi323; 05-Sep-2014 at 01:32.

  8. #8

    Default Re: glxinfo not responding

    Yeah, it was a bit strange as I did have all of the files I thought. glxinfo was tripping up playonlinux and steam saying i didn't have 32 bit OpenGL drivers installed. I was thinking I majorly messed something up with my flgrx install. Turns out everything is ok, that's why I was sweating the problem so hard. Anyway, glad everything is ok and once again thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •