Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Problem With Flash Player

  1. #1

    Default Problem With Flash Player

    I have just installed openSUSE 13.1 (32-bit) on an HP Pavillion dv1040us. The desktop environment is KDE. I am using Firefox 31.0.
    I also have installed Shockwave Flash 11.2.202.400.

    When playing YouTube videos, the colors are off! People appear with a purplish skin color, for instance. Other objects appear with greenish or blueish hues...

    In doing some online research, I found that it is recommended to turn off hardware acceleration in Flash. But when I right-click on a video and select Settings, the box that appears does not allow me to uncheck the Allow Hardware Acceleration option. (Basically, nothing happens when I click to uncheck the feature...)

    How do I solve this problem? I really would like to stay with Firefox 31.0, when possible.

  2. #2
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Problem With Flash Player

    Try switching to HTML Video on YouTube, or try disabling hardware acceleration in Firefox.

    Preferences > Advanced > General tab
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  3. #3

    Default Re: Problem With Flash Player

    Quote Originally Posted by rafter22 View Post
    Try switching to HTML Video on YouTube, or try disabling hardware acceleration in Firefox.

    Preferences > Advanced > General tab
    Hardware acceleration is already turned off in Firefox. I'll try the HTML switch that you suggest. It will be during the coming weekend...

  4. #4

    Default Re: Problem With Flash Player

    Quote Originally Posted by tb75252 View Post
    In doing some online research, I found that it is recommended to turn off hardware acceleration in Flash. But when I right-click on a video and select Settings, the box that appears does not allow me to uncheck the Allow Hardware Acceleration option. (Basically, nothing happens when I click to uncheck the feature...)
    So you see that option but it has no effect?

    Have you tried to reload the page after disabling the hardware acceleration?

    Have you tried with a new user?

    Changing the "enable_flash_uv_swap" option in /etc/vdpau_wrapper.cfg might fix your problem with hw acceleration as well.

    Using HTML5 should also work, but be aware that you will have to have the corresponding gstreamer-0_10-plugins from Packman installed then.

  5. #5

    Default Re: Problem With Flash Player

    Quote Originally Posted by wolfi323 View Post
    So you see that option but it has no effect?
    The window for Flash settings appears, but it is off color and hard to read because small. When I click on the box for the only setting that I can barely distinguish (which I'm assuming is the hardware acceleration option) nothing happens. The box on the left side of the hardware acceleration option appears to have a selection mark in it and I am unable to deselect that option.

    Have you tried to reload the page after disabling the hardware acceleration?
    After having disabled the hardware acceleration in Firefox? Yes.

    Have you tried with a new user?
    Yes. This appears to be a compatibility problem between the hardware (laptop is approx. ten years old!) and Flash Player for Linux, so it seems to show up no matter who the user is.

    Changing the "enable_flash_uv_swap" option in /etc/vdpau_wrapper.cfg might fix your problem with hw acceleration as well.
    I will try your suggestion this weekend and see what happens.

    Using HTML5 should also work, but be aware that you will have to have the corresponding gstreamer-0_10-plugins from Packman installed then.
    Where can I get instructions on where to find these plugins, how to install them, etc.?

  6. #6

    Default Re: Problem With Flash Player

    Quote Originally Posted by tb75252 View Post
    The window for Flash settings appears, but it is off color and hard to read because small. When I click on the box for the only setting that I can barely distinguish (which I'm assuming is the hardware acceleration option) nothing happens. The box on the left side of the hardware acceleration option appears to have a selection mark in it and I am unable to deselect that option.
    Well, what display resolution are you using?
    Maybe try to switch to a lower resolution to be able to hit that checkbox.
    You can switch back to the standard resolution afterwards again, of course.
    Or use some desktop zoom utility, kmag e.g. There's also a "Zoom" desktop effect.

    If that checkbox is ticked, hardware acceleration is _on_, yes.

    After having disabled the hardware acceleration in Firefox? Yes.
    Apparently you didn't disable it at all, according to your description above.

    Yes. This appears to be a compatibility problem between the hardware (laptop is approx. ten years old!) and Flash Player for Linux
    No.
    It might be a compatibility problem between Flash Player and your graphics driver.
    And indeed such an incompatibility does exist between Flash Player and the nvidia driver at least.

    Where can I get instructions on where to find these plugins, how to install them, etc.?
    Do you have the Packman repo added to your system?
    You can find it in YaST->Software Repositories->Add->Community Repositories.

    Install the packages gstreamer-0_10-plugins-bad-orig-addon, gstreamer-0_10-plugins-ugly-orig-addon, and gstreamer-0_10-plugins-ffmpeg in YaST->Software Management, that should give you the possibility to play back all files.

    Btw, the same are used by KDE's multimedia framework as well (with the default settings), so Dragon-Player and Amarok e.g. would profit, too.

  7. #7

    Default Re: Problem With Flash Player

    Quote Originally Posted by wolfi323 View Post
    Well, what display resolution are you using?
    Maybe try to switch to a lower resolution to be able to hit that checkbox.
    You can switch back to the standard resolution afterwards again, of course.
    Or use some desktop zoom utility, kmag e.g. There's also a "Zoom" desktop effect.
    I actually tried both a lower resolution and refresh rate. I ended up having to open a separate help thread because KDE would crash after I did that. I got the needed help and the problem is now fixed. (I don't know if the KDE crashing was due to the lower resolution, refresh rate, or both.)

    If that checkbox is ticked, hardware acceleration is _on_, yes.

    Apparently you didn't disable it at all, according to your description above.
    What I did within Firefox is Options -> Advanced -> General and unchecked the "Use Hardware Acceleration When Available" option. However, when playing YouTube videos that does not solve the off-colors problem... It is with Adobe Flash Player hardware acceleration settings that I have troubles! (Right-click within any YouTube video, select Settings, a small window titled "Adobe Flash Player Settings" appears and I am unable to deselect the option "Enable Hardware Acceleration".)

    No.
    It might be a compatibility problem between Flash Player and your graphics driver.
    And indeed such an incompatibility does exist between Flash Player and the nvidia driver at least.

    Do you have the Packman repo added to your system?
    You can find it in YaST->Software Repositories->Add->Community Repositories.

    Install the packages gstreamer-0_10-plugins-bad-orig-addon, gstreamer-0_10-plugins-ugly-orig-addon, and gstreamer-0_10-plugins-ffmpeg in YaST->Software Management, that should give you the possibility to play back all files.

    Btw, the same are used by KDE's multimedia framework as well (with the default settings), so Dragon-Player and Amarok e.g. would profit, too.
    Great. I'll do that this weekend.

  8. #8

    Default Re: Problem With Flash Player

    Quote Originally Posted by tb75252 View Post
    I actually tried both a lower resolution and refresh rate. I ended up having to open a separate help thread because KDE would crash after I did that. I got the needed help and the problem is now fixed. (I don't know if the KDE crashing was due to the lower resolution, refresh rate, or both.)
    The refresh rate should not matter at all, and the lower resolution should not make KDE crash either.
    But there was a bug in the shipped intel driver which caused it to crash X on resolution changes.
    Maybe that was your problem?

    But if it is fixed now, you should be able to switch to a lower resolution to change that setting, no?
    Can you point to that thread, so that I know what exactly you are talking about?

    And desktop zoom still is an option as well, even when changing resolution would crash.

    As I understand it, you cannot disable hardware acceleration because the settings window and the checkbox is too small.

    What I did within Firefox is Options -> Advanced -> General and unchecked the "Use Hardware Acceleration When Available" option. However, when playing YouTube videos that does not solve the off-colors problem... It is with Adobe Flash Player hardware acceleration settings that I have troubles! (Right-click within any YouTube video, select Settings, a small window titled "Adobe Flash Player Settings" appears and I am unable to deselect the option "Enable Hardware Acceleration".)
    Yes, I know.
    But you have to deselect the option "Enable Hardware Acceleration" in the small window titled "Adobe Flash Player Settings" to disable hardware acceleration in flash-player.
    The other one has absolutely no effect on flash-player, it is for Firefox itself only.

  9. #9

    Default Re: Problem With Flash Player

    Quote Originally Posted by wolfi323 View Post
    The refresh rate should not matter at all, and the lower resolution should not make KDE crash either.
    But there was a bug in the shipped intel driver which caused it to crash X on resolution changes.
    Maybe that was your problem?

    But if it is fixed now, you should be able to switch to a lower resolution to change that setting, no?
    Can you point to that thread, so that I know what exactly you are talking about?
    You probably mean this one, right?
    http://forums.opensuse.org/showthrea...51-KDE-Crashes

    Well, you didn't tell which graphics card you have.
    But if it is indeed that intel driver bug, it should be fixed after you install all updates.

    Please post the output of:
    Code:
    /sbin/lspci | grep VGA
    This site would suggest it is indeed intel though:
    http://h20566.www2.hp.com/portal/sit...4892.199480143
    Last edited by wolfi323; 03-Sep-2014 at 09:38.

  10. #10

    Default Re: Problem With Flash Player

    Quote Originally Posted by wolfi323 View Post
    Yep, that's it!

    Well, you didn't tell which graphics card you have.
    But if it is indeed that intel driver bug, it should be fixed after you install all updates.

    Please post the output of:
    Code:
    /sbin/lspci | grep VGA
    This site would suggest it is indeed intel though:
    http://h20566.www2.hp.com/portal/sit...4892.199480143
    Ok, I will have to do it this weekend. In the meantime, thanks for your help.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •