Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Problem With Flash Player

  1. #11

    Default Re: Problem With Flash Player

    Quote Originally Posted by wolfi323 View Post
    The refresh rate should not matter at all, and the lower resolution should not make KDE crash either.
    But there was a bug in the shipped intel driver which caused it to crash X on resolution changes.
    Maybe that was your problem?

    But if it is fixed now, you should be able to switch to a lower resolution to change that setting, no?
    Can you point to that thread, so that I know what exactly you are talking about?

    And desktop zoom still is an option as well, even when changing resolution would crash.

    As I understand it, you cannot disable hardware acceleration because the settings window and the checkbox is too small.


    Yes, I know.
    But you have to deselect the option "Enable Hardware Acceleration" in the small window titled "Adobe Flash Player Settings" to disable hardware acceleration in flash-player.
    The other one has absolutely no effect on flash-player, it is for Firefox itself only.
    There must be a file somewhere that has this "Enable Hardware Acceleration" flag set to ON (or whatever the setting syntax is!), don't you think? If I knew where this file is, I could set hardware acceleration to OFF.

  2. #12

    Default Re: Problem With Flash Player

    Quote Originally Posted by tb75252 View Post
    There must be a file somewhere that has this "Enable Hardware Acceleration" flag set to ON (or whatever the setting syntax is!), don't you think? If I knew where this file is, I could set hardware acceleration to OFF.
    Well, apparently this is stored in ~/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol, but of course this is no user-editable text file...

    But:
    Code:
    :~ cmp -b ~/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol.bak ~/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol
    /home/wolfi/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol.bak /home/wolfi/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol differ: byte 116, line 2 is   0 ^@   1 ^A
    So, open the file in a hex editor (e.g. okteta or ghex) and change the byte at offset 115 (hex offset 0x73) from 0 to 1 to turn _off_ hardware acceleration. (right, that's no typo: 1 means off, and cmp starts to count at 1, so cmp's byte #1 has actually offset 0)

    To be clear, it's this one:
    Last edited by wolfi323; 03-Sep-2014 at 21:46.

  3. #13

    Default Re: Problem With Flash Player

    This is a recap of what I have (unsuccessfully) tried so far:

    * Disabled hardware acceleration in Firefox. Does not work.
    * Changed the "enable_flash_uv_swap" option to "disable_flash_uv_swap" option in /etc/vdpau_wrapper.cfg. Does not work.
    * Installed gstreamer-0_10-plugins from Packman. Does not work.
    * This is the output of /sbin/lspci | grep VGA:
    Code:
    # /sbin/lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
    I indeed have an integrated Intel graphics card. I have run "zypper up" and all updates are installed. Does not work.
    * Installed Okteta and edited file ~/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol. Option "Enable Hardware Acceleration" is now no longer selected in Settings. Does not work.

  4. #14

    Default Re: Problem With Flash Player

    Quote Originally Posted by tb75252 View Post
    This is a recap of what I have (unsuccessfully) tried so far:

    * Disabled hardware acceleration in Firefox. Does not work.
    * Changed the "enable_flash_uv_swap" option to "disable_flash_uv_swap" option in /etc/vdpau_wrapper.cfg. Does not work.
    * Installed gstreamer-0_10-plugins from Packman. Does not work.
    * This is the output of /sbin/lspci | grep VGA:
    Code:
    # /sbin/lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
    I indeed have an integrated Intel graphics card. I have run "zypper up" and all updates are installed. Does not work.
    * Installed Okteta and edited file ~/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol. Option "Enable Hardware Acceleration" is now no longer selected in Settings. Does not work.
    I am happy to report that I was able to solve the problem! Credit goes to this article:
    http://lslezak.blogspot.com/2011/04/...cs-driver.html

    This is what I did:
    * I went to YaST -> Software Management, searched for "xf86-video-intel" (in my case it found version "xf86-video-intel-2.99.906), right-clicked on it, marked it for deletion, and then pressed Accept. (This step was not mentioned in the above-mentioned link!!)
    * I went to http://xorg.freedesktop.org/archive/individual/driver/ and downloaded the latest Intel video driver (currently it is "xf86-video-intel-2.99.914.tar.bz2").
    * I went to my Downloads directory and unpacked the archived file:
    Code:
    tar xfjv xf86-video-intel-2.99.914.tar.bz2
    * I compiled the driver:
    Code:
    cd xf86-video-intel-2.99.914
    ./configure --prefix=/usr --libdir=/usr/lib  <--use "/lib64" instead of "/lib" if you have a 64-bit system!
    make
    * I installed the driver:
    Code:
    sudo make install
    * I restarted the laptop and made sure that YouTube videos were working fine. :-)

  5. #15

    Default Re: Problem With Flash Player

    Quote Originally Posted by tb75252 View Post
    I am happy to report that I was able to solve the problem! Credit goes to this article:
    http://lslezak.blogspot.com/2011/04/...cs-driver.html

    This is what I did:
    * I went to YaST -> Software Management, searched for "xf86-video-intel" (in my case it found version "xf86-video-intel-2.99.906), right-clicked on it, marked it for deletion, and then pressed Accept. (This step was not mentioned in the above-mentioned link!!)
    * I went to http://xorg.freedesktop.org/archive/individual/driver/ and downloaded the latest Intel video driver (currently it is "xf86-video-intel-2.99.914.tar.bz2").
    * I went to my Downloads directory and unpacked the archived file:
    Code:
    tar xfjv xf86-video-intel-2.99.914.tar.bz2
    * I compiled the driver:
    Code:
    cd xf86-video-intel-2.99.914
    ./configure --prefix=/usr --libdir=/usr/lib  <--use "/lib64" instead of "/lib" if you have a 64-bit system!
    make
    * I installed the driver:
    Code:
    sudo make install
    * I restarted the laptop and made sure that YouTube videos were working fine. :-)
    I forgot to mention that after the "sudo make install" command I went to YaST -> Software Management, searched for "xf86-video-intel-2.99.914", right-clicked on it, marked it for install, and then pressed Accept.

  6. #16

    Default AW: Re: Problem With Flash Player

    Quote Originally Posted by tb75252 View Post
    This is a recap of what I have (unsuccessfully) tried so far:

    * Disabled hardware acceleration in Firefox. Does not work.
    As I said, this doesn't have any effect on the flash-player. That option is only for Firefox itself.

    * Changed the "enable_flash_uv_swap" option to "disable_flash_uv_swap" option in /etc/vdpau_wrapper.cfg. Does not work.
    That's wrong.
    You should change "enable_flash_uv_swap=1" to "enable_flash_uv_swap=0" (or vice-versa).
    I thought that was obvious.

    * Installed gstreamer-0_10-plugins from Packman. Does not work.
    Again, this is only used for HTML5. Flash-player is a completely different beast.

    * Installed Okteta and edited file ~/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol. Option "Enable Hardware Acceleration" is now no longer selected in Settings. Does not work.
    Well, then it's probably not caused by the hardware acceleration.

    Quote Originally Posted by tb75252 View Post
    I am happy to report that I was able to solve the problem! Credit goes to this article:
    http://lslezak.blogspot.com/2011/04/...cs-driver.html
    So apparently it is a driver bug that's fixed in a later version.
    You would not have had to compile the driver yourself though, a package should be available from OBS as well.
    And you should not have had to uninstall the old version in YaST. If you install the new driver to /usr/lib64/xorg/modules/updates/drivers/ it is preferred over the installed one. (that directory is intended for using updated drivers instead of the ones installed by the system)

    Quote Originally Posted by tb75252 View Post
    I forgot to mention that after the "sudo make install" command I went to YaST -> Software Management, searched for "xf86-video-intel-2.99.914", right-clicked on it, marked it for install, and then pressed Accept.
    You did what?
    Your above steps do _not_ make the new intel driver available in YaST.
    So either you installed the old version now again (which is ok if the newer version is in that updates directory I mentioned), or you installed the newer driver from an additional repo which makes the above steps to manually compile and install the intel driver completely unnecessary and useless of course.
    Last edited by wolfi323; 07-Sep-2014 at 21:37.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •