Results 1 to 9 of 9

Thread: time setting issues

  1. #1
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,171

    Default time setting issues

    If I try to set the proper time in Configure Desktop, it works but I receive:
    Unable to authenticate/execute the action: 6,

    If I try to set it from the Current Time applet in the KDE taskbar, I receive:
    Unable to authenticate/execute the action: 4,
    ... and it fails to set.

    Weird.

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: time setting issues

    Quote Originally Posted by PattiMichelle View Post
    If I try to set the proper time in Configure Desktop, it works but I receive:
    Unable to authenticate/execute the action: 6,

    If I try to set it from the Current Time applet in the KDE taskbar, I receive:
    Unable to authenticate/execute the action: 4,
    ... and it fails to set.

    Weird.
    Are you getting a dialogue box to authenticate with the root password?

    You should be. Only root can set the time, or the automated daemon.

    You could set it from Yast, or from a root command line.

    Code:
    date -s 17:47
    Sets the time to 17:45 (or 5:45 pm).
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: time setting issues

    On 2014-08-24 23:56, PattiMichelle wrote:
    >
    > If I try to set the proper time in Configure Desktop, it works but I


    Open a terminal, do "su -" to root, then use the command "date" to
    verify set the clock (instructions in "man date"). The desktop is
    typically unreliable in setting the clock, you only can choose your time
    zone.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: time setting issues

    ... heh, heh.

    Typo!

    That would actually set the time to 17:47 !!!
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: time setting issues

    On 2014-08-25 02:56, Fraser Bell wrote:
    >
    > ... heh, heh.
    >
    > Typo!
    >
    > That would actually set the time to 17:47 !!!


    Heh.

    The typo was not posted on nntp. Once of those times...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: time setting issues

    Quote Originally Posted by robin_listas View Post
    On 2014-08-25 02:56, Fraser Bell wrote:
    >
    > ... heh, heh.
    >
    > Typo!
    >
    > That would actually set the time to 17:47 !!!


    Heh.

    The typo was not posted on nntp. Once of those times...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)
    Yeah.

    I was editing my post at the same time you were writing your first reply to this thread, and I added the sample command (to be run as root, from a root console or with su):

    Code:
    date -s 17:47
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  7. #7
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,171

    Default Re: time setting issues

    Thanks for the discussion, I will use those ideas when I get back. I remember being asked for root password, and that threw a slightly different error. Preference would be to set by pool.ntp.***, actually, but that, too, threw and error, but eventually I noticed that the time was correctly updated.


  8. #8
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,171

    Default Re: time setting issues

    OK, so in YaST > Date and Time > (huh? Blank yast window with twirly arrow? Restart YaST)...

    "Error The storage subsystem is locked by application 'y2base' (3223). You must quit that application before you can continue."

    OK - time to reboot... :-/

    OK, rebooting didn't help. YaST time tool offline. I should note this always appears on a blank screen for the forst 20 seconds or so of boot:
    FATAL. Module modprobe not found

  9. #9
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,171

    Default Re: time setting issues

    This worked - odd about the modprobe and nonop on YaST time setting tool...

    Code:
    patti@linux-l8th:~> su
    Password: 
    linux-l8th:/home/patti # date -s 9:43
    Sun Sep  7 09:43:00 PDT 2014
    linux-l8th:/home/patti # ntpdate ntp.ubuntu.com
     7 Sep 09:45:57 ntpdate[2479]: step time server 91.189.94.4 offset 58.187001 sec
    linux-l8th:/home/patti #

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •