Results 1 to 3 of 3

Thread: KDE services

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,272

    Default KDE services

    openSUSE 13.1 64bit KDE

    Under 12.3 KDE I had an audio converter service called "pacpl" that would show when I right-clicked on an audio file while using Konqueror as a file browser. Since I moved to 13.1 it doesn't show in the menu any more. It's located in /home/ion/.kde4/share/kde4/services and called pacpl.desktop. The contents are...

    Code:
    [Desktop Entry]Type=Service
    ServiceTypes=KonqPopupMenu/Plugin
    MimeType=audio/*;video/*;application/x-flash-video;inode/directory;
    Actions=AAC;AC3;AIF;AIFF;APE;AU;AVR;BONK;CAF;CDR;FAP;FLA;FLAC;IRCAM;LA;LPAC;M4A;M4P;MAT;MAT4;MAT5;MMF;MP2;MP3;MP4;MPC;MPP;NIST;OFR;OFS;OGG;PAC;PAF;PVF;RA;RAW;SD2;SF;SHN;SMP;SND;SPX;TTA;VOC;W64;WAV;WMA;WV;
    X-KDE-Submenu=PACPL-Convert
    
    
    [Desktop Action AAC]
    Name=To AAC
    Icon=sound
    Exec=pacpl --to AAC --gui %F &
    
    ......etc
    What am I doing wrong? Thanks in advance.

  2. #2

    Default Re: KDE services

    Quote Originally Posted by ionmich View Post
    It's located in /home/ion/.kde4/share/kde4/services and called pacpl.desktop.
    I'm not sure, but I think it should be in ~/.kde4/share/kde4/services/ServiceMenus/.

    At least the system-wide ones (installed via rpm) are in /usr/share/kde4/services/ServiceMenus/.

    And you might have to run "kbuildsycoca4" (maybe even with the "--noincremental" option) to get it recognized.

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,272

    Default Re: KDE services

    Quote Originally Posted by wolfi323 View Post
    I'm not sure, but I think it should be in ~/.kde4/share/kde4/services/ServiceMenus/.

    At least the system-wide ones (installed via rpm) are in /usr/share/kde4/services/ServiceMenus/.

    And you might have to run "kbuildsycoca4" (maybe even with the "--noincremental" option) to get it recognized.
    Creating the new directory and moving the pacpl.desktop file into it worked immediately. Many thanks for the quick solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •