Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Firefox Cannot Connect to the Internet on System Reboot

  1. #1

    Default Firefox Cannot Connect to the Internet on System Reboot

    I think I have encountered a bug with Firefox that I would like to report. If there is a better place to send bug reports, please let me know!

    I have OpenSuSE 13.1 with the KDE window manager. I often have a Firefox window or two open when I shut down - I love that Firefox saves my place, so I can jump right back into whatever I was working on. Unfortunately, this doesn't work well with the current software stack. My laptop relies on a wireless network connection, which is never available immediately when I log into the KDE window manager - first, I have to enter my KDE wallet password so that Network Manager can connect to my wireless router.

    So it's not a surprise to me that all of my firefox pages load with an error ( could not connect to the internet ). When Firefox is launched, my laptop is still waiting for the internet connection to be established. Here's the part that's strange: even after my wireless connection is established, the "Try again" button still doesn't work. In fact, all web browsing through Firefox continues to fail until I restart the application. Then, it immediately begins working without a hitch.

    I found a workaround that is pretty easy for me (just kill firefox after the wireless connects, and relaunch it - all the pages will reload successfully this time), but I'm curious where to send this bug report to help improve the experience for less savvy users.

    Thanks in advance for the advice!

  2. #2

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    Quote Originally Posted by haileris View Post
    Thanks in advance for the advice!
    Probably Firefox does not pickup the change in network connection state, and therefore doesn't even try to reconnect because it thinks you are still offline anyway. You could regard this as bug in Firefox I suppose, yes.

    What I would do in your case is mark your wireless connection as "system connection". It would be established during boot then already, so you would already be online when Firefox is started.
    It would also prevent you from having to enter the kwallet password at login, and give you internet connection even in textmode.

    Another hint: you can set an empty password for the wallet. You won't be asked for a password then any more when an application tries to open it.
    Last edited by wolfi323; 17-Aug-2014 at 16:26.

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    when it happens go into the File menu and make sure "work offline" is unchecked.
    Try toggling it and see if that brings your connection back.

    If it really is a bug then it's something you'd meed to report over at Mozilla.
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  4. #4
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,014

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    I have a similar problem with my laptop (connected by cable, wi-fi disabled), after every zupper up/dup and after reboot Firefox doesn't work. Other networked functions work. I have learn to reboot again and its ok.

    I have the the same software on my stat PC and have never had the problem with Firefox there as above. I had a problem sometimes when it wake up from sleep. Then its enought to restart Firefox and History->Restore Previus Session.

    On the other hand after zypper up/dup there and maybe half the time my 12-year old wireless Logitech mouse need a reboot to start working again. I convinced that my house is build upon a old pet cemetery .

    regards
    Last edited by jonte1; 19-Aug-2014 at 05:45. Reason: added info.
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  5. #5

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    Solid advice, thanks. Making the wireless network a system connection gets the network online before Firefox launches. It's great.

    I did a little more testing, and it doesn't look like it was set to browse offline, but the behavior was inconsistent - I don't get this issue reliably enough to merit further reporting. Thanks for the tip.

  6. #6
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    Quote Originally Posted by haileris View Post
    I think I have encountered a bug with Firefox that I would like to report. If there is a better place to send bug reports, please let me know!

    I have OpenSuSE 13.1 with the KDE window manager. I often have a Firefox window or two open when I shut down - I love that Firefox saves my place, so I can jump right back into whatever I was working on. Unfortunately, this doesn't work well with the current software stack. My laptop relies on a wireless network connection, which is never available immediately when I log into the KDE window manager - first, I have to enter my KDE wallet password so that Network Manager can connect to my wireless router.

    So it's not a surprise to me that all of my firefox pages load with an error ( could not connect to the internet ). When Firefox is launched, my laptop is still waiting for the internet connection to be established. Here's the part that's strange: even after my wireless connection is established, the "Try again" button still doesn't work. In fact, all web browsing through Firefox continues to fail until I restart the application. Then, it immediately begins working without a hitch.

    I found a workaround that is pretty easy for me (just kill firefox after the wireless connects, and relaunch it - all the pages will reload successfully this time), but I'm curious where to send this bug report to help improve the experience for less savvy users.

    Thanks in advance for the advice!
    Although this is posted in 2014, I find it very helpful. I am using Tumbleweed with almost always the latest snapshot. And I am experiencing the same situation as described here.

    Quote Originally Posted by wolfi323 View Post
    Probably Firefox does not pickup the change in network connection state, and therefore doesn't even try to reconnect because it thinks you are still offline anyway. You could regard this as bug in Firefox I suppose, yes.

    What I would do in your case is mark your wireless connection as "system connection". It would be established during boot then already, so you would already be online when Firefox is started.
    It would also prevent you from having to enter the kwallet password at login, and give you internet connection even in textmode.

    Another hint: you can set an empty password for the wallet. You won't be asked for a password then any more when an application tries to open it.
    Quote Originally Posted by haileris View Post
    Solid advice, thanks. Making the wireless network a system connection gets the network online before Firefox launches. It's great.
    This advice seems helpful to me as well. But I do not know how to make the wireless network a system connection. Could anyone help to describe it more clearly?
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,016
    Blog Entries
    1

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    Quote Originally Posted by cnzhx View Post
    This advice seems helpful to me as well. But I do not know how to make the wireless network a system connection. Could anyone help to describe it more clearly?
    When you add a connection with the NetworkManager connection editor, check 'All users may connect to this network'.

  8. #8
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    Quote Originally Posted by deano_ferrari View Post
    When you add a connection with the NetworkManager connection editor, check 'All users may connect to this network'.
    Thank you, deano. Now I get it.

    And I'd like to add two thing worth noting:
    1. I need to delete the old one then add it again to make it work for 'All users may connect to this network'. Or else the system would ask for password for root to connect after boot, because "System policy prevents modification of network settings for all users".
    2. When creating the new connection, I should select the password saving option (the disk icon on the left of the password input field) to "Store password and make it available for all users (not encrypted)".


    Now, it works like a charm :-)
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  9. #9

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    Quote Originally Posted by cnzhx View Post
    I need to delete the old one then add it again to make it work for 'All users may connect to this network'. Or else the system would ask for password for root to connect after boot, because "System policy prevents modification of network settings for all users".
    This only happens if the connection is established during login as before, and seems to be a "bug" (or design flaw) in NetworkManager itself.
    You do need the root password to modify a system connection ("modification of network settings for all users"), but this shouldn't be needed to *activate* it. And actually it will be activated if you just click on Cancel in the root password request...


    If the password is stored system-wide (as you do in point 2), the connection is established during boot already (and that's what I actually suggested as fix/workaround).

    Btw, I may have misunderstood you, but you seem to have two connections now, right?
    You do not need to keep the old connection if you create a new one.
    OTOH, you would not need to create a new one at all, you can just change the existing one in the first place.

    Btw, back in 2014, this was still called "system connection" in the settings (in KDE at least). This has changed some time ago (in 13.2, which was released in November 2014) to be in line with newer NetworkManager (and GNOME) versions.

    When creating the new connection, I should select the password saving option (the disk icon on the left of the password input field) to "Store password and make it available for all users (not encrypted)".
    Yes, current plasma-nm versions still store the password per user even when "Allow other users to connect" is activated (just like GNOME does).
    Previously, it was always stored system-wide ("make it available for all users") in that case, that's why I didn't mention it here in this thread two years ago.

  10. #10
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Firefox Cannot Connect to the Internet on System Reboot

    Hi wolfi,

    Thanks for the clarification. By this,
    Quote Originally Posted by wolfi323 View Post
    If the password is stored system-wide (as you do in point 2), the connection is established during boot already (and that's what I actually suggested as fix/workaround).
    Do you mean that one need only the 2nd point in my post to make a connection "system connection"? Or to say that I do not really need the 1st point?

    Quote Originally Posted by wolfi323 View Post
    Btw, I may have misunderstood you, but you seem to have two connections now, right?
    You do not need to keep the old connection if you create a new one.
    OTOH, you would not need to create a new one at all, you can just change the existing one in the first place.
    Yes, you're right. And I figured it out later :-)

    Quote Originally Posted by wolfi323 View Post
    Btw, back in 2014, this was still called "system connection" in the settings (in KDE at least). This has changed some time ago (in 13.2, which was released in November 2014) to be in line with newer NetworkManager (and GNOME) versions.

    Yes, current plasma-nm versions still store the password per user even when "Allow other users to connect" is activated (just like GNOME does).
    Previously, it was always stored system-wide ("make it available for all users") in that case, that's why I didn't mention it here in this thread two years ago.
    Ah Haaa, that's very interesting. Earlier this morning, someone told me that in Ubuntu, the password of wifi is stored system wide. But why we changed it? It is because storing it system-wide makes it unable to encrypt it?
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •