Results 1 to 5 of 5

Thread: WLAN funktioniert nicht: Broadcom: [14e4:4365]

  1. #1

    Default WLAN funktioniert nicht: Broadcom: [14e4:4365]

    Hallo,
    ich habe mir vor kurzem einen neuen Laptop gekauft und darauf die aktuelle Version von openSUSE aufgespielt. Allerdings funktioniert nun das WLAN nicht. Ich kann den Netzwerkcontroller zwar über Yast konfigurieren, allerdings bringt mir das nichts, da mir keine vorhandenen Netzwerke angezeigt werden und auch das Feld Drahtlos im NetworkManager ausgegraut bleibt. Ich habe mich schon im Internet umgeschaut, bin allerdings leider aufnichts gestoßen, das mir weitergeholfen hätte. Ich habe über rfkill festgestellt, dass weder Soft-, noch Hardblocks vorliegen. Im Anschluss poste ich die Ausgaube von lspci zu den Netzwerkkarten. Über eine Hilfe würde ich mich sehr freuen.

    Code:
    08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
            Subsystem: Lenovo Device [17aa:0611]
            Kernel driver in use: wl
            Kernel modules: bcma, wl
    09:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8172 Fast Ethernet [1969:10a0] (rev 10)
            Subsystem: Lenovo Device [17aa:3801]
            Kernel driver in use: alx
            Kernel modules: alx
    LG Maximilian

  2. #2

    Default AW: WLAN funktioniert nicht: Broadcom: [14e4:4365]

    Quote Originally Posted by derprovost View Post
    Code:
    08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
            Subsystem: Lenovo Device [17aa:0611]
            Kernel driver in use: wl
            Kernel modules: bcma, wl
    Ok, du hast also den broadcom wl Treiber installiert, und er scheint auch zu funktionieren.
    Dann sollte eigentlich alles passen.

    Probier mal in YaST (Netzwerkgeräte->Netzwerkeinstellungen) unter "Globale Optionen" auf "Benutzergesteuert mithilfe von NetworkManager" umzuschalten.
    Sonst funktioniert NetworkManager logischerweise nicht.

    Dann sollten eigentlich auch Drahtlosnetzwerke im Netzwerk-Applet angezeigt werden, und das Feld Drahtlos nicht mehr ausgegraut sein.

    Ansonsten müsstest du die Drahtlos-Verbindung direkt in YaST einrichten (die Schnittstelle auswählen und auf "Bearbeiten" klicken). Aber vor allem wenn du zu verschiedenen Netzwerken verbinden willst, ist das keine gute Lösung.
    Für Drahtlos ist im Allgemeinen NetworkManager besser geeignet. Deshalb wird das auch automatisch aktiviert wenn eine WLAN Karte bei der Installation entdeckt wird, deine benötigt aber einen proprietären Treiber und wurde deswegen vermutlich nicht erkannt.
    Last edited by wolfi323; 16-Aug-2014 at 02:59.

  3. #3

    Talking Re: WLAN funktioniert nicht: Broadcom: [14e4:4365]

    Vielen Dank. Jetzt funktioniert alles bestens.

  4. #4
    Join Date
    Aug 2010
    Location
    Hessens Herz
    Posts
    35

    Cool AW: WLAN funktioniert nicht: Broadcom: [14e4:4365]

    Hallo derprovost,

    Quote Originally Posted by derprovost View Post
    Ich kann den Netzwerkcontroller zwar über Yast konfigurieren, allerdings bringt mir das nichts, da mir keine vorhandenen Netzwerke angezeigt werden und auch das Feld Drahtlos im NetworkManager ausgegraut bleibt.
    Zeig doch mal die Ausgabe des folgenden Kommandos:
    Code:
    iwlist scanning
    Quote Originally Posted by derprovost View Post
    Code:
    08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
            Subsystem: Lenovo Device [17aa:0611]
            Kernel driver in use: wl
            Kernel modules: bcma, wl
    Dieses Paket installieren falls noch nicht getan:

    Code:
    zypper in broadcom-wl
    Lieben Gruß aus Hessen

  5. #5

    Default Re: WLAN funktioniert nicht: Broadcom: [14e4:4365]

    Quote Originally Posted by Herz-von-Hessen View Post
    Dieses Paket installieren falls noch nicht getan:

    Code:
    zypper in broadcom-wl
    Der wl Treiber war schon von Anfang an installiert, siehe ersten Post.

    Außerdem hast du scheinbar übersehen, dass das Problem sowieso schon gelöst ist...

    Trotzdem danke für den Versuch zu helfen!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •