Results 1 to 5 of 5

Thread: Kwrite/Kate error "KDE text-editor...not found"

  1. #1

    Default Kwrite/Kate error "KDE text-editor...not found"

    Some time in the near past, I installed something that stopped kwrite and kate. This could have been installing kate itself which is when I discovered these text editors would not start-up again.

    Error message is a pop-up window stating: "A KDE text-editor component could not be found". there is not other error message.

    I have tried starting these application using dbus-launch and get a little more information, reporting:

    Code:
    kded4: Fatal IO error: client killed
    kded(1850): Communication problem with  "kded" , it probably crashed.
    but apparently kded is still running, so this could be a false diagnosis.

    but before I dive down into the rabbit hole I thought it best f I ask advice of analyzing the fault, or how I could force a re-installation of these applications, and their dependencies (zypper in -f xxxx) only does package, not prerequisites to some level below?

    Any help much appreciated.

    System: OpenSuse 13.1

  2. #2

    Default Re: Kwrite/Kate error "KDE text-editor...not found"

    Quote Originally Posted by blacq View Post
    Error message is a pop-up window stating: "A KDE text-editor component could not be found". there is not other error message.
    This message can be caused by two things mainly:
    - You don't have libktexteditor installed. As kate and kwrite require that package, this should not happen, unless you selected "break xxx by ignoring some of its dependencies".

    - The version of libktexteditor does not match the versions of kate/kwrite and/or your KDE installation.
    This can happen f.i. if you use an additional KDE repo for a newer KDE version and don't switch all packages to that repo.

    Or when you install KDE updates, older versions of some things will keep running, which can also lead to that problem.
    In the latter case simply logging out and in again or rebooting should "fix" it.

    but before I dive down into the rabbit hole I thought it best f I ask advice of analyzing the fault, or how I could force a re-installation of these applications, and their dependencies (zypper in -f xxxx) only does package, not prerequisites to some level below?
    Do you still have them installed?
    Then zypper's -f option would force a re-install, yes. Or select "Update Unconditionally" in YaST.
    If you don't have them installed, there's no need for "-f".

    But normally a re-installation should not be necessary and probably won't help.

    Please post your repo list:
    Code:
    zypper lr -d
    and the package versions you have installed:
    Code:
    rpm -q kate kwrite libktexteditor
    Last edited by wolfi323; 11-Aug-2014 at 13:30.

  3. #3

    Default Re: Kwrite/Kate error "KDE text-editor...not found"

    Thanks for your feedback Wolfi

    Code:
    rpm -q kate kwrite libktexteditor
    kate-4.11.5-456.7.x86_64
    kwrite-4.11.5-456.7.x86_64
    libktexteditor-4.11.5-456.7.x86_64
    Code:
    zypper lr -d
    #  | Alias                        | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                               | Service
    ---+------------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
     1 | Education                    | Education                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_13.1/                |        
     2 | KDE:Extra                    | KDE:Extra                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1/               |        
     3 | KDE:KDE3                     | KDE:KDE3                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_13.1/                |        
     4 | X11:QtDesktop                | X11:QtDesktop                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/QtDesktop/openSUSE_13.1/           |        
     5 | devel:languages:perl         | devel:languages:perl               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_13.1/   |        
     6 | devel:languages:python       | devel:languages:python             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_13.1/ |        
     7 | download.nvidia.com-opensuse | nVidia Graphics Drivers            | Yes     | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/13.1/                                         |        
     8 | editors                      | editors                            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/editors/openSUSE_13.1/                  |        
     9 | ftp.gwdg.de-suse             | Packman Repository                 | Yes     | Yes     |   98     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                          |        
    10 | home:lorenz:CAM              | home:lorenz:CAM                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/lorenz:/CAM/openSUSE_13.1/        |        
    11 | multimedia:libs              | multimedia:libs                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_13.1/         |        
    12 | openSUSE-13.1-1.10           | openSUSE-13.1-1.10                 | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-ASUS_BC-12B1ST_CBD0CL129931,/dev/sr0           |        
    13 | opensuse-guide.org-repo      | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                              |        
    14 | repo-debug                   | openSUSE-13.1-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                    |        
    15 | repo-debug-update            | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                                   |        
    16 | repo-debug-update-non-oss    | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                           |        
    17 | repo-non-oss                 | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                      |        
    18 | repo-oss                     | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                          |        
    19 | repo-source                  | openSUSE-13.1-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/                   |        
    20 | repo-update                  | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                         |        
    21 | repo-update-non-oss          | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                                 |
    So it seems that I might have a newer version of kate/kwrite/libktexteditor than the kdebase:

    Code:
    rpm -qa 'kdebase4*'
    kdebase4-workspace-plasma-calendar-4.11.2-7.4.x86_64
    kdebase4-runtime-branding-openSUSE-13.1-6.5.4.x86_64
    kdebase4-workspace-liboxygenstyle-4.11.2-7.4.x86_64
    kdebase4-libkonq-4.11.2-1.1.x86_64
    kdebase4-workspace-4.11.2-7.4.x86_64
    kdebase4-runtime-4.11.2-1.1.x86_64
    kdebase4-workspace-ksysguardd-4.11.2-7.4.x86_64
    kdebase4-openSUSE-13.1-6.5.4.x86_64
    kdebase4-workspace-branding-openSUSE-13.1-6.5.4.x86_64
    kdebase4-nsplugin-4.11.2-1.1.x86_64
    kdebase4-session-4.11-2.1.2.noarch
    kdebase4-workspace-devel-4.11.2-7.4.x86_64
    So I suspect I must downgrade the kate/kwrite/libktext... or be brave and upgrade the kdebase

    Thanks

  4. #4

    Default Re: Kwrite/Kate error "KDE text-editor...not found"

    Resolved:

    Did the responsible thing and update with latest online update. Kate/Kwrite all working as normal.

    Thanks for your help.

  5. #5

    Default Re: Kwrite/Kate error "KDE text-editor...not found"

    Quote Originally Posted by blacq View Post
    Did the responsible thing and update with latest online update. Kate/Kwrite all working as normal.
    Good to hear!

    4.11.5 is just a bugfix update, so you shouldn't have to expect any problems...

    Btw, the "problem" in this case is kdelibs's plugin loader (ktexteditor is a plugin). It refuses to load plugins that don't exactly match its version.
    In your case you (probably) had kdelibs4 4.11.2 installed, which couldn't load the 4.11.5 ktexteditor.

    This version check has been relaxed in KDE 4.12, so in later versions only the minor versions have to match. (i.e. 4.11, 4.12)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •