Results 1 to 3 of 3

Thread: Patch reports kernel conflicts in freshly upgraded 13.1

  1. #1
    Join Date
    Mar 2009
    Location
    Bangkok
    Posts
    431

    Default Patch reports kernel conflicts in freshly upgraded 13.1

    I just upgraded from 12.3 to 13.1, everything went smooth. Then I added bumblebee and that installed and runs without problems, too.

    Update applets, however, tell me that a new patch cannot be installed due to conflicts. I've looked for "kernel" packages in Yast and there's one update candidate there that reports conflicts, too.

    Code:
    #### YaST2 conflicts list - generated 2014-08-08 17:31:44 ####
    
    kernel-desktop-base-3.11.10-17.2.x86_64 conflicts with kernel-desktop = 3.11.10-17.2 provided by kernel-desktop-3.11.10-17.2.x86_64
    
        [ ] do not install kernel-desktop-base-3.11.10-17.2.x86_64
    
        [ ] deinstallation of kernel-desktop-3.11.10-17.2.x86_64
    
    
    
    
    #### YaST2 conflicts list END ###
    And the patch one gives this:

    Code:
    #### YaST2 conflicts list - generated 2014-08-08 17:36:57 ####
    
    patch:openSUSE-2014-441-1.noarch conflicts with kernel-desktop.x86_64 < 3.11.10-17.2 provided by kernel-desktop-3.7.10-1.40.1.x86_64
    
        [ ] Following actions will be done:
    deinstallation of kernel-desktop-base-3.11.6-4.1.x86_64
    deinstallation of kernel-desktop-base-3.11.10-11.1.x86_64
        [ ] Following actions will be done:
    deinstallation of kernel-desktop-3.7.10-1.40.1.x86_64
    deinstallation of hdjmod-kmp-desktop-1.28_k3.7.10_1.11-14.4.3.x86_64
    deinstallation of virtualbox-guest-kmp-desktop-4.2.6_k3.7.10_1.11-3.6.11.x86_64
    deinstallation of virtualbox-host-kmp-desktop-4.2.6_k3.7.10_1.11-3.6.11.x86_64
    deinstallation of kernel-desktop-3.11.10-17.2.x86_64
    deinstallation of virtualbox-host-kmp-desktop-4.2.18_k3.11.10_17-2.15.2.x86_64
    deinstallation of virtualbox-guest-kmp-desktop-4.2.18_k3.11.10_17-2.15.2.x86_64
    deinstallation of hdjmod-kmp-desktop-1.28_k3.11.10_17-16.10.1.x86_64
        [ ] do not install patch:openSUSE-2014-441-1.noarch
    
    
    
    
    #### YaST2 conflicts list END ###
    There's "kernel-desktop-3.7.10-1.40.1.x86_64" in this list but I can't see in Yast software manager, I'd like to delete it and all other old kernels, too. How to do it safely if they don't show up in Yast?

    It's a laptop so stripped down kernel (desktop-base?) would be appreciated.

  2. #2

    Default Re: Patch reports kernel conflicts in freshly upgraded 13.1

    Quote Originally Posted by Stan_Ice View Post
    Code:
    #### YaST2 conflicts list - generated 2014-08-08 17:31:44 ####
    
    kernel-desktop-base-3.11.10-17.2.x86_64 conflicts with kernel-desktop = 3.11.10-17.2 provided by kernel-desktop-3.11.10-17.2.x86_64
    
        [ ] do not install kernel-desktop-base-3.11.10-17.2.x86_64
    
        [ ] deinstallation of kernel-desktop-3.11.10-17.2.x86_64
    
    
    
    
    #### YaST2 conflicts list END ###
    Do not try to install kernel-desktop-base. It conflicts with kernel-desktop which you already have installed.

    And the patch one gives this:

    Code:
    #### YaST2 conflicts list - generated 2014-08-08 17:36:57 ####
    
    patch:openSUSE-2014-441-1.noarch conflicts with kernel-desktop.x86_64 < 3.11.10-17.2 provided by kernel-desktop-3.7.10-1.40.1.x86_64
    
        [ ] Following actions will be done:
    deinstallation of kernel-desktop-base-3.11.6-4.1.x86_64
    deinstallation of kernel-desktop-base-3.11.10-11.1.x86_64
        [ ] Following actions will be done:
    deinstallation of kernel-desktop-3.7.10-1.40.1.x86_64
    deinstallation of hdjmod-kmp-desktop-1.28_k3.7.10_1.11-14.4.3.x86_64
    deinstallation of virtualbox-guest-kmp-desktop-4.2.6_k3.7.10_1.11-3.6.11.x86_64
    deinstallation of virtualbox-host-kmp-desktop-4.2.6_k3.7.10_1.11-3.6.11.x86_64
    deinstallation of kernel-desktop-3.11.10-17.2.x86_64
    deinstallation of virtualbox-host-kmp-desktop-4.2.18_k3.11.10_17-2.15.2.x86_64
    deinstallation of virtualbox-guest-kmp-desktop-4.2.18_k3.11.10_17-2.15.2.x86_64
    deinstallation of hdjmod-kmp-desktop-1.28_k3.11.10_17-16.10.1.x86_64
        [ ] do not install patch:openSUSE-2014-441-1.noarch
    
    
    
    #### YaST2 conflicts list END ###
    Select the first option "deinstallation of kernel-desktop-base...".

    There's "kernel-desktop-3.7.10-1.40.1.x86_64" in this list but I can't see in Yast software manager, I'd like to delete it and all other old kernels, too. How to do it safely if they don't show up in Yast?
    That's the one from 12.3.
    Select the package in YaST and click on "Versions" below the list to see _all_ available/installed versions.

    It's a laptop so stripped down kernel (desktop-base?) would be appreciated.
    No, it would not.
    Most likely your laptop would not even boot with kernel-desktop-base.
    Last edited by wolfi323; 08-Aug-2014 at 04:10.

  3. #3
    Join Date
    Mar 2009
    Location
    Bangkok
    Posts
    431

    Default Re: Patch reports kernel conflicts in freshly upgraded 13.1

    Thanks, that fixed it. Old kernels are gone, too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •