Results 1 to 4 of 4

Thread: Kaffeine unable to play videos after 13.1 upgrade

  1. #1
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question Kaffeine unable to play videos after 13.1 upgrade

    I have Kaffeine v 1.2.2 under KDE 4.11.5. Under OSS 12.3, I had installed all the necessary packman codecs. Now, I'm stumped after the 13.1 upgrade. I can't play DVDs, .mov, .avi and other file types I used to play on Kaffeine.

    Could someone please tell me how to find out what's missing? Is there a new repo I should know about? Thanks in advance!


    Linux 3.11.10-17-desktop
    Opensuse 13.1 (bottle) (x86_64)

  2. #2

    Default Re: Kaffeine unable to play videos after 13.1 upgrade

    Quote Originally Posted by HealingMindNOS View Post
    Is there a new repo I should know about?
    No, just Packman.
    You apparently used the Packman repo on 12.3, but have you changed the URL to 13.1/re-added the repo after the upgrade?

    Please post your repo-list:
    Code:
    zypper lr -d
    And check that you have "libxine2-codecs" installed, in the same version as libxine2.

    And after you verified that you have the 13.1 Packman repo added to your system, do a "full repository vendor change update" to it. Maybe you still have some packages from 12.3 installed. or some of them have been switched to the crippled OSS versions during the upgrade.
    http://en.opensuse.org/SDB:Vendor_ch..._Vendor_change
    Last edited by wolfi323; 07-Aug-2014 at 11:43.

  3. #3
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Default Re: Kaffeine unable to play videos after 13.1 upgrade

    OK, here are my current repos:
    Code:
    zypper lr -d
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                               | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------+--------
     1 | Google_Chrome             | Google Chrome                      | No      | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64/              |        
     2 | Mozilla                   | Mozilla                            | No      | Yes     |   99     | NONE   | http://download.opensuse.org/repositories/mozilla/openSUSE_13     |        
     3 | Packman_Codecs            | Packman Codecs                     | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/13.1                                 |        
     4 | Packman_Essentials        | Packman Essentials                 | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Essentials/            |        
     5 | Packman_Multimedia        | Packman Multimedia                 | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Multimedia/            |        
     6 | libdvdcss                 | libdvdcss                          | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                              |        
     7 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | No      | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-ASUS_DRW-24B1ST_c_CBD0CL044017 |        
     8 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/13.1/repo/oss/    |        
     9 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.1/                   |        
    10 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.1-non-oss/           |        
    11 | repo-non-oss              | openSUSE-13.1-Non-Oss              | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/      |        
    12 | repo-oss                  | openSUSE-13.1-Oss                  | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/          |        
    13 | repo-source               | openSUSE-13.1-Source               | No      | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.1/repo/oss/   |        
    14 | repo-update               | openSUSE-13.1-Update               | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                         |        
    15 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/
    Upon looking for libxine2-codecs at the packman repos, I found it not installed. When I attempted to install, I get the message:
    Code:
    "Nothing provides libva.so.1 (VA_API_0.33.0)(64 bit) needed by libxine2-codecs-1.2.5-90.6.x86_64
    
    "conflict resolution:
    
    1. Do not install libxine2-codecs-1.2.5-90.6.x86_64
    2. Break libxine2-codecs-1.2.5-90.6.x86_64 by ignoring some of its dependencies"
    That's a new one on me. I'm guessing that one or more of my packman repos is out of order. I'd like to make sure that I have the right packman repos before a "full repository vendor change update." I thought it was a simple matter of changing 12.3 to 13.1.

  4. #4

    Default Re: Kaffeine unable to play videos after 13.1 upgrade

    Quote Originally Posted by HealingMindNOS View Post
    OK, here are my current repos:
    They look ok, just some notes that are unrelated to your problem:
    Code:
     2 | Mozilla                   | Mozilla                            | No      | Yes     |   99     | NONE   | http://download.opensuse.org/repositories/mozilla/openSUSE_13     |
    That URL is invalid. Probably better remove that repo, even though it's disabled.

    Code:
     3 | Packman_Codecs            | Packman Codecs                     | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/13.1                                 |        
     4 | Packman_Essentials        | Packman Essentials                 | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Essentials/            |        
     5 | Packman_Multimedia        | Packman Multimedia                 | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Multimedia/            |
    You can remove 4 and 5. #3 is the complete Packman repo, and contains everything that's in #4 and #5 and more.

    Here is what causes your problem:
    Code:
    11 | repo-non-oss              | openSUSE-13.1-Non-Oss              | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/      |        
    12 | repo-oss                  | openSUSE-13.1-Oss                  | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/          |        
    14 | repo-update               | openSUSE-13.1-Update               | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                         |        
    15 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/
    All those should be _enabled_!
    You absolutely need them!

    Upon looking for libxine2-codecs at the packman repos, I found it not installed. When I attempted to install, I get the message:
    Code:
    "Nothing provides libva.so.1 (VA_API_0.33.0)(64 bit) needed by libxine2-codecs-1.2.5-90.6.x86_64
    
    "conflict resolution:
    
    1. Do not install libxine2-codecs-1.2.5-90.6.x86_64
    2. Break libxine2-codecs-1.2.5-90.6.x86_64 by ignoring some of its dependencies"
    That's a new one on me.
    libva is not found as you actually don't have any repos enabled except Packman.
    libva is in the standard openSUSE distribution though, in the OSS repo. You have to enable that repo, and you should be able to install it then.

    If you do that "full repository vendor change update" to Packman, the libxine2-codecs should be installed automatically.
    If you install it manually, you will get some conflicts. Just choose "install xxx (with vendor change) openSUSE --> Packman" (or similar) for each.

    I'm guessing that one or more of my packman repos is out of order. I'd like to make sure that I have the right packman repos before a "full repository vendor change update." I thought it was a simple matter of changing 12.3 to 13.1.
    You do have the right Packman repo.
    Last edited by wolfi323; 07-Aug-2014 at 14:15.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •