Results 1 to 6 of 6

Thread: Samba setup question

  1. #1

    Default Samba setup question

    Hello!

    I am new to Linux (coming from SCO) and trying to get up to speed with openSuse 13. I am trying to setup a root (/) share in Samba that is accessible from Windows 7 and am not having any luck. Yes, I know this a bad idea, but this is a training setup and I would never do it in a production setting. All my other shares are working fine. The following are the relevant smb.conf entries:

    [root]
    comment = root directory
    path = /
    read only = no
    writeable = yes
    browseable = yes
    valid users = {username}
    force user = root
    force group = root
    admin users = {username}

    The force entries were just me throwing darts, don't know if they are needed or not.

    Whenever I access the the root share from windows it requests a login/password which it never validates. I believe the error is in my Suse setup as I get the following error in /var/log/messages:
    smbd: Ignoing unknown parameter "encrypt passwd"

    The smb.conf is set to encrypt passwd = yes as is Windows 7 and my SCO6 box (older version of samba but no access problems). Again all of other Suse shares access and function normally from windows. Any help or guidance would be greatly appreciated!

    Thank you,
    Jim

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,022

    Default Re: Samba setup question

    It's encrypt passwords = True and you're most likely blocked by AppArmo(u)r because sharing root is a bad idea.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: Samba setup question

    Thank you for your reply. Although I believe True and yes are interchangeable, I did make the change in smb.conf. I also stopped the apparmor service and am still having the same issue.

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,022

    Default Re: Samba setup question

    No I meant it's "Encrypt Passwords", not "Encrypt passwd" like you had in your error report.

    Looks at /var/log/samba/log.smbd for errors and raise your debug / loglevel in smb.conf to see what is causing the rejection - something like log level = 3 should dump a fair bit of data.

    And I still think it's AppArmor - Launch yast2-apparmor and go to Manage Existing Profiles, set smbd to "Complain" and restart the services.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  5. #5

    Default Re: Samba setup question

    Miuku,

    Sorry for the delay in responding, but I've been reading up on the information you gave me. I did have the encrypt passwd set correctly, it was just the shorthand I used typing up the message. My fault, I'll be more careful in the future. Once I set smbd to complain in AppArmor, I was able to access what I wanted with the proper samba settings. I won't leave it that way, but it will at least let me accomplish what I want for the short term. Thank you again for your assistance.

    Jim

  6. #6
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,022

    Default Re: Samba setup question

    No problem.

    AppArmor allows you to fine tune what directories Samba (and other services) can access - the root limitation is a logical one, it prevents inexperienced (don't that as a negative :-) ) administrators from accidentally allowing too much access to the system and compromising security.

    It's a great, if somewhat obscure, tool. It does, however, log all the errors, complaints and warnings so it's easy to find out what is preventing access and why.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •