Results 1 to 6 of 6

Thread: Embedded PDF in Firefox mangles math.

  1. #1

    Default Embedded PDF in Firefox mangles math.

    I am accessing the PDF from this site: http://www.fourierandwavelets.org/

    This is the URL for the PDF: http://www.fourierandwavelets.org/FSP_v1.1_2014.pdf

    When I look at the preferences->applications in Firefox, PDF is set to Preview in Firefox. Apparently the previewer is part of Firefox, and not Okular, which is what Konqueror is obviously using. Is there a way to change this behavior? Are others seeing the same thing? I know (or believe) Acrobat is no longer maintained for Linux.

    This is what it looks like in Firefox. Note the summation range is place on the base of the sigma, not under it, where it belongs.



    In Konqueror it looks like this. Note that the mathematical symbols are properly placed.


  2. #2

    Default Re: Embedded PDF in Firefox mangles math.

    Now I'm even more confused. If I brows to the site http://www.fourierandwavelets.org and click the image to open the PDF Konqueror offers the option to open the file, or to download it. It doesn't embed the viewer. If I put the URL http://www.fourierandwavelets.org/FSP_v1.1_2014.pdf directly into the location field the display in embedded.

    Changing the file association settings seems to have no impact on this behavior.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,897
    Blog Entries
    3

    Default Re: Embedded PDF in Firefox mangles math.

    Firstly, I am not at all sure why you see this as a problem.

    Using firefox, and scrolling to the same page (p. 23), it looks okay to me. I am not seeing the improperly placed symbols that you see.

    I'll note that I am running "factory" on the system where I tested this, and I have desktop effects disabled. I'm not sure whether either of those is relevant. I can try later on factory with desktop effects enabled, or on 13.1, if you think it worth the effort.

    The system where I tried this is using Intel graphics (Ivy bridge). It might be a graphics problem on your system that is messing up the symbol placement.

    The reason that I don't see it as a problem, is that it is every easy to download with firefox. I just clicked the download arrow (on the pdf viewer header). This was quick, because it was just storing the copy that it already had for its pdf viewer. Once downloaded, I can read with "okular", where it seems quite readable.

    I then tried with konqueror (again, running factory). I browsed to the page, then clicked on the link. The document opened in konqueror's pdf viewer and looks similar to reading in okular.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Embedded PDF in Firefox mangles math.

    In FF 31.0 OS 13.1 the PDF viewer also does not render subscripts correctly here. Downloading and viewing in okular it renders right


    Odd

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Embedded PDF in Firefox mangles math.

    On 2014-08-07 19:06, gogalthorp wrote:
    >
    > In FF 31.0 OS 13.1 the PDF viewer also does not render subscripts
    > correctly here. Downloading and viewing in okular it renders right


    I gave up on the FF internal PDF viewer long ago, it has many errors.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Embedded PDF in Firefox mangles math.

    Quote Originally Posted by hattons View Post
    I am accessing the PDF from this site: http://www.fourierandwavelets.org/

    This is the URL for the PDF: http://www.fourierandwavelets.org/FSP_v1.1_2014.pdf

    When I look at the preferences->applications in Firefox, PDF is set to Preview in Firefox. Apparently the previewer is part of Firefox, and not Okular, which is what Konqueror is obviously using. Is there a way to change this behavior? Are others seeing the same thing? I know (or believe) Acrobat is no longer maintained for Linux.
    I see the same using the Nightly development build of Firefox 34.0a1 with an updated pdf.js version.

    To answer your question on how change the behavior.

    Go to Preferences > Applications > Portable Document Format (PDF), click on Preview in Firefox and change the Action to the viewer of your choice.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •