I upgraded recently from 12.<someting>/LXDE to 13.1/LXDE.
upgrade was made reformatting the root partition, but keeping the hold home partition.

One day I discovered that libreoffice was not able anymore to open hyperlinks whose name contains spaces, accents, umlaut etc.

I get the problem on calc, but also write suffer from the same bug.

As first step I tried to upgrade libreoffice, installing 4.2 --> no change

Then I tried to file a bug to the libreoffice community.
Nobody was able to reproduce the bug, but I discover that the problem is the following:
when one ctrl-clicks on a libreoffice hyperlink, libreoffice calls its own "open-url" program,
then in turns calls xdg-open with the parameter file:///path/name%20with%20spaces
xdg-open calls pcmanfm, with the parameter /path/name%20with%20spaces
and pcmanfm is not able to find the file named name%20with%20spaces, and emit the error message that I saw.

people of libreoffice concluded "Not Our Bug" and suggested to file a bug report to pcmanfm community, since
"their file manager isn't interpreting commands correctly like other file managers".

I filed the bug with pcmanfm, and their answer was "Not Our Bug". They said that xdg specifications say that "/path/to/some%20file is exactly the some%20file in the directory /path/to, while file:///path/to/some%20file is the some file in the directory /path/to at localhost", and the bug has to be filed against xdg-open.
Reasonable.

Then I look for xdg-open. For what I found understood that the Porland project is poorly maintained.... no chance.


Questions:
Is somebody else experiencing the same problem, or the problem is limited to my special configuration?
Do somebody has ideas how to solve the problem? (I patched pcmanfm, but this is *not* the solution)

rrossi1