Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Unplugging laptop charger disables sound (13.1)

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,986
    Blog Entries
    1

    Default Re: Unplugging laptop charger disables sound (13.1)

    Quote Originally Posted by alvanx View Post
    Might there be some sort of log that could help me understand what is going on in the moment of unplugging? I am only marginally familiar with these things, but could something in /var/log/ or even .xsession-errors record stuff like this? If yes, what would I have to look out for in the log file?
    1. Okay, clearly the options to prevent power saving do not seem be having an effect. Try removing all the power saving parameters in /etc/modprobe.d/50-sound.conf as oldcpu suggested
    Code:
    options snd slots=snd-hda-intel
    Then restart the sound system with
    Code:
    systemctl restart alsasound.service
    For that matter, does restarting alsasound.service (when on battery) cause your sound to be re-enabled? (Try running a sound test just after it is run.)

    2. Could you please tell us your laptop make and model. (Perhaps there is a hardware feature/quirk behind this that is not Linux-specifc?)

  2. #12
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Unplugging laptop charger disables sound (13.1)

    Quote Originally Posted by alvanx View Post
    I am not sure what you mean by my sound being muted.
    I obtained that from the script output you provided. Previous your mixer showed this:
    Code:
    Simple mixer control 'Speaker',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 74
      Mono:
      Front Left: Playback 0 [0%] [-74.00dB] [on]
      Front Right: Playback 0 [0%] [-74.00dB] [on]
    With Speaker playback volume set to 0% that mutes the sound. I hope that clarifies that for you.


    Now currently it shows this:
    Code:
    Simple mixer control 'Master',0
      Capabilities: pvolume pvolume-joined pswitch pswitch-joined
      Playback channels: Mono
      Limits: Playback 0 - 74
      Mono: Playback 34 [46%] [-40.00dB] [on]
    Simple mixer control 'Headphone',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 74
      Mono:
      Front Left: Playback 0 [0%] [-74.00dB] [off]
      Front Right: Playback 0 [0%] [-74.00dB] [off]
    Simple mixer control 'Speaker',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 74
      Mono:
      Front Left: Playback 74 [100%] [0.00dB] [on]
      Front Right: Playback 74 [100%] [0.00dB] [on]
    Do I need to highlight this in colour for you to see the settings ?

    Now this is better, as the 'speaker' control is at 100%, where before it was at 0% . But your 'Master' volume playback at 46% is pretty low - it may be so low you can not hear anything. And your headphones are muted.
    Last edited by oldcpu; 11-Aug-2014 at 09:20.

  3. #13

    Default Re: Unplugging laptop charger disables sound (13.1)

    Thank you all for your helpful comments thus far. Please excuse my slow response. :-)

    I tried clearing /etc/modprobe.d/50-sound.conf by backing up the file. The current file is now empty. This didn't change anything, and restarting ALSA doesn't restore the sound either.

    One thing that still helps though is when I use Yast to reset the sound system. If we could find out what command Yast uses for this, that may take us one step further.

    For about a week now I have had another sound problem that is just as troubling: If I want my internal speakers to work, I have to plug in headphones (which have sound) and unplug them. Only then do I get sound on my internal speakers.

    This is driving me bonkers. :-)

    Do you think that my kernel 3.14 may be the issue? Could a newer kernel fix this?

    Thanks again.


    @oldcpu: Thank you for your illustration. Since I'm able to have sound under certain conditions, I'm not sure that a too low master volume would be the problem. Still, it's weird how these settings seem to change.

  4. #14
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Unplugging laptop charger disables sound (13.1)

    Quote Originally Posted by alvanx View Post
    I tried clearing /etc/modprobe.d/50-sound.conf by backing up the file. The current file is now empty. This didn't change anything, and restarting ALSA doesn't restore the sound either.

    One thing that still helps though is when I use Yast to reset the sound system. If we could find out what command Yast uses for this, that may take us one step further.

    For about a week now I have had another sound problem that is just as troubling: If I want my internal speakers to work, I have to plug in headphones (which have sound) and unplug them. Only then do I get sound on my internal speakers.
    I need to see the output of the alsa-info.sh script file, immediately after the problem occurs, BEFORE you start adjusting any configuration settings. That last output CLEARLY indicated a problem with the mixer settings. But that may not be the only problem.

    Quote Originally Posted by alvanx View Post
    Do you think that my kernel 3.14 may be the issue? Could a newer kernel fix this?
    Maybe it will. We are fortunate that at least one, and maybe more, alsa sound driver developer(s) is/are a member of the SuSE-GmbH team that packages openSUSE. If you write a bug report on openSUSE describing your problem, they have a better chance of anyone in answering the question you asked. For certain, they WILL ask for the script output, that I asked for. There is guidance here wrt writing bug reports. http://en.opensuse.org/openSUSE:Submitting_bug_reports You can use your openSUSE user name and password when logging on to bugzilla.

  5. #15

    Default Re: Unplugging laptop charger disables sound (13.1)

    Here you go!

    Filing a bug definitely sounds like an option. I'll just see how far we get here.

    Thanks again.

  6. #16
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Unplugging laptop charger disables sound (13.1)

    Quote Originally Posted by alvanx View Post
    Here you go!

    Filing a bug definitely sounds like an option. I'll just see how far we get here.

    Thanks again.
    That one reads like it has options in the /etc/modprobe.d/50-sound.conf file that completely breaks the sound, and those options should ALL be removed.

    I type that because I note:
    Code:
    !!Modprobe options (Sound related)
    !!--------------------------------
    
    snd-hda-intel: power_save_controller=0 power_save_controller=N
    and I note:

    Code:
    !!Aplay/Arecord output
    !!--------------------
    
    APLAY
    
    aplay: device_list:268: no soundcards found...
    
    ARECORD
    
    arecord: device_list:268: no soundcards found...
    I recommend you remove the /etc/modprobe.d/50-sound.conf file, restart your PC and try again from scratch to sort the sound. I also suspect in any bug report, the SuSE-GmbH packagers who address the bug report will also ask you to clean up that file (where the easiest way is to remove it, as it will be created again from YaST).

  7. #17

    Default Re: Unplugging laptop charger disables sound (13.1)

    That's strange because that's exactly what I did!

    For a few days the file didn't even exist, until Yast recreated it when I tried to reset the sound system. Now, it is possible that I made some changes to it through Yast inadvertently. Let me try it again just to be sure.

    This is how 50-sound.conf looks right now:
    Code:
    options snd slots=snd-hda-intel# u1Nb.QgEwyVEnfB3:Intel Corporation
    alias snd-card-0 snd-hda-intel
    I 1. renamed the file, 2. restarted alsa, 3. let Yast configure the sound.

    And this is the new 50-sound.conf Yast created:
    Code:
    options snd slots=snd-hda-intel# u1Nb.QgEwyVEnfB3:Intel Corporation
    alias snd-card-0 snd-hda-intel
    Am I the only one who is confused by this? :-)

    And just to be sure: Here's the output of /usr/sbin/alsa-info.sh after what I just tried.

  8. #18
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Unplugging laptop charger disables sound (13.1)

    Quote Originally Posted by alvanx View Post
    This is how 50-sound.conf looks right now:
    Code:
    options snd slots=snd-hda-intel# u1Nb.QgEwyVEnfB3:Intel Corporation
    alias snd-card-0 snd-hda-intel
    I 1. renamed the file, 2. restarted alsa, 3. let Yast configure the sound.
    Don't just rename the file. Any file in that /etc/modprobe directory can be loaded, independant of the file name. If you want to keep the old version you need to MOVE the file to a different directory.

    Quote Originally Posted by alvanx View Post
    And this is the new 50-sound.conf Yast created:
    Code:
    options snd slots=snd-hda-intel# u1Nb.QgEwyVEnfB3:Intel Corporation
    alias snd-card-0 snd-hda-intel
    Am I the only one who is confused by this? :-)

    And just to be sure: Here's the output of /usr/sbin/alsa-info.sh after what I just tried.
    Thats an improvement, but the problem is still there !! I note:
    Code:
    !!Modprobe options (Sound related)
    !!--------------------------------
    
    snd-hda-intel: power_save_controller=0 power_save_controller=N
    I think those options are coming from the backup/renamed file you have in place in the /etc/modprobe directory. You need to remove that backup file and put it elsewhere. That is highly likely to be causing some problems.

    Now I also note your laptop's mixer has the sound muted with playback at 0%.
    Code:
    Simple mixer control 'Speaker',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 74
      Mono:
      Front Left: Playback 0 [0%] [-74.00dB] [on]
      Front Right: Playback 0 [0%] [-74.00dB] [on]
    Again ... do NOT store backups in the /etc/modprobe directory.

  9. #19
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Unplugging laptop charger disables sound (13.1)

    Quote Originally Posted by oldcpu View Post
    Don't just rename the file. Any file in that /etc/modprobe directory can be loaded, independant of the file name. If you want to keep the old version you need to MOVE the file to a different directory.
    .......
    Again ... do NOT store backups in the /etc/modprobe directory.
    That should read "do NOT store backups in the /etc/modprobe.d directory"

  10. #20

    Default Re: Unplugging laptop charger disables sound (13.1)

    Quote Originally Posted by oldcpu View Post
    Don't just rename the file. Any file in that /etc/modprobe directory can be loaded, independant of the file name.
    Not quite.
    Only files that end in .conf are loaded. See "man modprobe.d":
    All files underneath the /etc/modprobe.d directory which end with the .conf extension specify those
    options as required.
    So it is actually ok to rename it to 50-sound.conf.old or similar.
    YaST itself does this by the way, it keeps the old file as "50-sound.conf.YaST2save" (or correspondingly for other config files).

    Of course the OP didn't say to _what_ he renamed the file, so it might still be the cause of the problem...

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •