Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: yast2 kde theme on gnome - openSUSE factory

  1. #1

    Default yast2 kde theme on gnome - openSUSE factory

    Hi,

    I just upgrade from opensuse 13.1 to opensuse Factory without major problems. However, when I open Settings > YaST, YaST has a KDE theme, even though I use the Gnome desktop manager.

    I do believe that it is related to the package yast2-branding-openSUSE. I uninstalled it during the distribution upgrade, and when I try to install it on Factory, I have:

    Code:
    sudo zypper in yast2-branding-openSUSE
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides yast2-theme-openSUSE-any needed by yast2-branding-openSUSE-3.1.0-1.2.noarch
     Solution 1: do not install yast2-branding-openSUSE-3.1.0-1.2.noarch
     Solution 2: break yast2-branding-openSUSE-3.1.0-1.2.noarch by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    Any ideas?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: yast2 kde theme on gnome - openSUSE factory

    As root, try:
    Code:
    # yast2 --gtk
    Does that give you what you want? Or is the theme still wrong?
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: yast2 kde theme on gnome - openSUSE factory

    I tried your command and I get this :

    http://i.imgur.com/dfR7BJT.png

    I would expect something like this :

    http://regmedia.co.uk/2013/11/27/ope...min_tools2.jpg


    It seems like only the icons are wrong. It is not a big problem, but it is inconsistent with the rest of the Gnome environment.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: yast2 kde theme on gnome - openSUSE factory

    It is going to be using the theme configured (or default) for the root account, rather than what you configured for your account.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5

    Default Re: yast2 kde theme on gnome - openSUSE factory

    Quote Originally Posted by gariepya View Post
    It seems like only the icons are wrong. It is not a big problem, but it is inconsistent with the rest of the Gnome environment.
    There are two different yast2-theme packages available (those contain the icons).

    Your picture looks like yast2-theme-openSUSE-Oxygen.
    The other one is yast2-theme-openSUSE-Crystal which is the old KDE3-style.

    I don't see any other icon styles available (in the standard 13.1 repos at least), sorry.

    Btw, YaST GTK's icons look the same here in 13.1. Are you sure you only see this since upgrading to Factory?

  6. #6

    Default Re: yast2 kde theme on gnome - openSUSE factory

    Yes, when I was in 13.1 I had the icons of the second link

  7. #7

    Default Re: yast2 kde theme on gnome - openSUSE factory

    Quote Originally Posted by gariepya View Post
    Yes, when I was in 13.1 I had the icons of the second link
    Well, I get the same ("KDE", as you name them) icons on 13.1, even when logged in to GNOME:



    OTOH, I noticed now that the icons you are expecting are in fact contained in the package "yast2-theme-openSUSE".
    And I succeeded in making them used now (even in KDE ) by uninstalling "yast2-theme-openSUSE-Oxygen" and running "sudo gtk-update-icon-cache-3.0 /usr/share/icons/hicolor/" afterwards (the latter is important, without that the oxygen icons were still used even though they weren't installed any more):

    Now YaST GTK still uses the hicolor icons even after re-installing yast2-theme-openSUSE-Oxygen, so maybe it isn't even necessary to uninstall that but only run that gtk-update-icons line...

    This was on 13.1 though, but you can at least try that on Factory...
    Last edited by wolfi323; 13-Aug-2014 at 03:08.

  8. #8

    Default Re: yast2 kde theme on gnome - openSUSE factory

    On factory, when I do "sudo zypper rm yast2-theme-openSUSE-Oxygen", it also removes yast2-control-center and yast2-control-center-gnome.

    I did:
    Code:
    sudo zypper rm yast2-theme-openSUSE-Oxygen
    sudo gtk-update-icon-cache-3.0 /usr/share/icons/hicolor/
    sudo zypper in yast2-control-center
    and when I open Yast in the settings, there are no icons at all. If I then do:
    Code:
    sudo zypper in yast2-theme-openSUSE-Oxygen
    sudo gtk-update-icon-cache-3.0 /usr/share/icons/hicolor/
    The icons I don't want are back.

  9. #9

    Default Re: yast2 kde theme on gnome - openSUSE factory

    Quote Originally Posted by gariepya View Post
    On factory, when I do "sudo zypper rm yast2-theme-openSUSE-Oxygen", it also removes yast2-control-center and yast2-control-center-gnome.
    Ok, that might indicate something...
    Probably that was an intended change.

    The icons I don't want are back.
    Well, I cannot try that in my Factory VM at the moment, I don't have enough space to install GNOME as well.

    The only thing I can say now:
    If you feel this is a bug, please report it.
    http://bugzilla.novell.com/ (same username/password as here)

  10. #10

    Default Re: yast2 kde theme on gnome - openSUSE factory

    Thank you for your help

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •