Results 1 to 8 of 8

Thread: Skype, flash, Pulseaudio not working together

  1. #1

    Default Skype, flash, Pulseaudio not working together

    Skype service refused to serve older clients, and users have to install the latest versions, for all OSes.

    For Linux, the version is 4.3.0.37.

    This version is a spoilage, as expected. No new features added, but it requires Pulseaudio server in order to reproduce sound.

    In addition, the CPU consumption is huge and on small laptops Skype and Pulseaudio together can consume 100% of the CPU and the conversation becomes choppy.

    I installed that latest version of Skype, started Pulseaudio. Now a new problem emerges: flash in Firefox crashes when Skype is running. If flash is started first, then Skype cannot reproduce sound, but, once the flash is terminated, Skype plays sounds again, as if it had queued them.

    In kmix, it looks like flash player's control is confused with that of Skype's. In pavucontrol, all seems correct.

    So, this is total mess, probably because of two closed-source developments.

    Any suggestions?

  2. #2

    Default Re: Skype, flash, Pulseaudio not working together

    Quote Originally Posted by ZStefan View Post
    Any suggestions?
    Check that alsa-plugins-pulse is installed.
    That forces applications that use ALSA to use PulseAudio instead, which is necessary because PulseAudio grabs ALSA and blocks all other programs from using it.

  3. #3

    Default Re: Skype, flash, Pulseaudio not working together

    Quote Originally Posted by wolfi323 View Post
    Check that alsa-plugins-pulse is installed.
    That forces applications that use ALSA to use PulseAudio instead, which is necessary because PulseAudio grabs ALSA and blocks all other programs from using it.
    Both 32 and 64 bit versions are installed. Skype's rpm requires the 32 bit version of alsa-plugins-pulse.

  4. #4

    Default Installation of the 32 and 64 bit versions solves the problem.

    Quote Originally Posted by wolfi323 View Post
    Check that alsa-plugins-pulse is installed.
    That forces applications that use ALSA to use PulseAudio instead, which is necessary because PulseAudio grabs ALSA and blocks all other programs from using it.
    Sorry for the previous reply - only 64 bit version was installed. For some reason, the 32 bit version was marked as "Taboo -- Never install". I don't remember doing it, so I don't know how it happened. In fact, the package was required for Skype installation.

    I have now installed both versions of alsa-plugins-pulse package, and Skype and flash seem to work simultaneously without conflict.

    Thanks for the help. I had the wrong knowledge that, since Skype required the 32 bit version for installation, the package was there.

  5. #5

    Default Re: Installation of the 32 and 64 bit versions solves the problem.

    Quote Originally Posted by ZStefan View Post
    Thanks for the help. I had the wrong knowledge that, since Skype required the 32 bit version for installation, the package was there.
    Hm. I thought Skype is using PulseAudio directly now?
    Then alsa-plugins-pulse shouldn't be needed at all for Skype. (you still need it for flash-player though, but that is available as 64bit version anyway)

    Anyway, good to hear that it's working now...

  6. #6
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: Skype, flash, Pulseaudio not working together

    4.3 or newer requires PA and doesn't work with ALSA.

    Which I don't personally like but hey that's how things go.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  7. #7

    Default Re: Skype, flash, Pulseaudio not working together

    Quote Originally Posted by Miuku View Post
    4.3 or newer requires PA and doesn't work with ALSA.
    Yes, at least the announcement states this.

    But as I understand it, if it would use PA directly it shouldn't need (or be affected by) alsa-plugins-pulse.
    The alsa plugins are only needed for applications using ALSA, those applications then get re-routed to PA by the plugin.

    So apparently Skype does still use ALSA for sound output. Maybe it uses/needs PA for specific other functions only?

    Anyway, doesn't really matter here now...

    Which I don't personally like but hey that's how things go.
    I don't like that either.
    But well, I'm not using Skype anyway. (and definitely won't any time soon... )

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Skype, flash, Pulseaudio not working together

    Flash can consume a large amount of memory and maybe it still uses alsa?? So if the machine is memory constrained (under 2gig these days) it may be a problem to run 2 memory hogs at the same time both vying for the same resources.

    I had problems running multiple memory hogs with my old MB single core with 2 gig my new one with a 6 core AMD and 8 gig I see no problems.

    I don't understand it no one should need more then 640K memory after all

    .

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •