Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

  1. #1

    Default i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    hello! i can't find an update button in yast sw managerafter searching for xscreensaver

    Code:
    The `xscreensaver' program is a daemon that runs in the background.
        You control a running xscreensaver process by sending it messages
        with `xscreensaver-demo' or `xscreensaver-command'.
    .   See the man pages for details, or check the web page:
        http://www.jwz.org/xscreensaver/
    
    frank[5808] xscreensaver --help
    xscreensaver 5.22, copyright (c) 1991-2013 by Jamie Zawinski <jwz@jwz.org>
    
      All xscreensaver configuration is via the `~/.xscreensaver' file.
      Rather than editing that file by hand, just run `xscreensaver-demo':
      that program lets you configure the screen saver graphically,
      including timeouts, locking, and display modes.
    
      Just getting started?  Try this:
    
            xscreensaver &
            xscreensaver-demo
    
      For updates, online manual, and FAQ, please see the web page:
    
           http://www.jwz.org/xscreensaver/
    whatis the processto update this app with the 13.1 yast > sw manager? heboland.

  2. #2

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    Quote Originally Posted by heboland View Post
    hello! i can't find an update button in yast sw managerafter searching for xscreensaver

    ...whatis the processto update this app with the 13.1 yast > sw manager? heboland.
    Right-click on the package and select "update", or select the package and select "Update" from the "Package" menu, or click on the box next to the package until it shows a green arrow-up.

    But there is no update for 13.1's xscreensaver.
    If you want to install a newer one, you have to add an extra repo.
    http://software.opensuse.org/package/xscreensaver
    Click on "Show other versions" and then "Show possibly unstable packages".

    On KDE you should not use it anyway. KDE has its own screensaver which can even use xscreensaver's modules.
    Configure it in "Configure Desktop"->"Display and Monitor"->"Screen Locker".

    And regarding the subject: where do you get that message?

  3. #3

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    wolfi323, the old ss message pops upwhen the screen saver startts, then disappears. i have lx de installed along with some extra xscreen saver rpms to get the gl slide show i'll try to add the new repository and see if i can find an update. what i use now needs the perl www library fwiw.

    heboland

  4. #4

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    the add reprodidn'tfair very well!- LOTS of errors1! I CAN LIVE WITHOUT it,but i've enjoyed gl slideshow for a long time before 13.1

    i'll show some of them, bu t this is what i getwhen i try toset the parameters!
    HTML Code:
    This version of xscreensaver is VERY OLD!Please upgrade!http://www.jwz.org/xscreensaver/(If this is the latest version that your distro ships, thenyour distro is doing you a disservice. Build from source.
    HTML Code:
    An error occurred while initializing the software repository.
    Details:
    openSUSE:13.1:Ports: [|] Valid metadata not found at specified URL
    History:
     - [|] Repository type can't be determined.
    
    Try again?
    maybe the new repros can be sorted out yet. maybe this leads to a tarball//www.jwz.org/xscreensaver/.i can build

    besides the lxde, i have a iot of kde apps installed - dolphin, kio slavek3b, is the kde screensaver a stand alone package?

    any recommendations for me at this point? heboland.

  5. #5

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    i found another postthat seems related to my plight this is the result of the advice offered him!
    Code:
    frank[5811] su
    Password: 
    root[501] zypper lr --details
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                    | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------+--------
     1 | ftp.gwdg.de-suse          | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/               |        
     2 | libdvdcss repository      | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                   |        
     3 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_DVD+_-RW_TS-L632H,/dev/sr0 |        
     4 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/         |        
     5 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                        |        
     6 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                |        
     7 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/           |        
     8 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/               |        
     9 | repo-source               | openSUSE-13.1-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/        |        
    10 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                              |        
    11 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                      |        
    root[502]
    also i had the chance to download a file, but it's not an rpm.but ratherxscreensaver.ymp. what should i do witrh that?heboland

  6. #6

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    i found an rpm from suse build service,but it doesn't connect!
    HTML Code:
    425 Failed to establish connection.
    the source rpm downloads.i can probably build it. there doesn/t seem to be an easy way out of this mess! heboland.

  7. #7
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,002

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    32-bit:
    Code:
    http://download.opensuse.org/repositories/home:/openSUSE_user1/openSUSE_13.1/i586/xscreensaver-5.29-48.3.i586.rpm
    64-bit:
    Code:
    http://download.opensuse.org/repositories/home:/openSUSE_user1/openSUSE_13.1/x86_64/xscreensaver-5.29-48.3.x86_64.rpm
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  8. #8

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    So you get that message from LXDE apparently.

    Quote Originally Posted by heboland View Post
    HTML Code:
    An error occurred while initializing the software repository.
    Details:
    openSUSE:13.1:Ports: [|] Valid metadata not found at specified URL
    History:
     - [|] Repository type can't be determined.
    
    Try again?
    That's an incorrect repo. openSUSE:13.1orts only contains the distribution for ARM and PPC CPUs, not standard x86/x86_64.

    Miuku already pointed you to the correct packages, but you would need to update xscreensaver-data as well I suppose.
    So better add the repo:
    Code:
    sudo zypper addrepo http://download.opensuse.org/repositories/home:openSUSE_user1/openSUSE_13.1/home:openSUSE_user1.repo
    Then search for "screensaver" in YaST, select each installed package, and update it to the 5.29 version on the "Versions" tab below the repo list. (if you're using the GTK version of YaST, there won't be a "Versions" tab, but IIRC you should have buttons for all available versions on the bottom-right).

    besides the lxde, i have a iot of kde apps installed - dolphin, kio slavek3b, is the kde screensaver a stand alone package?
    Well, there is an kdeartworks4-screensavers package that you need to use the xscreensavers in KDE.
    But KDE's screensaver/screenlocker itself is part of the desktop, you cannot use it in LXDE.

    also i had the chance to download a file, but it's not an rpm.but ratherxscreensaver.ymp. what should i do witrh that?
    A .ymp is a so-called "1-click install". If you open it, the repo should be added and the package(s) installed. But this doesn't work with Chrome/Chromium.
    Last edited by wolfi323; 02-Aug-2014 at 04:40.

  9. #9

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    Miuku. thanks for the rpm link! let that let me move the version to5.29 and the screen saver is working again
    Code:
    xscreensaver-5.29-48.3.i586.rpm
    Pay1040_receipt_31.7.2014.pdf  xscreensaver.ymp
    printerrpm/
    frank[5814] su
    Password: 
    root[501] zypper in xscreensaver-5.29-48.3.i586.rpm
    System management is locked by the application with pid 2366 (/usr/lib/YaST2/bin/y2base).
    Close this application before trying again.
    root[502] zypper in xscreensaver-5.29-48.3.i586.rpm
    Retrieving repository 'openSUSE:13.1:Ports' metadata ....................[error]
    Repository 'openSUSE:13.1:Ports' is invalid.
    [|] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Disabling repository 'openSUSE:13.1:Ports'.
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following package is going to be upgraded:
      xscreensaver 
    
    The following package is going to change vendor:
      xscreensaver  openSUSE -> obs://build.opensuse.org/home:openSUSE_user1
    
    
    1 package to upgrade, 1 to change vendor.
    Overall download size: 516.3 KiB. After the operation, 9.5 KiB will be freed.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package xscreensaver-5.29-48.3.i586
                                               (1/1), 516.3 KiB (  2.1 MiB unpacked)
    (1/1) Installing: xscreensaver-5.29-48.3 .................................[done]
    Additional rpm output:
    warning: /var/cache/zypp/packages/_tmpRPMcache_/xscreensaver-5.29-48.3.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 654eee7b: NOKEY
    
    
    There are some running programs that use files deleted by recent upgrade. You may wish to restart some of them. Run 'zypper ps' to list these programs.
    root[502] 'zypper ps'
    zsh: command not found: zypper ps
    root[503] zypper ps
    The following running processes use deleted files:
    
    PID  | PPID | UID  | Login | Command      | Service | Files                     
    -----+------+------+-------+--------------+---------+---------------------------
    1169 | 1061 | 1000 | frank | xscreensaver |         | /usr/bin/xscreensaver (d->
    
    You may wish to restart these processes.
    See 'man zypper' for information about the meaning of values in the above table.
    root[504]
    yasy>
    there are lot of locks between sw management and the add repros now, idisabled the repros i added previously, but the sw managerffailed to start.
    HTML Code:
    Accessing the sw management failedagement system managementis locked by the application with pid 2054 (/usr/lib/YaST2/bin/y2base).
    Close this application before trying again.
    
    Would you like to abort or try again?
    this comes fromtrying to add repros with sw manager still open.
    HTML Code:
    Accessing the sw management failedagement system managementis locked by the application with pid 2054 (/usr/lib/YaST2/bin/y2base).
    Close this application before trying again.
    
    Would you like to abort or try again?
    thanks gor your help with this!heboland
    i think i have what i wanted

  10. #10

    Default Re: i'm getting the message from 13.1 on a laptop xscreensaver is very 0ld please upgrade

    Quote Originally Posted by heboland View Post
    this comes fromtrying to add repros with sw manager still open.
    Yes.
    You can run only one instance of the software management tools at the same time.
    Close "Software Management" if you want to open "Software Repositories" and vice versa.
    Btw, there is a menu item in YaST->Software Management to switch to "Software Repositories", it's in the "Configuration" menu.

    This applies to zypper as well: If you want to run zypper you have to close YaST, and the other way round. You cannot run YaST->Software Management (or Software Repositories) while zypper is running. And you cannot run two instances of zypper at the same time either (in separate xterm windows f.e.).

    As I said already, you probably should update xscreensaver-data and xscreensaver-data-extra (if you have it installed) as well.
    Here the package links for those:
    http://download.opensuse.org/reposit...-48.3.i586.rpm
    http://download.opensuse.org/reposit...-48.3.i586.rpm

    Or add the repo as already suggested, and update with YaST.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •