Results 1 to 3 of 3

Thread: Opensuse 13.1 GNOME - Nautilus file manager (main window) doesn't show/use window themes...

  1. #1

    Question Opensuse 13.1 GNOME - Nautilus file manager (main window) doesn't show/use window themes...

    Nautilus file manager (main window) doesn't show/use window themes... even when set a theme with gnome tweak tool

    but dialog windows and other programs show window themes correctly
    (see image)

    maybe there's a way to set this but i don't know...

    (open in new window / tab)


    (open in new window / tab)
    made a bug-report for this here


    ..

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,002

    Default Re: Opensuse 13.1 GNOME - Nautilus file manager (main window) doesn't show/use window themes...

    From reading Ubuntu guys talk about it, it's a "feature" in the Nautilus browser which they now consider a "complete catastrophe".

    Have you considered using the Cinnamon's "Nemo" file manager? It looks like this (taken from a VM in which I just installed GNOME and Nemo to look at it, hehe)




    Or Cinnamon in general.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: Opensuse 13.1 GNOME - Nautilus file manager (main window) doesn't show/use window themes...

    Quote Originally Posted by dutchglory View Post
    Nautilus file manager (main window) doesn't show/use window themes... even when set a theme with gnome tweak tool
    Well, that's client-side window decorations for you, which GNOME chose to implement/use/force.

    Here's how it looks in KDE: (kwin ignores CSD and shows its own window decoration anyway)

    But this causes a lot of headache for KDE as well, especially in combination with the newer GNOME 3.12.
    The KDE developers filed a lot of bugs against GNOME already because of this.
    See here f.e. for a discussion about this:
    http://lists.kde.org/?l=kde-core-dev...5056904742&w=2

    Here's a blog post from one of the main kwin developers from 2010 already about this:
    http://blog.martin-graesslin.com/blo...w-decorations/

    maybe there's a way to set this but i don't know...
    AFAIK, there isn't.

    made a bug-report for this here
    I suppose you should better report this to GNOME directly.
    This is no openSUSE-specific issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •