Results 1 to 3 of 3

Thread: Mariadb - unable to connect because socket file name is in uppercase character.

  1. #1
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,031

    Default Mariadb - unable to connect because socket file name is in uppercase character.

    Hello.

    I could not connect to mariadb by script because pid file name are generated by system in uppercase character.

    How to solve this.

    Any help is welcome.
    Thanks for helping. JCD
    __________

    server leap 15-- ASUS g75vw KDE leap 42.3 -- ASUS g750JZ KDE leap 42.3 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  2. #2
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,031

    Default Re: Mariadb - unable to connect because socket file name is in uppercase character.

    Solved case.

    pid File name is generated in upper case somewhere in my.cnf

    Thank you for helping.
    Thanks for helping. JCD
    __________

    server leap 15-- ASUS g75vw KDE leap 42.3 -- ASUS g750JZ KDE leap 42.3 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  3. #3

    Default Re: Mariadb - unable to connect because socket file name is in uppercase character.

    Quote Originally Posted by jcdole View Post
    I could not connect to mariadb by script because pid file name are generated by system in uppercase character.
    ???
    How did you install MariaDB and how are you starting it?

    The openSUSE init script should specify a pid file with lower case characters.
    This is line #261 of that script:
    Code:
            pid_file=/var/run/mysql/mysqld.pid
    You can specify/override the pid file name in /etc/my.cnf and /etc/my.cnf.d/ though (with the option "pid-file ="), so have a look there.
    Last edited by wolfi323; 29-Jul-2014 at 14:53.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •