Hi all,

I have an opensuse 13.1 minimal server (no gui). I want to install Tomcat on this, but zypper tries to install 145 packages, most of which are gui-based.

Code:
zypper in -D tomcat
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 145 NEW packages are going to be installed:
  PackageKit-gstreamer-plugin PackageKit-gtk3-module apache-commons-collections apache-commons-daemon apache-commons-logging
  at-spi2-atk-common at-spi2-atk-gtk2 at-spi2-core bundle-lang-gnome-en crimson ecj fuse gcr-data gcr-prompter gcr-viewer
  gdk-pixbuf-lang gdk-pixbuf-query-loaders gnome-icon-theme gnome-icon-theme-extras gnome-icon-theme-symbolic gnome-online-accounts
  gptfdisk gstreamer gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-plugins-base gtk2-branding-openSUSE gtk2-data
  gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk2-metatheme-adwaita
  gtk2-theming-engine-adwaita gtk2-tools gtk3-branding-openSUSE gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut
  gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-metatheme-adwaita gtk3-theming-engine-adwaita gtk3-tools gvfs gvfs-backend-afc
  gvfs-backends gvfs-fuse hicolor-icon-theme hicolor-icon-theme-branding-openSUSE hunspell hunspell-tools jakarta-commons-dbcp
  jakarta-commons-pool jakarta-commons-pool-tomcat5 java-1_7_0-openjdk javapackages-tools libFLAC8 libXcomposite1 libXevie1
  libXtst6 libXv1 libaspell15 libatasmart4 libatk-1_0-0 libatk-bridge-2_0-0 libatspi0 libavahi-client3 libavahi-common3
  libavahi-glib1 libbluetooth3 libbluray1 libcairo-gobject2 libcdda_interface0 libcdda_paranoia0 libcdio14 libcdio_cdda1
  libcdio_paranoia1 libcolord2 libebl1 libenchant1 libexif12 libgck-1-0 libgcr-3-1 libgdk_pixbuf-2_0-0 libgeoclue0 libgif6
  libgoa-1_0-0 libgoa-backend-1_0-1 libgphoto2-6 libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstinterfaces-0_10-0
  libgstpbutils-1_0-0 libgstreamer-0_10-0 libgstreamer-1_0-0 libgstriff-1_0-0 libgsttag-1_0-0 libgstvideo-1_0-0 libgthread-2_0-0
  libgtk-2_0-0 libgtk-3-0 libgvfscommon0 libharfbuzz-icu0 libjson-glib-1_0-0 liblockdev1 liblua5_2 libmtp9 libogg0 libopenobex1
  liborc-0_4-0 libpulse0 librest0 libsecret-1-0 libsndfile1 libsoup-2_4-1 libspeex1 libtcnative-1-0 libtelepathy-glib0 libtheora0
  libudisks2-0 libvisual libvorbis0 libvorbisenc2 libwayland-cursor0 libwebkitgtk-3_0-0 libwebkitgtk3-lang libwebp4 libxkbcommon0
  libxslt-tools lockdev log4j lua metatheme-adwaita-common obex-data-server systemtap systemtap-runtime tomcat tomcat-el-2_2-api
  tomcat-jsp-2_2-api tomcat-lib tomcat-servlet-3_0-api udisks2 xerces-j2-xml-apis

The following 26 recommended packages were automatically selected:
  PackageKit-gstreamer-plugin bundle-lang-gnome-en gcr-viewer gdk-pixbuf-lang gnome-online-accounts gtk2-branding-openSUSE
  gtk2-data gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk3-branding-openSUSE
  gtk3-immodule-amharic gtk3-immodule-inuktitut gtk3-immodule-thai gtk3-immodule-vietnamese gvfs gvfs-backend-afc gvfs-backends
  gvfs-fuse hunspell-tools libtcnative-1-0 libwebkitgtk3-lang obex-data-server systemtap udisks2

145 new packages to install.
Overall download size: 48.6 MiB. After the operation, additional 141.5 MiB will be used.
Continue? [y/n/? shows all options] (y):
Anything obvious I'm missing?

Thanks.