Results 1 to 4 of 4

Thread: KDE4 Cover Switch Effect on OS13.1 stopped working

  1. #1

    Default KDE4 Cover Switch Effect on OS13.1 stopped working

    I'm not sure what happened to break it, but for some reason my "Cover Switch Effect" stopped working on the KDE4 provided with OS13.1. I don't know if this is a 3D graphics problem, or something else. The problem may have started when I was fiddling with the Desktop Effects trying to fix a problem I was having where new windows were opening behind others, including dialog popups.

    Any ideas? I'm not sure the "Defaults" button actually sets everything to defaults.

  2. #2

    Default Re: KDE4 Cover Switch Effect on OS13.1 stopped working

    Are the desktop effects activated?

    Verify that the Cover switch is actually enabled in Desktop Effects->All Effects.

    Check that "Composite type" is set to OpenGL (2.0 or higher) in Desktop Effects->Advanced (Qt graphics system should be set to "Raster").

    And check also that the "Task Switcher" is actually set to "Cover Switch" in "Window Behavior"->"Task Switcher".

    If that all doesn't help, please post which graphics card/driver you are actually using, and the output of:
    Code:
    glxinfo | grep render
    (you might have to install Mesa-demo-x first to get output)

  3. #3

    Default Re: KDE4 Cover Switch Effect on OS13.1 stopped working

    Quote Originally Posted by wolfi323 View Post
    Are the desktop effects activated?

    Verify that the Cover switch is actually enabled in Desktop Effects->All Effects.

    Check that "Composite type" is set to OpenGL (2.0 or higher) in Desktop Effects->Advanced (Qt graphics system should be set to "Raster").

    And check also that the "Task Switcher" is actually set to "Cover Switch" in "Window Behavior"->"Task Switcher".

    If that all doesn't help, please post which graphics card/driver you are actually using, and the output of:
    Code:
    glxinfo | grep render
    (you might have to install Mesa-demo-x first to get output)
    Profanity! PROFANITY! PROFANITY! The problem was that I checked

    Kickoff->Applications->Configure Desktop->Workspace Appearance and Behavior->Desktop Effects->All Effects->Cover Switch
    but didn't select
    Kickoff->Applications->Configure Desktop->Workspace Appearance and Behavior->Window Behavior->Task Switcher->Main->Visualization->Cover Switch

    Apparently both of those have to be selected in order for the feature to work.

    I have OpenGL 3.1 and Native selected, and it seems to work.

    Thanks for the suggestions. I learned something from them.

  4. #4

    Default Re: KDE4 Cover Switch Effect on OS13.1 stopped working

    Quote Originally Posted by hattons View Post
    Apparently both of those have to be selected in order for the feature to work.

    Yes.

    The first one is for enabling/disabling the effect itself.
    The second one is to configure how the task switcher actually should look like (there are of course more options than just "Cover Effect" or not "Cover Effect"...). You could also configure two different looks there, the second/alternative one is used for a different key combination.

    I have OpenGL 3.1 and Native selected, and it seems to work.
    You should set the Qt graphics system to "Raster" instead.
    "Native" does work, but "Raster" should give much better performance.
    Last edited by wolfi323; 28-Jul-2014 at 09:01.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •