Results 1 to 3 of 3

Thread: wlan funktioniert nach Kernel update nicht mehr!

  1. #1

    Default wlan funktioniert nach Kernel update nicht mehr!

    Hallo,
    vor ca 2 Wochen hatte ich mit dem Rechner eine normales Update gefahren. Ziemlich zum Ende brach plötzlich die Verbindung zum SuSE-Server ab. Das Update lief aber bis zum Ende. Seitdem ist das Wlan weg. Ich benutze jetzt den Lan Anschluss. Folgende Abfragen habe ich zur Ursachenfindung beigelegt:

    linux-6u6s:/home/margit # /sbin/lspci -nnk
    00:00.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD/ATI] RS480/RS482/RS485 Host Bridge [1002:5950] (rev 10)
    Subsystem: Dell Device [1028:01f5]
    00:01.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] RC4xx/RS4xx PCI Bridge [int gfx] [1002:5a3f]
    Kernel modules: shpchp
    00:05.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] RC4xx/RS4xx PCI Express Port 2 [1002:5a37]
    Kernel driver in use: pcieport
    Kernel modules: shpchp
    00:06.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] RC4xx/RS4xx PCI Express Port 3 [1002:5a38]
    Kernel driver in use: pcieport
    Kernel modules: shpchp
    00:12.0 SATA controller [0106]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 Non-Raid-5 SATA [1002:4380]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: ahci
    Kernel modules: ahci
    00:13.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI0) [1002:4387]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: ohci-pci
    Kernel modules: ohci_pci
    00:13.1 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI1) [1002:4388]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: ohci-pci
    Kernel modules: ohci_pci
    00:13.2 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI2) [1002:4389]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: ohci-pci
    Kernel modules: ohci_pci
    00:13.3 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI3) [1002:438a]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: ohci-pci
    Kernel modules: ohci_pci
    00:13.4 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI4) [1002:438b]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: ohci-pci
    Kernel modules: ohci_pci
    00:13.5 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB Controller (EHCI) [1002:4386]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: ehci-pci
    Kernel modules: ehci_pci
    00:14.0 SMBus [0c05]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller [1002:4385] (rev 13)
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: piix4_smbus
    Kernel modules: i2c_piix4, sp5100_tco
    00:14.1 IDE interface [0101]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 IDE [1002:438c]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: pata_atiixp
    Kernel modules: pata_atiixp, pata_acpi, ata_generic
    00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) [1002:4383]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
    00:14.3 ISA bridge [0601]: Advanced Micro Devices, Inc. [AMD/ATI] SB600 PCI to LPC Bridge [1002:438d]
    Subsystem: Dell Device [1028:01f5]
    00:14.4 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge [1002:4384]
    00:18.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
    00:18.1 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
    00:18.2 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
    00:18.3 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
    Kernel driver in use: k8temp
    Kernel modules: k8temp
    01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RS482M [Mobility Radeon Xpress 200] [1002:5975]
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: radeon
    Kernel modules: radeonfb, radeon
    05:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
    Subsystem: Dell Wireless 1390 WLAN Mini-Card [1028:0007]
    Kernel driver in use: b43-pci-bridge
    Kernel modules: ssb, wl
    08:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: b44
    Kernel modules: b44
    08:01.0 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 19)
    Subsystem: Dell Device [1028:01f5]
    Kernel driver in use: sdhci-pci
    Kernel modules: sdhci_pci
    08:01.1 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 01)
    Subsystem: Dell Dell Inspiron 1501 [1028:01f5]
    Kernel driver in use: sdhci-pci
    Kernel modules: sdhci_pci


    linux-6u6s:/home/margit # rpm -qa broadcom-*
    broadcom-wl-6.30.223.141-8.1.i586
    broadcom-wl-kmp-default-6.30.223.141_k3.11.10_11-2.9.i586
    broadcom-wl-kmp-default-6.30.223.141_k3.11.10_17-3.2.i586
    linux-6u6s:/home/margit # uname -a
    Linux linux-6u6s.site 3.11.10-17-default #1 SMP Mon Jun 16 15:28:13 UTC 2014 (fba7c1f) i686 athlon i386 GNU/Linux
    linux-6u6s:/home/margit #

    Kann mir jemand helfen?!

  2. #2

    Default Re: wlan funktioniert nach Kernel update nicht mehr!

    Quote Originally Posted by diethn16 View Post
    Hallo,
    vor ca 2 Wochen hatte ich mit dem Rechner eine normales Update gefahren. Ziemlich zum Ende brach plötzlich die Verbindung zum SuSE-Server ab. Das Update lief aber bis zum Ende. Seitdem ist das Wlan weg. Ich benutze jetzt den Lan Anschluss.
    Die Verbindung zum SuSE-Server brach ab, oder die ganze Internet-Verbindung?

    Sollte eigentlich nicht passieren. Das Installieren der Updates ändert ja im Prinzip nichts am laufenden System.

    Funktionierts, wenn du im Boot-Menü den alten Kernel bootest? (Erweiterte Optionen bzw. Advanced Options)

    Folgende Abfragen habe ich zur Ursachenfindung beigelegt:

    linux-6u6s:/home/margit # /sbin/lspci -nnk
    ...
    05:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
    Subsystem: Dell Wireless 1390 WLAN Mini-Card [1028:0007]
    Kernel driver in use: b43-pci-bridge
    Kernel modules: ssb, wl
    ...
    Tja, wie man sieht wird als "Kernel driver" b43-pci-bridge statt wl verwendet, obwohl das "wl" Modul scheinbar gefunden wird.

    linux-6u6s:/home/margit # rpm -qa broadcom-*
    broadcom-wl-6.30.223.141-8.1.i586
    broadcom-wl-kmp-default-6.30.223.141_k3.11.10_11-2.9.i586
    broadcom-wl-kmp-default-6.30.223.141_k3.11.10_17-3.2.i586
    linux-6u6s:/home/margit # uname -a
    Linux linux-6u6s.site 3.11.10-17-default #1 SMP Mon Jun 16 15:28:13 UTC 2014 (fba7c1f) i686 athlon i386 GNU/Linux
    linux-6u6s:/home/margit #
    Hm, schaut eigentlich ok aus.
    Probier mal speziell "broadcom-wl" neu zu installieren, das sollte verhindern, dass die anderen Treiber geladen werden.
    "zypper in -f broadcom-wl" oder in YaST rechts-klick auf das Paket und "Unbedingt aktualisieren" auswählen.
    Falls das nichts hilft, deinstalliere mal beide "broadcom-wl-kmp-default" Pakete komplett, und installiere das aktuelle dann erneut.

    Andererseits wird deine WLAN Karte auch vom mitgelieferten "b43" Treiber unterstützt, du brauchst also den proprietären wl Treiber nicht unbedingt.
    Um den Standard-Treiber zu nutzen, solltest du die broadcom-wl-* Pakete deinstallieren und stattdessen "b43-firmware" installieren. (die Firmware ist notwendig damit der Treiber funktioniert)

    Da der "b43" Treiber eben Teil des Kernel Pakets ist, sollte es auch bei Kernel-Updates keine Probleme mehr geben.
    Last edited by wolfi323; 28-Jul-2014 at 05:56.

  3. #3

    Default Re: [geloest] wlan funktioniert nach Kernel update nicht mehr!

    Hallo, ich habe broadcom-wl 3 mal deinstallieren müssen, bis alle Teile verschwunden waren. Dann habe ich die b43-firmware installiert, das Netzwerkkabel entfernt, neu gestartet und das wlan lief.
    Zu Deiner Frage, ob der SuSE-Server weg war, kann ich nur sagen, Es war der 19.07.2014, um ca. 16:00 Uhr. Ich bin mit meinem anderen Rechner auf die SuSE update Seite gegangen. Die Seite war nicht zu erreichen.
    Vielen Dank für Deine Hilfe!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •