My old gateway laptop became unstable. So I bought a new dell, and restored my 3
working Linux distros from backup tarballs:

tar --numeric-owner -xzf tarball.tgz mountpoint

After carefully editing the grub and fstab entries to reflect the new unique
LABEL={label} of the {somewhat larger} partitions on the new laptop I was able
to get all three Linux working.

antiX took a long time trying to resolve the incorrect UUID references in
the initrd before it let me boot normally. But once booted it had no
problem creating a new one, and works well. {including moc, except it
sometimes doesn't honor the "shuffle" "off" toggle.} And I had to use F6 in
the alsamixer to select "1 HDA Intel PCH" instead of the default. before I
could change the volume... Otherwise that copy of moc is working perfectly.

Mageia gave me a hard time with the initrd. But since I still had a copy of
the fstab it's installer made, I was able to grep an unzipped copy of it's
initrd for the files to edit, and rename with the values from
/dev/disk/by-uuid of the live-cd I was using to restore and edit the
filesystems with... Then with the new initrd it booted normally and everything
worked. {including moc, with the only exception that again I had to first
select the "1 HDA Intel PCH" soundcard - wish I could remember how to change
the default to "1"}

Opensuse on the other hand booted so close to normally on the first time that
I almost didn't remember to generate a new initrd. Everything worked just fine
except moc. Which prompted me to create a new initrd, moc still failed. I then
tried reinstalling moc.

zypper ref
zypper rm moc
zypper in moc

No change.

Then I did an:

zypper up

Which updated my kernel and initrd... But moc still exits with the same error.

Running the server...
Trying JACK...
Trying ALSA...
ALSA lib pcm_dmix.c:1022snd_pcm_dmix_open) unable to open slave
Trying OSS...

FATAL_ERROR: No valid sound driver

FATAL_ERROR: Server exited

BTW: I CAN play my music with Kaffeine, but I much prefer moc's clean mc like

And, oh yeah, if it matters, I'm running openbox...

Suggestions anyone???