Results 1 to 3 of 3

Thread: JDownloader and JVM error?

  1. #1

    Default JDownloader and JVM error?

    Hello everyone,
    I'm using openSUSE 13.1 x64 in Acer TimelineX 4820TG.
    I tried to install JDownloader2 for linux x64 from http://jdownloader.org/download/offline but it get error
    Unpacking JRE ...
    Preparing JRE ...
    JD2SilentSetup_x64.sh: line 217: bin/unpack200: Permission denied
    Error unpacking jar files. The architecture or bitness (32/64)
    of the bundled JVM might not match your machine.
    I has installed openjdk 1.7
    I search Google and was suggest to install 32 bit library but the pattern is missing as this topic https://forums.opensuse.org/showthre...attern-missing
    I don't know why, I already choose the x64 Jdownloader 2 setup package and check the java version
    java version "1.7.0_51"
    OpenJDK Runtime Environment (IcedTea 2.4.4) (suse-24.13.5-x86_64)
    OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)
    I tried to install Jdownloader 0.9 and I get the same error
    Eclipse, Android SDK, Libreoffice still work fine.

    Anyone help me!
    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,344
    Blog Entries
    15

    Default Re: JDownloader and JVM error?

    Hi
    How did you run the run the installer...seems to work fine here;
    Code:
     sh JD2SilentSetup_x64.sh 
    Unpacking JRE ...
    Preparing JRE ...
    Starting Installer ...
    Gnome Desktop detected
    Import proxyList
    []
    
    Then I get a popup to continue...
    
    [10/10|Priority: -2147483648]ShutdownController: start item->ShutdownEventWrapper Thread[XToolkt-Shutdown-Thread,5,system] - sun.awt.X11.XToolkit$1$1 Priority: -2147483648
    [Done:10/10
    Install completed without issue...
    Code:
     zypper se -i java
    Loading repository data...
    Reading installed packages...
    
    S | Name                           | Summary                                                                 | Type   
    --+--------------------------------+-------------------------------------------------------------------------+--------
    i | java-1_7_0-openjdk             | Java runtime environment based on OpenJDK 7 and IcedTea 7               | package
    i | java-1_7_0-openjdk-headless    | JRE based on OpenJDK 7 and IcedTea 7 without X, audio and video support | package
    i | libjavascriptcoregtk-1_0-0     | JavaScript Core Engine, GTK+ Port                                       | package
    i | libjavascriptcoregtk-3_0-0     | JavaScript Core Engine, GTK+ Port                                       | package
    i | timezone-java                  | Timezone Descriptions                                                   | package
    i | typelib-1_0-JavaScriptCore-3_0 | JavaScript Core Engine, GTK+ Port -- Introspection bindings             | package
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: JDownloader and JVM error?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    How did you run the run the installer...seems to work fine here;
    Code:
     sh JD2SilentSetup_x64.sh 
    Unpacking JRE ...
    Preparing JRE ...
    Starting Installer ...
    Gnome Desktop detected
    Import proxyList
    []
    
    Then I get a popup to continue...
    
    [10/10|Priority: -2147483648]ShutdownController: start item->ShutdownEventWrapper Thread[XToolkt-Shutdown-Thread,5,system] - sun.awt.X11.XToolkit$1$1 Priority: -2147483648
    [Done:10/10
    Install completed without issue...
    Code:
     zypper se -i java
    Loading repository data...
    Reading installed packages...
    
    S | Name                           | Summary                                                                 | Type   
    --+--------------------------------+-------------------------------------------------------------------------+--------
    i | java-1_7_0-openjdk             | Java runtime environment based on OpenJDK 7 and IcedTea 7               | package
    i | java-1_7_0-openjdk-headless    | JRE based on OpenJDK 7 and IcedTea 7 without X, audio and video support | package
    i | libjavascriptcoregtk-1_0-0     | JavaScript Core Engine, GTK+ Port                                       | package
    i | libjavascriptcoregtk-3_0-0     | JavaScript Core Engine, GTK+ Port                                       | package
    i | timezone-java                  | Timezone Descriptions                                                   | package
    i | typelib-1_0-JavaScriptCore-3_0 | JavaScript Core Engine, GTK+ Port -- Introspection bindings             | package
    I tried to install it by using Nautilus Super User Modem not by Terminal and now it run correctly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •