Results 1 to 5 of 5

Thread: Pithos3 from OBS issues

  1. #1
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Default Pithos3 from OBS issues

    I installed Pithos3 (Pandora radio playing application) from the OBS ( http://software.opensuse.org/package...h_term=pithos3 ). Installation went fine on my openSUSE 13.1 (Gnome) instal. When I first tried to run it, nothing would come up.

    So I ran it from a terminal, so to see what messages may come up and get this:
    Code:
    > pithos
    Traceback (most recent call last):
      File "/usr/bin/pithos", line 5, in <module>
        from pkg_resources import load_entry_point
      File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 3007, in <module>
        working_set.require(__requires__)
      File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 728, in require
        needed = self.resolve(parse_requirements(requirements))
      File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 626, in resolve
        raise DistributionNotFound(req)
    pkg_resources.DistributionNotFound: pylast
    I installed pylast which allowed the program to come up. I put in my credentials and it grabbed the "Quick Mix" which it always does the first time you log in, but then I receive a pop-up windows saying
    GStreamer encountered a general stream error.
    Which plugins does Pithos3 need?

    I don't think I have any plug-ins installed
    Code:
    > rpm -qa gstreamer
    gstreamer-1.0.10-2.1.4.x86_64
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,845
    Blog Entries
    15

    Default Re: Pithos3 from OBS issues

    Hi
    I'm guessing it was python3-pylast you installed?

    Do you have the gstreamer good bad and ugly plugins installed?
    Code:
    zypper se -i gstream
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Default Re: Pithos3 from OBS issues

    I didn't even think about it at the time, but I wondered if I installed the restricted codecs. So I looked up installing restricted codecs and came across this site ( http://opensuse-community.org/ ) and installed them.

    After a reboot, it started to work! Am listening to it right now as I type this.

    Thanks for the suggestion. Sometimes it just takes the idea to spark an "a-ha" moment!
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,845
    Blog Entries
    15

    Default Re: Pithos3 from OBS issues

    On Tue 22 Jul 2014 02:26:02 AM CDT, dragonbite wrote:


    I didn't even think about it at the time, but I wondered if I installed
    the restricted codecs. So I looked up installing restricted codecs and
    came across this site ( http://opensuse-community.org/ ) and installed
    them.

    After a reboot, it started to work! Am listening to it right now as I
    type this.

    Thanks for the suggestion. Sometimes it just takes the idea to spark an
    "a-ha" moment!


    Hi
    I use the fluendo codec bundle, so never really sure of which gstreamer
    ones need installing

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-17-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,845
    Blog Entries
    15

    Default Re: Pithos3 from OBS issues

    Hi
    Just an FYI, pithos has been updated to the 1.0.0 release for openSUSE => 13.1 and now resides in GNOME:Apps. You also need python3-pylast from the devel:languagesython3 project.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •