Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Slow performance w/LO calc

  1. #1
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Slow performance w/LO calc

    I'm having serious performance problems with LibreOffice calc. It can take up to a minute to load large files (>100KB), and even with small files there are long delays switching tabs or resizing windows. I've reset Undo to 20 steps from the default 100, disabled Java, and there's a slight but not significant improvement. calc doesn't provide any information in the terminal,

    Code:
    > localc
    >
    This is a new system running oS 13.1, GNOME & KDE, 32GB RAM, AMD FX 8-core 3.8GHz. The old system, with 13.1 and 4GB RAM, didn't give me this problem. I'm using LibreOffice 4.2.5.2 from the LO stable repo, but the official version was also having these problems. Calculations are no more complex than some sumifs. Can anyone think of possible causes of this?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Slow performance w/LO calc

    On 2014-07-20 04:26, chief sealth wrote:

    > This is a new system running oS 13.1, GNOME & KDE, 32GB RAM, AMD FX
    > 8-core 3.8GHz. The old system, with 13.1 and 4GB RAM, didn't give me
    > this problem. I'm using LibreOffice 4.2.5.2 from the LO stable repo, but
    > the official version was also having these problems. Calculations are no
    > more complex than some sumifs. Can anyone think of possible causes of
    > this?


    Are you running in failsafe mode, perhaps? It uses one CPU core only.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Slow performance w/LO calc

    Quote Originally Posted by robin_listas View Post
    On 2014-07-20 04:26, chief sealth wrote:

    > This is a new system running oS 13.1, GNOME & KDE, 32GB RAM, AMD FX
    > 8-core 3.8GHz. The old system, with 13.1 and 4GB RAM, didn't give me
    > this problem. I'm using LibreOffice 4.2.5.2 from the LO stable repo, but
    > the official version was also having these problems. Calculations are no
    > more complex than some sumifs. Can anyone think of possible causes of
    > this?


    Are you running in failsafe mode, perhaps? It uses one CPU core only.
    Not from what I can tell. It's the same if I open files in nautilus, dolphin, or within LO. Where's the setting for this?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Slow performance w/LO calc

    If you were in failsafe mode you would surely know it.
    And FYI, multi core CPU's are most often running on one unless you are giving the system a need for more
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Slow performance w/LO calc

    If you want useful info on your system, I suggest installing
    kio_sysinfo

    Logout and in

    Open konqueror and in the URL bar type
    sysinfo:/

    Upon opening check the number of cores running.
    Very shortly the number will clock down to a minimal amount that reflects the overall load
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Slow performance w/LO calc

    On 2014-07-20 04:56, chief sealth wrote:

    >> Are you running in failsafe mode, perhaps? It uses one CPU core only.
    >>

    >
    > Not from what I can tell. It's the same if I open files in nautilus,
    > dolphin, or within LO. Where's the setting for this?


    It is a boot option, so you select it on grub.

    You find out by looking, for instance, at the top few lines of "top" in
    a terminal: when you press "1", you get a display of how each core is
    loaded. If you get only one entry, then you know.

    You can also look at the contents of "/proc/cpuinfo", or searching in
    "/var/log/messages" for the *last* line that contains "Kernel command line"

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  7. #7
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Slow performance w/LO calc

    Quote Originally Posted by robin_listas View Post
    On 2014-07-20 04:56, chief sealth wrote:

    >> Are you running in failsafe mode, perhaps? It uses one CPU core only.
    >>

    >
    > Not from what I can tell. It's the same if I open files in nautilus,
    > dolphin, or within LO. Where's the setting for this?


    It is a boot option, so you select it on grub.
    Ah, I thought you might be referring to a setting in LO. I haven't had any reason to boot into failsafe.

  8. #8
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Slow performance w/LO calc

    Quote Originally Posted by caf4926 View Post
    If you want useful info on your system, I suggest installing
    kio_sysinfo

    Logout and in

    Open konqueror and in the URL bar type
    sysinfo:/

    Upon opening check the number of cores running.
    Very shortly the number will clock down to a minimal amount that reflects the overall load
    All cores are active on the meters. Logging in, sysinfo:// seems to confirm this:

    Code:
    CPU Information
    Processor (CPU):   AMD FX(tm)-8300 Eight-Core Processor
      Speed:  3,300.00 MHz
      Cores:  8

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Slow performance w/LO calc

    On 2014-07-20 19:16, chief sealth wrote:

    > Ah, I thought you might be referring to a setting in LO. I haven't had
    > any reason to boot into failsafe.


    I guess so, or you would know :-)

    But I have seen it happen by accident. I also remember a case here, new
    install, normal boot apparently, where only one core was running...

    Some people try that mode to solve a video problem, and then stay in
    that mode. Later they complain of somewhat slow machine, compared to
    Windows on same machine...

    Sorry, it is was the only think I could think about to justify your
    problem. I'll try thinking something else... but for the moment, no ideas.

    On another age, I'd ask if you had bought the coprocesor cpu (x87) and
    installed it properly. But as far as I know, all x86 cpus include its
    functionality on the main chip, since... well, a decade or more.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  10. #10
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Slow performance w/LO calc

    Quote Originally Posted by robin_listas View Post

    On another age, I'd ask if you had bought the coprocesor cpu (x87) and
    installed it properly. But as far as I know, all x86 cpus include its
    functionality on the main chip, since... well, a decade or more.
    It's the factory CPU. I hope it's installed correctly!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •