Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Apper with proxy authentication error

  1. #1

    Default Apper with proxy authentication error

    Apper Software Management does not respect the system proxy configurations (/etc/sysconfig/proxy) WITH USER/PASS and the popup notifications in openSUSE check for updates periodically always show error message when try to update.

    See the error:
    "There was a (possibly temporary) problem connecting to a software origins.
    Please check the detailed error for further details.

    Download (curl) error for 'http://download.videolan.org/pub/vlc/SuSE/13.1/repodata/repomd.xml':
    Error code: HTTP response: 407
    Error message: The requested URL returned error: 407 Proxy Authentication Required
    "

    IS IT A BUG???? THE Temporary solution is disable Apper and use update only in Yast, zypper, etc! Nooo! :/

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,118

    Default Re: Apper with proxy authentication error

    Quote Originally Posted by darkliz View Post
    THE Temporary solution is disable Apper and use update only in Yast, zypper, etc! Nooo! :/
    While I am with you that it should function, I can not follow this last sentence.

    I do not have Apper installed (nor Packagekit) and I am a happy YaST > software and zypper user.
    Henk van Velden

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: Apper with proxy authentication error

    Quote Originally Posted by darkliz View Post
    Apper Software Management does not respect the system proxy configurations (/etc/sysconfig/proxy) WITH USER/PASS and the popup notifications in openSUSE check for updates periodically always show error message when try to update.
    I don't use a proxy, so it is hard for me to check.

    Given that Apper is a KDE application, it should follow the KDE proxy settings.

    When I check my KDE proxy settings, they say "No proxy", which I assume is the default. There is an option to change that to "Use system proxy configuration."

    The KDE proxy settings can be found with

    Configure Desktop --> Network Settings
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    josephkk NNTP User

    Default Re: Apper with proxy authentication error

    On Fri, 18 Jul 2014 14:56:01 GMT, hcvv <hcvv@no-mx.forums.opensuse.org>
    wrote:

    >
    >darkliz;2654692 Wrote:
    >>
    >> THE Temporary solution is disable Apper and use update only in Yast,
    >> zypper, etc! Nooo! :/

    >While I am with you that it should function, I can not follow this last
    >sentence.
    >
    >I do not have Apper installed (nor Packagekit) and I am a happy YaST >
    >software and zypper user.


    I also am a long term member of that club.

    ?-)


  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Apper with proxy authentication error

    On 2014-07-18 17:26, nrickert wrote:

    > The KDE proxy settings can be found with
    >
    > Configure Desktop --> Network Settings


    If the setting is per user, you would have to do that as root. :-?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: Apper with proxy authentication error

    Quote Originally Posted by robin_listas View Post
    If the setting is per user, you would have to do that as root. :-?
    Why? I'm not seeing any obvious reason for that.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7

    Default Re: Apper with proxy authentication error

    Quote Originally Posted by nrickert View Post
    I don't use a proxy, so it is hard for me to check.

    Given that Apper is a KDE application, it should follow the KDE proxy settings.

    When I check my KDE proxy settings, they say "No proxy", which I assume is the default. There is an option to change that to "Use system proxy configuration."

    The KDE proxy settings can be found with

    Configure Desktop --> Network Settings
    I did the tests setting the 'System Proxy' and 'KDE Proxy' and none of them solved the problem with "407 - Authentication required".
    ps.: Others KDE applications work with Proxy smoothly.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Apper with proxy authentication error

    On 2014-07-21 14:26, nrickert wrote:
    >
    > robin_listas;2655020 Wrote:
    >> If the setting is per user, you would have to do that as root. :-?

    >
    > Why? I'm not seeing any obvious reason for that.


    Well... network settings in network manager by default apply to the
    current user only. You have to specify a system connection for a global
    connection, and then you have to supply the root password.

    I don't know where the proxy settings in KDE are, in network manager or
    outside, and I don't know if they are applied to all programs, or only
    to those of the user owning the session. And apper is different than
    yast, I think it runs as user, and gets permissions for the actual
    install via policy kit.

    But if the updater runs as root, and takes settings from the session, it
    would need to adjust them as that user, ie, root.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: Apper with proxy authentication error

    Quote Originally Posted by robin_listas View Post
    Well... network settings in network manager by default apply to the
    current user only. You have to specify a system connection for a global
    connection, and then you have to supply the root password.
    That's a different issue. Proxy is done on top of the basic network connection, not as part of it.

    And apper is different than
    yast, I think it runs as user, and gets permissions for the actual
    install via policy kit.
    Apper runs as the user, and passes requests to packagekitd. Presumably, it could pass proxy information to packagekitd, though comment #7 seems to suggest that it doesn't

    But if the updater runs as root, and takes settings from the session, it
    would need to adjust them as that user, ie, root.
    That's what I don't see.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Apper with proxy authentication error

    On 2014-07-21 21:16, nrickert wrote:

    >> But if the updater runs as root, and takes settings from the session, it
    >> would need to adjust them as that user, ie, root.

    >
    > That's what I don't see.


    Well, it stands to reason. A KDE application running as root takes
    configs and settings from the settings for root, not from the user that
    did "su". I'm unsure what "KDE" does regarding "su" / "su -"
    differences, though.

    I notice that, for instance, in how dates are sorted in KDE apps when
    used as root or as user (I don't have a proxy to check). Or in the
    language used by applications (root always in English, user in Spanish).

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •