Just installed KF5 and Plasma 5 (what can I say - I'm a sucker for new shiny toys ). The problem I get is that Kwin crashes right on login.

Here is the dump:

Code:
Application: kwin_x11 (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  0x00007f5ddfd98640 in ?? ()
#6  0x00007f5df5586103 in QInternal::activateCallbacks (cb=cb@entry=QInternal::EventNotifyCallback, parameters=parameters@entry=0x7fff4a100ff0) at global/qglobal.cpp:2914
#7  0x00007f5df5779282 in QCoreApplication::notifyInternal (this=0x7fff4a1016b0, receiver=0x20530d0, event=event@entry=0x7fff4a101060) at kernel/qcoreapplication.cpp:924
#8  0x00007f5df57af47e in sendEvent (event=0x7fff4a101060, receiver=<optimized out>) at kernel/qcoreapplication.h:237
#9  QObjectPrivate::setParent_helper (this=this@entry=0x1fff150, o=o@entry=0x0) at kernel/qobject.cpp:1961
#10 0x00007f5df57afa03 in QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1033
#11 0x00007f5df57b4e19 in QSocketNotifier::~QSocketNotifier (this=0x2068710, __in_chrg=<optimized out>) at kernel/qsocketnotifier.cpp:203
#12 0x00007f5dfc546897 in qDBusRemoveWatch (watch=0x2054920, data=0x20530d0) at qdbusintegrator.cpp:312
#13 0x00007f5df466c233 in ?? () from /lib64/libdbus-1.so.3
#14 0x00007f5df466a99e in ?? () from /lib64/libdbus-1.so.3
#15 0x00007f5df466aa19 in ?? () from /lib64/libdbus-1.so.3
#16 0x00007f5df4669ea7 in ?? () from /lib64/libdbus-1.so.3
#17 0x00007f5df4655d82 in ?? () from /lib64/libdbus-1.so.3
#18 0x00007f5dfc548e0a in q_dbus_connection_close (connection=<optimized out>) at qdbus_symbols_p.h:113
#19 QDBusConnectionPrivate::closeConnection (this=0x20530d0) at qdbusintegrator.cpp:1099
#20 0x00007f5dfc53be72 in QDBusConnectionManager::~QDBusConnectionManager (this=0x7f5dfc7a6ca0 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>, __in_chrg=<optimized out>) at qdbusconnection.cpp:108
#21 0x00007f5dfc53bef9 in (anonymous namespace)::Q_QGS__q_manager::innerFunction()::Holder::~Holder() () at qdbusconnection.cpp:67
#22 0x00007f5dfd1243d9 in __run_exit_handlers () from /lib64/libc.so.6
#23 0x00007f5dfd124425 in exit () from /lib64/libc.so.6
#24 0x00007f5dfd51906f in operator() (__closure=<optimized out>) at /usr/src/debug/kwin-5.0.0/main.cpp:241
#25 call (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:502
#26 call<QtPrivate::List<>, void> (f=..., arg=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:559
#27 QtPrivate::QFunctorSlotObject<KWin::Application::start()::__lambda7, 0, QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt5/QtCore/qobject_impl.h:200
#28 0x00007f5df57a7d13 in call (a=0x7fff4a1013e0, r=0x20b04e0, this=0x209a330) at ../../src/corelib/kernel/qobject_impl.h:132
#29 QMetaObject::activate (sender=sender@entry=0x20b04e0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x0) at kernel/qobject.cpp:3666
#30 0x00007f5df57a86c7 in QMetaObject::activate (sender=sender@entry=0x20b04e0, m=m@entry=0x7f5dfa41db80 <KSelectionOwner::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x0) at kernel/qobject.cpp:3546
#31 0x00007f5dfa20e723 in KSelectionOwner::failedToClaimOwnership (this=this@entry=0x20b04e0) at /usr/src/debug/kwindowsystem-5.0.0/build/src/moc_kselectionowner.cpp:155
#32 0x00007f5dfa1f2d48 in KSelectionOwner::claim (this=0x20b04e0, force_P=<optimized out>, force_kill_P=force_kill_P@entry=true) at /usr/src/debug/kwindowsystem-5.0.0/src/kselectionowner.cpp:259
#33 0x00007f5dfd51a59a in KWin::Application::start (this=this@entry=0x7fff4a1016b0) at /usr/src/debug/kwin-5.0.0/main.cpp:286
#34 0x00007f5dfd51b82f in kdemain (argc=3, argv=0x7fff4a101828) at /usr/src/debug/kwin-5.0.0/main.cpp:537
#35 0x00007f5dfd10dbe5 in __libc_start_main () from /lib64/libc.so.6
#36 0x0000000000400891 in _start () at ../sysdeps/x86_64/start.S:122

KDE guys said it's a Qt bug and they can't do anything about it. I tried upgrading Qt to version 5.3.2 but it didn't help


So... Any suggestions of what I could do to fix it?