Page 4 of 15 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 141

Thread: KDE5

  1. #31
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,146

    Default Re: KDE5

    Thanks very much wolfi323. I tried again - using the revised plasma5-session rpm from your factory repo - and it worked fine. I now have separate kde4 & plasma5 menu entries.


    Well done & thanks for all your work and guidance.

  2. #32
    Join Date
    Jan 2013
    Location
    Porto
    Posts
    82

    Default Re: KDE5

    Quote Originally Posted by wolfi323 View Post
    Of course not.
    But what process uses the CPU?
    kd5 doesn't exist.

    I guess you mean kded5. In that case try to disable all services in Systemsettings->Startup and Shutdown->Background Services and see if that helps. Then enable them one by one to find out which one is causing it.
    This might be caused by powerdevil, I read bug reports about this even for KDE4.


    I noticed something similar during the Betas here, but it seems gone now for me. I never could get powerdevil to work back then, the config module always showed it is unable to start. I suppose that was the problem.

    Another culprit (also already reported against KDE4) might be PulseAudio, which I do not even have installed here.

    One thing I did notice today was that kwin5 used the XRender backend by default.
    This can of course also explain a higher CPU usage. So check in Systemsettings->Display and Monitor->Compositor that the Rendering backend is set to OpenGL (depends on your graphics card/driver though of course).


    Of course.
    It was never unsafe.

    Or do you want to know whether KDE 4.13 is safe to use?

    @dth2:
    The packages for Factory are available in the meantime.
    Just install kdebase4-workspace and YaST should want to switch the plasma5 packages to my versions automatically I think (you would have to allow the vendor change though).

    If you get a conflict where you cannot switch to my packages, do so manually by using the "Versions" tab.

    So the service is really kded5 not kde5, and in Systemsettings->Startup and Shutdown->Background Services, all background services are stopped. Or do you mean the Startup Apps?

    In Systemsettings->Display and Monitor->Compositor, is set to OpenGL 2.0 by default.

    I´m using Kde 4.13.3 as my main desktop, i just asked if it was unsafe or not just for precaution. So is safe to enable them again

    There was an update to Plasma 5 today but at first glance its all the same.

  3. #33

    Default Re: KDE5

    Quote Originally Posted by sumski View Post
    Depending when you tried, and which packages where used - powerdevil in principle did not load.
    Main problem was with missing KAuth DBus service configuration file (that made backlighthelper stuck, etc).
    This is valid for 'regular' KF5/Plasma5 packages, so i guess also yours.
    Yes, I branched the package(s) from KF5.

    But only those few that explicitely conflict with the KDE4 packages, mainly plasma5-desktop, plasma5-workspace, and powerdevil5.
    Other than that I use the standard KF5 packages installed to /usr.

    If you experience the same after todays update (the .conf is now whitelisted, thus installed by package), check your powerdevil5 package - it needs polkit actions in /usr (or it should just work with 4.x variant) + DBus service and configuration file (those IIRC can be out of prefix, but with a local 'override' of dirs where DBus looks, and additionally the .conf file from 4.x should do).
    My powerdevil5 package installs the polkit and dbus files to /opt/kf5. I am aware that this has no effect, but the point is to not conflict with kdebase4-workspace.
    And I have kdebase4-workspace installed in parallel which has those files in /usr/ anyway.

    So that update should not matter really.

    Other than that, iirc KAuth macros create services dependent on KAuth prefix, so check are the paths inside correct.
    Ok, I suppose that is the problem:
    My /opt/kf5/share/dbus-1/system-services/org.kde.powerdevil.backlighthelper.service contains "Exec=/opt/kf5/lib64/libexec/kauth/backlighthelper", whereas the one in /usr/share/dbus-1/system-services/ (from kdebase4-workspace) has "Exec=/usr/lib64/kde4/libexec/backlighthelper" (of course).

    So obviously the KDE4 version of backlighthelper is called and seems to cause the problems.
    Apparently this is the conflict I was looking for. I copied the kf5 version over to /usr as a test, and powerdevil starts fine according to powerdevil's KCM and qdbusviewer.

    Thanks for the hint!

    Still, I'm not sure how to "fix" that. I can't install the file to /usr of course. You mentioned an "override" for the directories DBUS looks at, I guess I'll look into that direction...
    But I'm wondering whether this can be overridden during login, via envvars f.e.
    I wouldn't want to do it system-wide, as that would break KDE4's powermanagement I suppose and thus defeat the whole purpose of those packages.

    Well, if I don't find a solution, I'm thinking of just turning powerdevil5 into a dummy package that doesn't install anything at all. This would prevent those problems.
    It would also remove the powermanagement settings from Systemsettings5 though of course, but well.

    This kind of problems where one of the reasons why we've gone for full install in /usr for 'standard' packages.
    Yeah, I thought so.
    Well, my purpose is just to provide a way for users to take a glance at the new Plasma 5 without having to uninstall KDE4 packages.
    Actually mostly because I myself prefer to have it that way.

    Thanks for _your_ work on this with the earlier KDE:Unstable:Frameworks packages btw, I took the inspiration and some scripts (kf5.sh, macros.kf5) from there, at least partly.

    As a sidenote, KF5's plasma5-session package has this in plasma5.desktop:
    Code:
    Exec=/usr/startkde
    TryExec=/usr/startkde
    I suppose it should be "/usr/bin/startkde" in both cases?

  4. #34

    Default Re: KDE5

    Quote Originally Posted by hugosyt View Post
    So the service is really kded5 not kde5, and in Systemsettings->Startup and Shutdown->Background Services, all background services are stopped. Or do you mean the Startup Apps?
    No, I meant the "Background Services".
    As I'm pretty sure now that this is indeed caused by powerdevil, try to disable "Powermanagement" in there, i.e. remove the tick and click "Apply".
    The rest can stay activated.
    You have to logout or reboot for full effect though, especially if kded5 is already stuck.

    Btw, I cannot reproduce that CPU hogging issue any more now again. Does it happen every time for you?

    I´m using Kde 4.13.3 as my main desktop, i just asked if it was unsafe or not just for precaution. So is safe to enable them again
    Yes.
    It's the purpose of my packages to not conflict with KDE4, regardless whether you use the standard repos only or the KDE:Current repo.
    I am using KDE:Current (and Extras) myself.

    Btw, I added KScreen2 now to my repo as well.
    If you install that, you get the "Display Configuration" entry in "Display and Monitor" back.

  5. #35
    Join Date
    Feb 2011
    Location
    Zagreb, Croatia
    Posts
    120

    Default Re: KDE5

    Quote Originally Posted by wolfi323 View Post
    Yes, I branched the package(s) from KF5.

    But only those few that explicitely conflict with the KDE4 packages, mainly plasma5-desktop, plasma5-workspace, and powerdevil5.
    Other than that I use the standard KF5 packages installed to /usr.


    My powerdevil5 package installs the polkit and dbus files to /opt/kf5. I am aware that this has no effect, but the point is to not conflict with kdebase4-workspace.
    And I have kdebase4-workspace installed in parallel which has those files in /usr/ anyway.

    So that update should not matter really.
    I meant the update of libKF5Auth5 package
    Without /etc/dbus-1/system.d/org.kde.kf5auth.conf, DBus rejects any caller to org.kde.kf5auth interface (and every kauth helper does that)
    IOW, this part was broken with also KF:5 and KUF packages.

    Quote Originally Posted by wolfi323 View Post
    Ok, I suppose that is the problem:
    My /opt/kf5/share/dbus-1/system-services/org.kde.powerdevil.backlighthelper.service contains "Exec=/opt/kf5/lib64/libexec/kauth/backlighthelper", whereas the one in /usr/share/dbus-1/system-services/ (from kdebase4-workspace) has "Exec=/usr/lib64/kde4/libexec/backlighthelper" (of course).

    So obviously the KDE4 version of backlighthelper is called and seems to cause the problems.
    Apparently this is the conflict I was looking for. I copied the kf5 version over to /usr as a test, and powerdevil starts fine according to powerdevil's KCM and qdbusviewer.

    Thanks for the hint!
    I guess that could be resolved by sed post %cmake_kf5 call...

    Quote Originally Posted by wolfi323 View Post
    Still, I'm not sure how to "fix" that. I can't install the file to /usr of course. You mentioned an "override" for the directories DBUS looks at, I guess I'll look into that direction...
    But I'm wondering whether this can be overridden during login, via envvars f.e.
    I wouldn't want to do it system-wide, as that would break KDE4's powermanagement I suppose and thus defeat the whole purpose of those packages.
    Wrt configuration, that is afaik, only possible via .conf file in /etc/dbus-1/
    Wrt services, i think it actually even respects XDG envvars...
    So, this all might work - with 4.x conf's in place

    Quote Originally Posted by wolfi323 View Post
    Well, my purpose is just to provide a way for users to take a glance at the new Plasma 5 without having to uninstall KDE4 packages.
    Actually mostly because I myself prefer to have it that way.
    Understood
    I'm aware we'd have much more testers with this kind of setup, but we need to prepare packages for Factory, etc, so the move was imminent...

    Quote Originally Posted by wolfi323 View Post
    Thanks for _your_ work on this with the earlier KDE:Unstable:Frameworks packages btw, I took the inspiration and some scripts (kf5.sh, macros.kf5) from there, at least partly.
    Welcome, i'm glad they are usefull for something/someone else

    Quote Originally Posted by wolfi323 View Post
    As a sidenote, KF5's plasma5-session package has this in plasma5.desktop:
    Code:
    Exec=/usr/startkde
    TryExec=/usr/startkde
    I suppose it should be "/usr/bin/startkde" in both cases?
    D'oh!
    Tnx for the notice, i'm using local desktop file, so haven't noticed...
    Fixed it now

  6. #36
    Join Date
    Jan 2013
    Location
    Porto
    Posts
    82

    Default Re: KDE5

    Quote Originally Posted by wolfi323 View Post
    No, I meant the "Background Services".
    As I'm pretty sure now that this is indeed caused by powerdevil, try to disable "Powermanagement" in there, i.e. remove the tick and click "Apply".
    The rest can stay activated.
    You have to logout or reboot for full effect though, especially if kded5 is already stuck.

    Btw, I cannot reproduce that CPU hogging issue any more now again. Does it happen every time for you?


    Yes.
    It's the purpose of my packages to not conflict with KDE4, regardless whether you use the standard repos only or the KDE:Current repo.
    I am using KDE:Current (and Extras) myself.

    Btw, I added KScreen2 now to my repo as well.
    If you install that, you get the "Display Configuration" entry in "Display and Monitor" back.
    Ok so i disabled "Powermanagement" and now all looks fine and the process "kded5" is not using any CPU percentage an yes, it happened to every time

    Also, enabled the other repos again and i´m gonna try adding KScreen2.

    Thanks again.

    I´ll report new issues when possible.

  7. #37

    Default Re: KDE5

    Quote Originally Posted by sumski View Post
    I meant the update of libKF5Auth5 package
    Without /etc/dbus-1/system.d/org.kde.kf5auth.conf, DBus rejects any caller to org.kde.kf5auth interface (and every kauth helper does that)
    IOW, this part was broken with also KF:5 and KUF packages.
    Ok.
    But the powerdevil5 problem persists even after that update (when kdebase4-workspace is installed in parallel).

    I did reproduce the "kded5 uses 1 core at 100%" problem again now btw, and according to the backtrace it seems indeed to hang when starting the backlight helper (the KDE4 version):
    Code:
    #5  0x00007faaa9bc91ce in KJob::exec() () from /usr/lib64/libKF5CoreAddons.so.5
    #6  0x00007faa8f862941 in PowerDevilUPowerBackend::init() ()
    I guess that could be resolved by sed post %cmake_kf5 call...
    I don't see how.
    The paths are correct AFAICS, the problem seems to be just that the KDE4 version is used for org.kde.powerdevil.backlighthelper.service and therefore KDE4's backlighthelper.

    Wrt configuration, that is afaik, only possible via .conf file in /etc/dbus-1/
    Wrt services, i think it actually even respects XDG envvars...
    So, this all might work - with 4.x conf's in place
    With configuration I suppose you mean /etc/dbus-1/system.d/org.kde.powerdevil.backlighthelper.conf?
    That's not a problem at all, this file is exactly equal in both KDE4 and KF5 versions. So I just depend on the KDE4 version of this file present in /usr/share/ Again, the purpose of my packages is to be co-installed with KDE4. If one doesn't want to have kdebase4-workspace installed he/she should use the standard packages from KF5 instead. I might even add an explicit dependency on kdebase4-workspace...

    But the issue is about /usr/share/dbus-1/system-services/ and both powerdevil4 and powerdevil5 providing the same service "org.kde.powerdevil.backlighthelper" (with the helper executables in different paths, and KDE4's helper not working in KF5).
    At the moment I have no idea how it could be possible to tell DBUS to use the one from /opt/kf5 when logging into Plasma5 (i.e. set the standard_system_servicedirs to prefer /opt/kf5/...) and the one from /usr/share otherwise. AFAICS from a quick glimpse through the documentation, you can only set this in /etc/dbus-1/system.conf or /etc/dbus-1/system.conf.local (and maybe /etc/dbus-1/system.conf.d/, but would it be possible to make this conditional on the desktop session?).


    I do of course prepend the /opt/kf5/ places to the XDG vars.
    Everything else seems to be working as it should so far.

    Well, anyway. This is not really a big issue in my eyes, especially regarding the scope of those packages. Only that possible CPU hog is annoying, but that should be prevented by disabling the powermanagement service in Systemsettings5.
    I will work around that in one way or the other...
    Last edited by wolfi323; 18-Jul-2014 at 16:26.

  8. #38
    Join Date
    Feb 2011
    Location
    Zagreb, Croatia
    Posts
    120

    Default Re: KDE5

    Quote Originally Posted by wolfi323 View Post
    I don't see how.
    The paths are correct AFAICS, the problem seems to be just that the KDE4 version is used for org.kde.powerdevil.backlighthelper.service and therefore KDE4's backlighthelper.
    yes, you're right, i've mixed up yours, and previous issues

    Quote Originally Posted by wolfi323 View Post
    With configuration I suppose you mean /etc/dbus-1/system.d/org.kde.powerdevil.backlighthelper.conf?
    yep, and that's why i meant that this could go OK - if one could also force service in /opt

    Quote Originally Posted by wolfi323 View Post
    But the issue is about /usr/share/dbus-1/system-services/ and both powerdevil4 and powerdevil5 providing the same service "org.kde.powerdevil.backlighthelper" (with the helper executables in different paths, and KDE4's helper not working in KF5).
    At the moment I have no idea how it could be possible to tell DBUS to use the one from /opt/kf5 when logging into Plasma5 (i.e. set the standard_system_servicedirs to prefer /opt/kf5/...) and the one from /usr/share otherwise. AFAICS from a quick glimpse through the documentation, you can only set this in /etc/dbus-1/system.conf or /etc/dbus-1/system.conf.local (and maybe /etc/dbus-1/system.conf.d/, but would it be possible to make this conditional on the desktop session?).
    Correct, that would be the tricky part. I haven't really investigated this while packages where in /opt, as somehow the KF5 variants of services got started 'automagically', e.g. kuiserver5, etc. Though i might indeed had /etc/dbus-1/system.conf.local at the time...
    According to http://blog.martin-graesslin.com/blo...pps-in-prefix/ it looks the enviroment is not really looked up.
    I would maybe, either: patch powerdevil so it doesn't tries to start the helper, try to rename it (i wouldn't see an issue in this, as others also would have similar problems as well - if not worse due to QtDBus segfaults with kauth helpers), ship a kded5rc with PowerDevil disabled by default...

    But as you say:
    Quote Originally Posted by wolfi323 View Post
    I do of course prepend the /opt/kf5/ places to the XDG vars.
    Everything else seems to be working as it should so far.

    Well, anyway. This is not really a big issue in my eyes, especially regarding the scope of those packages. Only that possible CPU hog is annoying, but that should be prevented by disabling the powermanagement service in Systemsettings5.
    I will work around that in one way or the other...
    is not that big deal, especially once you know why

  9. #39

    Default Re: KDE5

    Quote Originally Posted by sumski View Post
    I would maybe, either: patch powerdevil so it doesn't tries to start the helper, try to rename it (i wouldn't see an issue in this, as others also would have similar problems as well - if not worse due to QtDBus segfaults with kauth helpers), ship a kded5rc with PowerDevil disabled by default...
    Surprisingly, moving powerdevil5's backlighthelper.service file to /usr/share (and replacing KDE4's one) didn't show any negative effect with KDE4's powermanagement...
    But then, my system doesn't have any backlights at all, so I cannot test this stuff.

    Anyway, I went with renaming the backlighthelper service now to org.kde.powerdevil5.backlighthelper, and installing those dbus/polkit files to /etc and /usr to not have to mess around with the system search paths. (I could install the whole package to /usr now, but didn't bother)

    Thank you, sumski, for your valuable input!

    @hugosyt:
    Could you try to enable the powermanagement service again after you updated the package?
    Please check whether you still see kded5 using one CPU core, and whether the "Power Management" config module in Systemsettings5 works now.

  10. #40
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,146

    Default Re: KDE5

    The "Power Management" config settings works fine after updating the package (using factory). Before updating the rpm the config setting menu was broken.

Page 4 of 15 FirstFirst ... 2345614 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •