Page 11 of 15 FirstFirst ... 910111213 ... LastLast
Results 101 to 110 of 141

Thread: KDE5

  1. #101

    Default Re: KDE5

    Quote Originally Posted by google01103 View Post
    Just double checked and it is your package installed, pretty sure I installed it by selecting your plasma-session5 package and Yast did the rest. Could it be the plasma5-session-envscript wasn't installed for some reason?
    Not really.
    plasma5-session-envscript is required by plasma5-session, so it will be installed unless you taboo it and tell YaST to "break xxx by ignoring some of its dependencies".

    But if you wouldn't have it, you wouldn't even be able to start the Plasma 5 session (if you have my plasma5-workspace installed).
    And your path wouldn't be set like you posted it in the KDE forums thread. ("/opt/kf5/bin:/usr/lib64/qt5/bin:/opt/kf5:....")

    Something like that could happen if the wrong arch of plasma-session-envscript is installed (e.g. the 32bit package on a 64bit system).
    This would set the LD_LIBRARY_PATH wrong, i.e. /opt/kf5/lib/ instead of /opt/kf5/lib64/, which would prevent the libraries to be found.
    And if just kglobalaccel5 was the wrong arch, it wouldn't work either.
    But according to the things you posted in the KDE forum thread, this cannot be the reason in your case.

    Maybe something might reset/overwrite the LD_LIBRARY_PATH during login (/etc/bashrc*, /etc/profile*, or its siblings in $HOME e.g.)?

    Do you have problems with starting other KF5 applications from my repo as well?
    What is your LD_LIBRARY_PATH actually set to after logging in to the Plasma 5 session?
    Code:
    echo $LD_LIBRARY_PATH
    One thing I noticed right now:
    In the KDE thread, you posted the error message when trying to start kglobalaccel5:
    https://forum.kde.org/viewtopic.php?...123893#p325146
    The shell prompt is '#' in the post, which normally is root's prompt.
    If you try to run kglobalaccel5 as root in the user's Plasma 5 session, the environment will _not_ be setup correctly, so the error message would actually be expected.
    This of course wouldn't explain the original problem of the shortcuts KCM not working. Or did you run that as root in a user's Plasma 5 session?

  2. #102

    Default Re: KDE5

    Quote Originally Posted by wolfi323 View Post
    One thing I noticed right now:
    In the KDE thread, you posted the error message when trying to start kglobalaccel5:
    https://forum.kde.org/viewtopic.php?...123893#p325146
    The shell prompt is '#' in the post, which normally is root's prompt.
    If you try to run kglobalaccel5 as root in the user's Plasma 5 session, the environment will _not_ be setup correctly, so the error message would actually be expected.
    This of course wouldn't explain the original problem of the shortcuts KCM not working. Or did you run that as root in a user's Plasma 5 session?
    please ignore the '#' as when I copied I didn't copy the prompt so I just used the '#' as a demarcation - dumb but true

    so, stupidly, I removed all the Plasma5 packages and started fresh with the Frameworks5, your and the QT5 repo and of course it wouldn't start, looking at the errors it seemed changing to the QT5.4 (from QT5) repo would help and it did and didn't - now I get a pointer but a black screen and a bit of dependency heck in Yast, relevant error might be:

    kdeinit5: preparing to launch '/opt/kf5/bin/plasmashell'
    /opt/kf5/bin/plasmashell: error while loading shared libraries: libKF5Screen.so.5: cannot open share
    d object file: No such file or directory
    Yast heck is see image:
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  3. #103

    Default Re: KDE5

    Quote Originally Posted by google01103 View Post
    please ignore the '#' as when I copied I didn't copy the prompt so I just used the '#' as a demarcation - dumb but true
    Ok, I actually thought so, but still wanted to mention it. It could have been the cause of the problem...

    so, stupidly, I removed all the Plasma5 packages and started fresh with the Frameworks5, your and the QT5 repo and of course it wouldn't start, looking at the errors it seemed changing to the QT5.4 (from QT5) repo would help and it did and didn't - now I get a pointer but a black screen and a bit of dependency heck in Yast, relevant error might be:
    Yes, upgrading to Qt5.4 should be done.

    What are you trying to do in YaST that you get that dependency errors though?
    Did you really add the KDE:Frameworks5 repo? YaST doesn't seem to find libKF5Screen5-5.1.1, only the 5.1.0 from standard 13.2 (which would also force it to install Plasma 5.1.0 from 13.2 which conflicts with KDE4).
    Please post your repo list:
    Code:
    zypper lr -d

  4. #104

    Thumbs up Re: KDE5

    Quote Originally Posted by wolfi323 View Post
    Ok, I actually thought so, but still wanted to mention it. It could have been the cause of the problem...


    Yes, upgrading to Qt5.4 should be done.

    What are you trying to do in YaST that you get that dependency errors though?
    Did you really add the KDE:Frameworks5 repo? YaST doesn't seem to find libKF5Screen5-5.1.1, only the 5.1.0 from standard 13.2 (which would also force it to install Plasma 5.1.0 from 13.2 which conflicts with KDE4).
    Please post your repo list:
    Code:
    zypper lr -d
    I was using the unstable repo (prior to my upgrade to 13.2 it appears) http://download.opensuse.org/reposit...openSUSE_13.2/

    so now I am able to start Plasma5 again

    of course global shortcuts aren't working,
    Couldn't start kglobalaccel from org.kde.kglobalaccel.service: QDBusError("org.freedesktop.DBus.Error.ServiceUnknown", "The name org.kde.kglobalaccel was not provided by any .service files")
    Failed to connect to the kglobalaccel daemon QDBusError("org.freedesktop.DBus.Error.NameHasNoOwner", "Could not get owner of name 'org.kde.kglobalaccel': no such name")
    thanks, for both the help with my self inflicted wounds and the awesome work on the repo
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  5. #105

    Default Re: KDE5

    Quote Originally Posted by google01103 View Post
    I was using the unstable repo (prior to my upgrade to 13.2 it appears) http://download.opensuse.org/reposit...openSUSE_13.2/
    Ah, well. This contains the latest unstable versions of the Frameworks (5.5.0git) and Plasma (5.1.90git) packages of course, which are not compatible to the "stable" versions (5.4.0, 5.1.1 at the moment).
    A mixture can cause all sorts of problems.

    so now I am able to start Plasma5 again
    Good!

    of course global shortcuts aren't working,
    Hm. So we're still at square one.
    I take it you still get that error about the missing library when trying to start kglobalaccel5 manually?

    What does "echo $LD_LIBRARY_PATH" say? (inside the Plasma5 session)
    And "rpm -qi plasma5-session"?

    I suppose it will work when you run this, right?
    Code:
    . /opt/kf5/share/env/kf5.sh ; kglobalaccel5
    This would mean that you have the setup script and it is working fine.

    AND OOC, do you have a full KDE4 installation?
    Maybe I overlooked something because I do have the corresponding KDE4 packages installed.
    Btw, the global shortcuts module can talk to the KDE4 version of kglobalaccel as well, so it should work inside a KDE4 session. But it will change KDE4's shortcuts then of course.

    PS: I just had another idea:
    As the service is D-BUS activated, maybe D-BUS doesn't find the service file in your case? (my packages install it to /opt/kf5/share/)
    Code:
    echo $XDG_DATA_DIRS
    But my script does add /opt/kf5/share/ to $XDG_DATA_DIRS as well.
    Your error message would indicate that it is using a wrong service file though, I think. It says "Couldn't start kglobalaccel", whereas it should actually try to start "kglobalaccel5"...
    Last edited by wolfi323; 03-Dec-2014 at 03:29.

  6. #106

    Default Re: KDE5

    Quote Originally Posted by wolfi323 View Post
    Ah, well. This contains the latest unstable versions of the Frameworks (5.5.0git) and Plasma (5.1.90git) packages of course, which are not compatible to the "stable" versions (5.4.0, 5.1.1 at the moment).
    A mixture can cause all sorts of problems.


    Good!


    Hm. So we're still at square one.
    I take it you still get that error about the missing library when trying to start kglobalaccel5 manually?

    What does "echo $LD_LIBRARY_PATH" say? (inside the Plasma5 session)
    And "rpm -qi plasma5-session"?

    I suppose it will work when you run this, right?
    Code:
    . /opt/kf5/share/env/kf5.sh ; kglobalaccel5
    This would mean that you have the setup script and it is working fine.

    AND OOC, do you have a full KDE4 installation?
    Maybe I overlooked something because I do have the corresponding KDE4 packages installed.
    Btw, the global shortcuts module can talk to the KDE4 version of kglobalaccel as well, so it should work inside a KDE4 session. But it will change KDE4's shortcuts then of course.

    PS: I just had another idea:
    As the service is D-BUS activated, maybe D-BUS doesn't find the service file in your case? (my packages install it to /opt/kf5/share/)
    Code:
    echo $XDG_DATA_DIRS
    But my script does add /opt/kf5/share/ to $XDG_DATA_DIRS as well.
    Your error message would indicate that it is using a wrong service file though, I think. It says "Couldn't start kglobalaccel", whereas it should actually try to start "kglobalaccel5"...
    I get this error when I start the Global Keyboard Shortcuts kcm within systemsettings
    the message in my previous post is from ~.xsession-errors-:1, within systemsettings it is:
    Failed to contact the KDE global shortcuts daemon
    Message: Could not get owner of name 'org.kde.kglobalaccel': no such name
    Error: org.freedesktop.DBus.Error.NameHasNoOwner
    it runs fine as expected when I run
    Code:
    . /opt/kf5/share/env/kf5.sh ; kglobalaccel5
    >rpm -qi plasma5-session
    Name : plasma5-session
    Version : 5.0.95
    Release : 45.1
    Architecture: x86_64
    Install Date: Tue 02 Dec 2014 07:40:39 PM EST
    Group : System/GUI/KDE
    Size : 18394
    License : GPL-2.0+
    Signature : RSA/SHA1, Mon 01 Dec 2014 11:32:20 AM EST, Key ID 3eb6fc6323312922
    Source RPM : plasma5-session-5.0.95-45.1.src.rpm
    Build Date : Mon 01 Dec 2014 11:31:58 AM EST
    Build Host : cloud126
    Relocations : (not relocatable)
    Vendor : obs://build.opensuse.org/home:wolfi323
    URL : http://www.kde.org/
    Summary : The KDE Session
    Description :
    This package contains the startup scripts necessary to start a KDE
    session from kdm.
    Distribution: home:wolfi323:branches:KDE:Frameworks5 / openSUSE_13.2
    > echo $LD_LIBRARY_PATH
    /opt/kf5/lib64

    > echo $XDG_DATA_DIRS
    /opt/kf5/share:/opt/kf5/share:/usr/share:/etc/opt/kde3/share:/opt/kde3/share:/opt/kf5/share
    I have a full KDE4 install

    ps - yes I need to figure out how to multi quote
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  7. #107

    Default Re: KDE5

    Quote Originally Posted by google01103 View Post
    I get this error when I start the Global Keyboard Shortcuts kcm within systemsettings
    the message in my previous post is from ~.xsession-errors-:1, within systemsettings it is:
    Yes. This says that the service is not available.
    Your previous message would suggest that not even the .service file itself is found. If I delete the kglobalaccel5 executable (so that it cannot be started) or make sure the libraries are not found (by resetting LD_LIBRARY_PATH), I get different error messages.

    >rpm -qi plasma5-session
    Ok, that's the right one. I just wanted to make sure.

    it runs fine as expected when I run
    Code:
    . /opt/kf5/share/env/kf5.sh ; kglobalaccel5
    Ok, good. We know at least that the script is available and working. But as I mentioned already, you shouldn't even be able to login to Plasma 5 otherwise when using my packages.

    > echo $LD_LIBRARY_PATH
    > echo $XDG_DATA_DIRS
    Well, I suppose you ran those after running ". /opt/kf5/share/env/kf5.sh ; kglobalaccel5" now, did you?
    That line of course ran my script and set the environment accordingly, so kglobalaccel5 did start successfully and it is to be expected that the environment is set up correctly.

    But your output does tell me something:
    > echo $XDG_DATA_DIRS
    /opt/kf5/share:/opt/kf5/share:/usr/share:/etc/opt/kde3/share:/opt/kde3/share:/opt/kf5/share
    As we can see here, the script was run twice (once on login, and once again now), because /opt/kf5/share/ is added twice at the beginning.

    > echo $LD_LIBRARY_PATH
    /opt/kf5/lib64
    But /opt/kf5/lib64 is there only _once_. I changed my script on Monday to append /opt/kf5/lib64 to LD_LIBRARY_PATH, not replace it, so it should be in there twice as well.
    This would indicate that LD_LIBRARY_PATH was indeed empty before running the script manually.

    So something must clear LD_LIBRARY_PATH during login IMNSHO.

    Does this show anything?
    Code:
    grep -R LD_LIBRARY_PATH /etc/environment /etc/bash* /etc/profile* ~/.bashrc ~/.profile
    (I hope I didn't forget anything that might set it... )

    And just to be sure that you have the latest version, can you please post your /opt/kf5/share/env/kf5.sh.

  8. #108

    Default Re: KDE5

    >grep -R LD_LIBRARY_PATH /etc/environment /etc/bash* /etc/profile* ~/.bash
    rc ~/.profile
    /etc/bash.bashrc.local:#export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/gnome/lib64
    /etc/bash.bashrc.local:#export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/kf5/lib64
    /etc/bash.bashrc.local~:export LD_LIBRARY_PATH=/opt/gnome/lib64:
    grep: /home/kde5/.bashrc: No such file or directory
    grep: /home/kde5/.profile: No such file or directory

    > cat /opt/kf5/share/env/kf5.sh
    export KF5=/opt/kf5
    export QTDIR=/usr/lib64/qt5
    export XDG_DATA_DIRS=$KF5/share:$XDG_DATA_DIRS
    export XDG_CONFIG_DIRS=$KF5/etc/xdg:$KF5/share/kde5/config:$XDG_CONFIG_DIRS
    export PATH=$KF5/bin:$QTDIR/bin:$KF5:$PATH
    export LIBEXEC_PATH=/usr/lib64/libexec/kf5:/usr/lib64/libexec:$KF5/lib64/libexec/kf5:$KF
    5/lib64/libexec
    export LD_LIBRARY_PATH=$KF5/lib64${LD_LIBRARY_PATH:+:}$LD_LIBRARY_PATH
    export QT_PLUGIN_PATH=$KF5/lib64/qt5/plugins:$KF5/lib64/qt5/plugins/kf5:$QTDIR/plugins
    export QML2_IMPORT_PATH=$KF5/lib64/qt5/qml:$QTDIR/qml
    #export XDG_DATA_HOME=$HOME/.kf5
    #export XDG_CONFIG_HOME=$HOME/.kf5
    #export XDG_CACHE_HOME=$HOME/.kf5
    export KDE_COLOR_DEBUG=1
    export QTEST_COLORED=1

    # Source kf5.sh.local if it exists
    # Put your own local changes, e.g. setting the XDG_* variables, into that file so your c
    hanges don't get lost on updates...
    test -s $KF5/share/env/kf5.sh.local && . $KF5/share/env/kf5.sh.local
    gonna logout and redo
    > echo $LD_LIBRARY_PATH & > echo $XDG_DATA_DIRS

    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  9. #109

    Default Re: KDE5

    reran these commands after re-logging in and the global keyboard shortcuts issue is still there

    > echo $LD_LIBRARY_PATH &
    [1] 1492
    /opt/kf5/lib64

    > echo $XDG_DATA_DIRS
    /opt/kf5/share:/opt/kf5/share:/usr/share:/etc/opt/kde3/share:/opt/kde3/share:/opt/kf5/sh
    are
    note: double entries might be something I cause in .bashrc
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  10. #110

    Default Re: KDE5

    Quote Originally Posted by google01103 View Post
    reran these commands after re-logging in and the global keyboard shortcuts issue is still there

    > echo $LD_LIBRARY_PATH &
    [1] 1492
    /opt/kf5/lib64

    > echo $XDG_DATA_DIRS
    /opt/kf5/share:/opt/kf5/share:/usr/share:/etc/opt/kde3/share:/opt/kde3/share:/opt/kf5/share
    Well, if those values are set without you calling the script manually, then everything should work as expected, I'd say.

    So you still get that error about the missing library when you run "kglobalaccel5" manually in a shell?
    What does
    Code:
    ldd /opt/kf5/lib64/libkdeinit5_kglobalaccel5.so
    say? Maybe just the error message is misleading, and it does actually find libkdeinit5_kglobalaccel5.so, but not some other required lib.
    And please also post the output of:
    Code:
    ldd /opt/kf5/bin/kglobalaccel5
    Maybe there's some dangling symlink somewhere else in the library path which it tries to load instead.

    Although, if it is working when running my script (or setting LD_LIBRARY_PATH) manually, this is rather unlikely I suppose.

    note: double entries might be something I cause in .bashrc
    Really? But the grep said "grep: /home/kde5/.bashrc: No such file or directory"...

    And what do you have in .bashrc exactly?
    Please note that .bashrc is run _every_ time a bash is started, so it might have unexpected side-effects.

    The duplication of /opt/kf5/share in XDG_DATA_DIRS should not cause any problem though.
    Last edited by wolfi323; 03-Dec-2014 at 09:39.

Page 11 of 15 FirstFirst ... 910111213 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •