Results 1 to 8 of 8

Thread: change boot order on dual boot w 8.1 (thinkpad x240)

  1. #1

    Default change boot order on dual boot w 8.1 (thinkpad x240)

    on a thinkpad x240 with win 8.1 (GPT) I installed OS 13.1 in a separate partition on the same SSD with Win 8.1.
    (I was impressed, how well that worked)

    to boot to OS instead of Win I have to select it via F12 during the boot process.
    when trying to change the boot order to boot by default to OS and not to WIn, I had to realize that the bios doesn't allow me to do that.
    the list of partitions in the startup menu can not be modified, stating in the bottom "excluded from boot priority"

    - is it truly not possible to boot by default to OS?
    - did I miss something?
    - should win 8.1 have been installed with MBR instead of GPT?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,191
    Blog Entries
    3

    Default Re: change boot order on dual boot w 8.1 (thinkpad x240)

    Quote Originally Posted by suse_paul View Post
    when trying to change the boot order to boot by default to OS and not to WIn, I had to realize that the bios doesn't allow me to do that.
    That's probably a peculiarity of your Thinkpad BIOS.

    On my Dell computer, I can set the boot order with:
    Code:
    # efibootmgr -v    #### to list the current boot order
    # efibootmgr -o 0002,0001    ### to change the order
    However, on my Lenovo ThinkServer, the order is back to what it was after the next reboot.

    I was able to change the order in BIOS settings for Startup. However, I do not have Windows installed, and perhaps that makes a difference.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,191
    Blog Entries
    3

    Default Re: change boot order on dual boot w 8.1 (thinkpad x240)

    Quote Originally Posted by suse_paul View Post
    to boot to OS instead of Win I have to select it via F12 during the boot process.
    when trying to change the boot order to boot by default to OS and not to WIn, I had to realize that the bios doesn't allow me to do that.
    the list of partitions in the startup menu can not be modified, stating in the bottom "excluded from boot priority"
    Okay, I have taken a second look at this. I booted my ThinkServer to the BIOS settings.

    There is a section "excluded from boot priority", but it isn't relevant. I may have moved some options to there, myself (the boot from network, for example).

    I have my system setup with CSM disabled.
    That way, the startup menu has a boot list. But there's a secondary boot list of all of the UEFI boot entries. I am able to reorder those with the "+" and "-" keys. And those set the boot order for me.

    This assumes that you did install opensuse as a UEFI booting system.

    If I later turn CSM back on, the BIOS startup options change and I do not see that list of UEFI boot entries. But it still defaults to using the first one that I had set when I had CSM disabled.

    I'm not sure if this helps. The ThinkPad BIOS settings may be a bit different from the ThinkServer settings.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: change boot order on dual boot w 8.1 (thinkpad x240)

    thanks for checking your settings

    Quote Originally Posted by nrickert View Post

    There is a section "excluded from boot priority", but it isn't relevant. I may have moved some options to there, myself (the boot from network, for example).
    how did you do that?

    Quote Originally Posted by nrickert View Post
    I have my system setup with CSM disabled.
    That way, the startup menu has a boot list. But there's a secondary boot list of all of the UEFI boot entries. I am able to reorder those with the "+" and "-" keys. And those set the boot order for me.
    I disabled CSM, but it didn't make a difference - as far as I could see


    Quote Originally Posted by nrickert View Post
    This assumes that you did install opensuse as a UEFI booting system.
    I don't know. how can I check?

    the startup section in the bios had allowed legacy and uefi.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,191
    Blog Entries
    3

    Default Re: change boot order on dual boot w 8.1 (thinkpad x240)

    Quote Originally Posted by suse_paul View Post
    how did you do that?
    That was the "*" key (on the numeric keypad), or the "/" key to reverse it. I've updated the BIOS since I did that, and I have not tested with the current BIOS.

    It won't allow me to move EFI named entries. It will allow me to move device entries.

    I disabled CSM, but it didn't make a difference - as far as I could see
    I forgot to mention that, after disabling CSM, you have to reboot back into BIOS settings to see the effect.

    With CSM enabled, the BIOS startup settings page just lists devices. With CSM disabled (and after reboot), it also lists named EFI systems (such as "opensuse").

    I don't know. how can I check?
    Look in the EFI partition. If opensuse was installed as a UEFI system, then there will be a directory "\EFI\opensuse" (relative to the beginning of the partition, and using Windows notation).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: change boot order on dual boot w 8.1 (thinkpad x240)

    Quote Originally Posted by nrickert View Post
    Look in the EFI partition. If opensuse was installed as a UEFI system, then there will be a directory "\EFI\opensuse" (relative to the beginning of the partition, and using Windows notation).
    > ll /mnt/EFI/
    total 12
    drwxr-xr-x 2 root root 4096 Jul 6 07:08 Boot
    drwxr-xr-x 3 root root 4096 Jul 6 07:39 Lenovo
    drwxr-xr-x 3 root root 4096 Jul 6 07:08 Microsoft

    I therefore assume that OS had not been installed as UEFI.
    Can influence that during installation?
    did you have secure boot enabled?

  7. #7

    Default Re: change boot order on dual boot w 8.1 (thinkpad x240)

    ok, I made it

    maybe the problem was simply that I have a german keyboard of what the bios is not aware????
    Is there somewhere a picture of a US keyboard layout, so that I can check where the "+" and "-" reside on such a keyboard?

    my way:
    via "!" I could move Windows to the list of entries that are excluded from boot priority. when I put it back again into the list via "!", it landed at the end of the list so that the opsensuse entry was in front.

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,191
    Blog Entries
    3

    Default Re: change boot order on dual boot w 8.1 (thinkpad x240)

    Quote Originally Posted by suse_paul View Post
    > ll /mnt/EFI/
    total 12
    drwxr-xr-x 2 root root 4096 Jul 6 07:08 Boot
    drwxr-xr-x 3 root root 4096 Jul 6 07:39 Lenovo
    drwxr-xr-x 3 root root 4096 Jul 6 07:08 Microsoft

    I therefore assume that OS had not been installed as UEFI.
    Can influence that during installation?
    did you have secure boot enabled?
    I have secure-boot disabled. The lenovo version doesn't like opensuse secure boot.

    The way to influence during install, is to boot the install media in UEFI mode.

    I think the default is to boot legacy mode.

    Before install, I went to the startup page in the BIOS settings. As best I recall, I left CSM enabled at that time. But I set the option to prefer UEFI. With that setting, the install media did boot in UEFI mode.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •