Results 1 to 8 of 8

Thread: Problem with assigning PATH for TexLive

  1. #1
    Join Date
    Jul 2014
    Location
    The Hague, Netherlands
    Posts
    9

    Default Problem with assigning PATH for TexLive

    So far, I've followed all steps in this tutorial:

    https://www.tug.org/texlive/quickinstall.html

    And it seems only the last Post-installation step is not yet done correctly. The tutorial advised me to execute this:

    Code:
    PATH=/usr/local/texlive/2014/bin/i386-linux:$PATH
    On my system, I should replace i386 with x68_64, if I am not mistaken by this output:

    Code:
    margreet@linux-ivul:~/Desktop/margreet/latexdocs> arch
    x86_64
    Which would make:

    Code:
    PATH=/usr/local/texlive/2014/bin/x86_64-linux:$PATH
    I have executed this command. Now, I should be able to use the latex command anywhere, to typeset a text file (or not?). I have tried to do this with the following file test.tex located at
    Code:
    /home/margreet/Desktop/margreet/latexdocs/
    The file is just a standard tryout latex file, and the content is probably not relevant to my problem. I'll post it anyway.
    Code:
    \documentclass[a4paper,12pt]{article}
    \begin{document}
    
    The foundations of the rigorous study of \emph{analysis}
    were laid in the nineteenth century, notably by the
    mathematicians Cauchy and Weierstrass. Central to the
    study of this subject are the formal definitions of
    \emph{limits} and \emph{continuity}.
    
    Let $D$ be a subset of $\bf R$ and let
    $f \colon D \to \mathbf{R}$ be a real-valued function on
    $D$. The function $f$ is said to be \emph{continuous} on
    $D$ if, for all $\epsilon > 0$ and for all $x \in D$,
    there exists some $\delta > 0$ (which may depend on $x$)
    such that if $y \in D$ satisfies
    \[ |y - x| < \delta \]
    then
    \[ |f(y) - f(x)| < \epsilon. \]
    
    One may readily verify that if $f$ and $g$ are continuous
    functions on $D$ then the functions $f+g$, $f-g$ and
    $f.g$ are continuous. If in addition $g$ is everywhere
    non-zero then $f/g$ is continuous.
    
    \end{document}
    This is the result when I try to typeset the file using either latex or pdflatex:

    Code:
    linux-ivul:/home/margreet/Desktop/margreet/latexdocs # latex test.tex
    If 'latex' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf latex
    linux-ivul:/home/margreet/Desktop/margreet/latexdocs # pdflatex test.tex
    If 'pdflatex' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf pdflatex
    I am however succesful in typesetting the .tex file from the folder where the latex 'application' is stored:

    Code:
    linux-ivul:/usr/local/texlive/2014/bin/x86_64-linux # ./latex /home/margreet/Desktop/margreet/latexdocs/test.tex
    This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=latex)
     restricted \write18 enabled.
    entering extended mode
    (/home/margreet/Desktop/margreet/latexdocs/test.tex
    LaTeX2e <2014/05/01>
    Babel <3.9k> and hyphenation patterns for 79 languages loaded.
    (/usr/local/texlive/2014/texmf-dist/tex/latex/base/article.cls
    Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
    (/usr/local/texlive/2014/texmf-dist/tex/latex/base/size12.clo)) (./test.aux)
    [1] (./test.aux) )
    Output written on test.dvi (1 page, 1508 bytes).
    Transcript written on test.log.
    linux-ivul:/usr/local/texlive/2014/bin/x86_64-linux # ./pdflatex /home/margreet/Desktop/margreet/latexdocs/test.tex
    This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdflatex)
     restricted \write18 enabled.
    entering extended mode
    (/home/margreet/Desktop/margreet/latexdocs/test.tex
    LaTeX2e <2014/05/01>
    Babel <3.9k> and hyphenation patterns for 79 languages loaded.
    (/usr/local/texlive/2014/texmf-dist/tex/latex/base/article.cls
    Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
    (/usr/local/texlive/2014/texmf-dist/tex/latex/base/size12.clo)) (./test.aux)
    [1{/usr/local/texlive/2014/texmf-dist/fonts/map/pdftex/updmap/pdftex.map}]
    (./test.aux) )</usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/c
    m/cmbx12.pfb></usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm
    /cmmi12.pfb></usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/
    cmr12.pfb></usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/cm
    sy10.pfb></usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/cmt
    i12.pfb>
    Output written on test.pdf (1 page, 50737 bytes).
    Transcript written on test.log.
    The output files go in the same folder as latex and pdflatex are where located. I would however like for the output to appear at the folder where the .tex document is stored. In my ideal world, I could type
    Code:
    latex test.tex
    or something similar in the folder containing test.tex, and have the output also appear in the same folder. Any ideas on how to approach this?
    Last edited by Merlione404; 08-Jul-2014 at 11:37. Reason: typo

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,481
    Blog Entries
    3

    Default Re: Problem with assigning PATH for TexLive

    I have not put anything tex-related on my path. Thus far, everything has worked.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default AW: Problem with assigning PATH for TexLive

    Quote Originally Posted by Merlione404 View Post
    Which would make:

    Code:
    PATH=/usr/local/texlive/2014/bin/x86_64-linux:$PATH
    I have executed this command. Now, I should be able to use the latex command anywhere, to typeset a text file (or not?).
    Where have you executed this command?
    This has only effect for the shell/terminal window where you execute it.
    You would have to add it to some startup file to become permanent, f.e. ~/.profile or ~/.bashrc, or create a file with that line in /etc/profile.d/ for system-wide effect.

    The directory seems to be correct because it works when you are inside that directory.

    Why are you installing texlive manually btw, and not just using the packages included in openSUSE?
    They would just work.
    Do you _need_ the 2014 version?

  4. #4
    Join Date
    Jul 2014
    Location
    The Hague, Netherlands
    Posts
    9

    Default Re: AW: Problem with assigning PATH for TexLive

    Quote Originally Posted by wolfi323 View Post
    Where have you executed this command?
    This has only effect for the shell/terminal window where you execute it.
    You would have to add it to some startup file to become permanent, f.e. ~/.profile or ~/.bashrc, or create a file with that line in /etc/profile.d/ for system-wide effect.

    The directory seems to be correct because it works when you are inside that directory.

    Why are you installing texlive manually btw, and not just using the packages included in openSUSE?
    They would just work.
    Do you _need_ the 2014 version?
    I executed that command at some random location. It was like black magic to me the first time I attempted it. Now I understand. Thank you, it works. At least, I would like it to have a system wide effect. What kind of file do I need to create at /etc/profile.d/ ? Does it matter what extension? and if so, which?

    No good reason why I did the manual install - I only have been using Linux since yesterday and I hadn't found out that the package was simply included in openSUSE.

  5. #5

    Default Re: Problem with assigning PATH for TexLive

    Quote Originally Posted by Merlione404 View Post
    At least, I would like it to have a system wide effect. What kind of file do I need to create at /etc/profile.d/ ? Does it matter what extension? and if so, which?
    It should have the extension .sh so that it is executed regardless of which shell you use.
    You could also use /etc/profile.local though.

    No good reason why I did the manual install - I only have been using Linux since yesterday and I hadn't found out that the package was simply included in openSUSE.
    You could just install the package texlive-latex in YaST->Software Management or run "sudo zypper in texlive-latex".

    But if you decide to do that, you should remove your manual installation:
    Code:
    rm -rf /usr/local/texlive
    rm -rf ~/.texlive*

  6. #6
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: AW: Problem with assigning PATH for TexLive

    Quote Originally Posted by Merlione404 View Post
    No good reason why I did the manual install - I only have been using Linux since yesterday and I hadn't found out that the package was simply included in openSUSE.
    Well, you have had a useful lesson. Linux distros provide everything in packages along with a package manager. So, unless you are installing something unusual, you always use the distro's packages. These are split into repositories so that you only need to use the repositories that contain the packages you want.

    Some of these repositories hold packages which are not in the standard distro and some hold updated versions of packages. You can access all the packages at software.opensuse.org and, if you select one whose repository you do not have in your list, it will be automatically added. As you appear to be an avid user of TexLive, I recommend you add http://download.opensuse.org/reposit...openSUSE_13.1/ to your list of repositories as this will often hold more recent versions of TeXLive and supporting programs than the standard repos.

  7. #7

    Default Re: Problem with assigning PATH for TexLive

    Just up to it (in the PATH) without super user privileges!

    PHP Code:
    :-#_:-#_:-#_:p_:~/Desktop/latextest> latex test.tex && pdflatex test.tex
    This is pdfTeXVersion 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=latex)
     
    restricted \write18 enabled.
    entering extended mode
    (./test.tex
    LaTeX2e 
    <2014/05/01>
    Babel <3.9k> and hyphenation patterns for 78 languages loaded.
    (/
    usr/local/texlive/2014/texmf-dist/tex/latex/base/article.cls
    Document 
    Class: article 2007/10/19 v1.4h Standard LaTeX document class
    (/
    usr/local/texlive/2014/texmf-dist/tex/latex/base/size12.clo)) (./test.aux)
    [
    1] (./test.aux) )
    Output written on test.dvi (1 page1508 bytes).
    Transcript written on test.log.
    This is pdfTeXVersion 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdflatex)
     
    restricted \write18 enabled.
    entering extended mode
    (./test.tex
    LaTeX2e 
    <2014/05/01>
    Babel <3.9k> and hyphenation patterns for 78 languages loaded.
    (/
    usr/local/texlive/2014/texmf-dist/tex/latex/base/article.cls
    Document 
    Class: article 2007/10/19 v1.4h Standard LaTeX document class
    (/
    usr/local/texlive/2014/texmf-dist/tex/latex/base/size12.clo)) (./test.aux)
    [
    1{/usr/local/texlive/2014/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
    (./
    test.aux) )</usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/c
    m
    /cmbx12.pfb></usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm
    /cmmi12.pfb></usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/
    cmr12.pfb></usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/cm
    sy10
    .pfb></usr/local/texlive/2014/texmf-dist/fonts/type1/public/amsfonts/cm/cmt
    i12
    .pfb>
    Output written on test.pdf (1 page50726 bytes).
    Transcript written on test.log.
    :-
    #_:-#_:-#_:p_:~/Desktop/latextest> 

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem with assigning PATH for TexLive

    On 2014-10-01 08:06, marioheloar wrote:
    >
    > Just up to it (in the PATH) without super user privileges!
    >
    >
    > PHP code:


    Please use plain code tags, not PHP code tags. The button labeled '#'.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •